1. njtexas's Avatar
    I noticed on previous posts/threads people bought used blackberries. Question--say, I have a 2 year plan with verizon right now (which is almost up). Am I allowed to switch phones at anytime? I guess verizon doesn't care which physical phone I have, correct?

    As per my previous post last week, I'm up for an upgrade soon. I'd like to stick with a blackberry, but I want one that not only is easy to type (for emails), but also have good internet capability (and can get apps from blackberry app world)!!

    Is it wise for me to find a used one for now until the newer BB's come out Q2/Q3 in 2011?

    Thanks
    02-27-11 07:35 PM
  2. Motorcycle Mama's Avatar
    I noticed on previous posts/threads people bought used blackberries. Question--say, I have a 2 year plan with verizon right now (which is almost up). Am I allowed to switch phones at anytime? I guess verizon doesn't care which physical phone I have, correct?
    Yes. And yes.

    As per my previous post last week, I'm up for an upgrade soon. I'd like to stick with a blackberry, but I want one that not only is easy to type (for emails), but also have good internet capability (and can get apps from blackberry app world)!!

    Is it wise for me to find a used one for now until the newer BB's come out Q2/Q3 in 2011?

    Thanks
    Yes
    02-27-11 07:38 PM
  3. tuffy100's Avatar
    Yeah I'd say get a cheap used one until devices like the new Curve & the Bold Touch come out.
    02-27-11 09:38 PM
  4. Rootbrian's Avatar
    I would wait it out. But you could easily download app world, or update your devices software.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-27-11 09:50 PM
  5. njtexas's Avatar
    I can't seem to get blackberry app world to work on my curve 8330. I see an icon for it on my BB. I click on it and then click on download...then it says after awhile that my device does not meet the system requirements that are needed to support Blackberry App World. ..Note: I have a data plan.
    02-28-11 07:56 AM
  6. Rootbrian's Avatar
    I can't seem to get blackberry app world to work on my curve 8330. I see an icon for it on my BB. I click on it and then click on download...then it says after awhile that my device does not meet the system requirements that are needed to support Blackberry App World. ..Note: I have a data plan.
    You did update to he latest device software right? App world worked on my pearl 8130, so it should work on your 8330.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-28-11 04:10 PM
LINK TO POST COPIED TO CLIPBOARD