1. idlemanbn86's Avatar
    So I know the Bold has had problems with "Unable to turn on wifi" message. Apparently I am the only Storm 2 owner that is having the same problem. I have done everything that every website says so far, include RIM support forums.

    Multiple battery pulls
    Security wipe
    OS reload (multiple times)
    Security swipe after OS reload
    Hard and soft reset

    Still, when I hit WIFI on, the box goes checked for a second and then turns off.

    I have no idea what to do now except be pissed off that I have a $400 phone that doesnt work.
    02-01-10 02:34 PM
  2. howarmat's Avatar
    that is odd....a reboot always fixes it for me when it happens. i would take the phone in and get a new one perhaps
    02-01-10 05:32 PM
  3. BCasella9189's Avatar
    Im with howarmat.... battery pull always fixes any wifi issues that I have had.... which are rare.
    02-01-10 07:56 PM
  4. Umass021's Avatar
    I have never had a wifi issue. It works every time for me.
    02-01-10 08:49 PM
  5. anon202304's Avatar
    Call Verizon they'll send you a new phone.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-01-10 09:15 PM
  6. gozirra's Avatar
    Have you tried with NO encryption turned on in your router? If so, when you enter your key, make sure you look at what you type (it shows briefly before it covers it up with an *). Its likely that the first character is being (mis)capitalized.
    02-01-10 10:38 PM
  7. idlemanbn86's Avatar
    well its not my router...i am using that right now because im using wifi through my macbook. its the wifi adapter/antenna on the phone
    02-01-10 11:35 PM
  8. JoelTruckerDude's Avatar
    I know when the S2 first released there was a problem with it missing or not having the correct service book, but I think that was resolved. Still might be something to check anyway and resend the service books.
    02-02-10 07:46 AM
  9. Shadowlore's Avatar
    One thing to note.. if you're running WPA2-AES on your wifi connection, you may run into some oddness with wifi.

    There are some chipset manufacturers that aren't using the final approved standard for AES2..

    I ran into this issue when my wife and I got our Storm2's in late November, with a Netgear WNR2000. The WNR2000 will not lock a 'hard' lock on the Storm2 if running WPA2.

    Changing the Auth type to WPA1-TKIP (less secure) or WEP (MUCH less secure) resolves the issue.

    Over the last few months, I've ran into this problem with a handful of wireless devices. Some Netgear, Linksys, and Dlink seem to have this issue... BUT not all models. Several friends have also been experiencing the same issues.. connectivity being hit or miss on some models, and rock solid on others. (6 friends currently with Storm2s, same issues)

    As always, YMMV.
    02-02-10 09:01 AM
  10. Coachbulldog's Avatar
    that is odd....a reboot always fixes it for me when it happens.
    Curious, how often does it happen?
    02-02-10 09:05 AM
  11. brillantesdv's Avatar
    never had trouble connecting to WIFI anywhere. no encryption, WPA, WPA2, WEP...all the different kinds of routers. all works.

    has to be a hardware issue. i'd bring it to verizon...
    02-02-10 09:24 AM
  12. howarmat's Avatar
    Curious, how often does it happen?
    no often, i have had it happen maybe 4-5 times in 1.5 months. it kinda happens after i uninstall something so i need to reboot anyway most times
    02-02-10 09:50 AM
  13. thegunny's Avatar
    Are you by chance on a BES? If so contact your administrator and ensure they haven't diabled wifi via IT Policy.
    02-02-10 10:00 AM
  14. Ahsai's Avatar
    I could get my wifi to work at home on my Bold 9700 but couldn't do it at the office . The ssid didn't even appear besides the word wifi on the wifi screen. Only "On" appears. The wifi works on my Bold 9000 at home and my office, all with the same settings. I am on BIS. Appreciate any help.
    02-19-10 01:45 AM
LINK TO POST COPIED TO CLIPBOARD