1. noizfx's Avatar
    I've checked the forum before and I don't think anyone encountered the issue no the Torch yet... the "internet browser/hotspot" thing doesn't apply to the Torch, and I don't think there are any other suggestions yet?

    So the problem is that my browser doesn't work on 3G which it used to, it only works by using WIFI now for some reason, however everything else still works under 3G, like BBM, Facebook etc etc, just web browsing doesn't work. I've tried Opera Mini and that doesn't work either. So pretty much all the applications that need internet access works besides web browsing.

    I'm using the Torch in Hong Kong, which they don't have the Torch yet, but the thing is, everything used to work fine! Just all of a sudden the I cannot browse the web over 3G starting from 2 days ago. I've called the carrier and they said they don't have a problem with their BIS, and they can't help much on OS6 as they don't even have the phone.

    Anyone got any ideas? Much appreciated.

    Update: I called my service provided to send the service books to me again, did that, received the notification on my phone, still the same. Everything else works, eg MSN, BBM, social feeds, etc etc, just not the browser.

    Update2: This morning I tried doing something I've done many many times again just for the heck of it - which is to log into my carrier's BIS and resend the service book and register the HRT again, but now it works! I've done that many mant times before and it never worked, don't why it's working this time. I'm guessing my carrier is upgrading or doing something to their BIS as they told me they'll be getting the Torch later this month? I don't know...
    Last edited by noizfx; 10-04-10 at 02:56 AM.
    10-02-10 01:12 AM
  2. mhg2000's Avatar
    If you have a backup, try to restore the service book.

    Method in the sticky thread "Everything works"
    10-02-10 01:59 AM
  3. noizfx's Avatar
    Yea I saw that post beforehand too, except:
    1. I do not have a previous blackberry, nor access to one at the moment.
    2. I attempted the DM6 steps but I do not see "Customs" nor "Service Books"

    Service books seem to be for phones that never worked before? But in my cases my Torch worked perfectly fine until all of a sudden the browser stopped working two days ago...
    10-02-10 05:12 AM
  4. adriandavid23's Avatar
    Hey, guys!
    I also have this problem with my phone. I use it with a carrier that does not sell this model and I was told that they can't tell that the phone is 100% compatible. Social feed is working, BBm is working but i can't browse the web and i can't setup e-mail.
    Please help!!
    Thank you!
    01-21-11 06:32 PM
LINK TO POST COPIED TO CLIPBOARD