1. mercy023's Avatar
    my phone was working fine, now ppl are saying they sending me messages and im not receiving it. they say the d for deliver never shows up. i deleted them and added them again. and they say they accepted but it still says pending and this problem is new. does anyone know whats the problem? or anyone else having this same problem?
    12-01-10 06:25 PM
  2. albee 1's Avatar
    Done a battery pull yet?

    Posted from my CrackBerry at wapforums.crackberry.com
    12-01-10 06:55 PM
  3. pkcable's Avatar
    Do you have a BB Data plan?
    12-01-10 09:43 PM
  4. Shodan775's Avatar
    Do you have a BB Data plan?
    you can only have a boostmobile BB if you sign up to the blackberry plan they have, which is 60 bucks/month and unlimited data plan/calls.

    What's funky about boostmobile is though it's claim about roaming. It says "no roaming" ...which would indicate, that they would not charge for roaming, but it's misleading. No roaming means no roaming...meaning your phone will not have service in roaming areas at all.

    For the thread starter:
    Do a battery pull and make sure you check the advanced options that your service is set to "home only" and you click the bb option button and click on "start provisioning" and wait until it finishes. Just in case.
    12-01-10 10:59 PM
  5. Laura Knotek's Avatar
    you can only have a boostmobile BB if you sign up to the blackberry plan they have, which is 60 bucks/month and unlimited data plan/calls.

    What's funky about boostmobile is though it's claim about roaming. It says "no roaming" ...which would indicate, that they would not charge for roaming, but it's misleading. No roaming means no roaming...meaning your phone will not have service in roaming areas at all.

    For the thread starter:
    Do a battery pull and make sure you check the advanced options that your service is set to "home only" and you click the bb option button and click on "start provisioning" and wait until it finishes. Just in case.
    That is correct. Boost uses Sprint's towers, since they are affiliated with Sprint. If you are in an area where you do not have Sprint service, you get no service at all. Unlike regular Sprint, which roams on VZW, Boost will not roam at all.
    12-01-10 11:11 PM
  6. albee 1's Avatar
    Yup no Roaming, but I have never "not" had a sigmal. The worst I have experienced is the non capitalized xev. And on one occasion in the mountains of Washington got just an X. It all depends on your location and your needs. And try Shodans suggestion and re provision your bb. Menu/Options/Mobile Network/Menu/Start Provisioning.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-02-10 06:39 PM
LINK TO POST COPIED TO CLIPBOARD