1. playa4real007's Avatar
    i entered the password to connect but it won't connect!!!

    my laptop and nokia connect with no problems

    anyhelp please

    my bold is unlocked
    03-02-09 01:08 AM
  2. ST79's Avatar
    Reset the wi-fi router... Do a battery pull on your bold and try connecting again..

    Welcome to CB!
    03-02-09 03:03 AM
  3. playa4real007's Avatar
    "in the network search" it says it's connected but when i use the browser it tells me cannot connect to the internet!!!

    "on the options for browser it says (Hotspot Browser) and the other choice is my provider service"
    Last edited by playa4real007; 03-02-09 at 04:09 AM.
    03-02-09 03:48 AM
  4. playa4real007's Avatar
    i can't join any wifi network

    keeps saying "unable to determine ip address" (on all networks)

    should i update my device or format it? i'm a total newbie
    03-02-09 05:47 AM
  5. Danman1043's Avatar
    Go into Manage connections, WIFI options and edit your profile. Is "Automatically obtain IP address and DNS" Ticked? it should be.
    03-02-09 07:33 AM
  6. playa4real007's Avatar
    yes it's ticked and it's not working
    03-02-09 08:51 AM
  7. playa4real007's Avatar
    i downloaded the software "update" from blackberry's website.

    can i update my bold with it "it say's it's my service provider update (Mobily in Saudi)" even if my device is bought unlocked "i don't know if it's factory unlocked or software unlocked"

    please let me know.

    thanks in advance.
    03-02-09 09:13 AM
  8. J-Mar's Avatar
    My Bold was connecting fine to my home wireless network, but at my folks' house it wouldn't connect even though it found it. I change the WiFi Selection Mode to manual and then selected my parents network and it worked that way.
    03-02-09 09:43 AM
  9. playa4real007's Avatar
    thanks but still not working!!!
    03-02-09 10:06 AM
  10. lajaro's Avatar
    This is a common problem with many routers.

    What is the make, model and firmware version?
    03-02-09 11:28 AM
  11. bt224's Avatar
    Did you reboot the router as suggested by ST?
    03-02-09 11:30 AM
  12. arch378's Avatar
    Log into the router and make sure that all the wifi spots aren't being used up, if you limited how many can connect to your wifi. Other than that, like everyone has already stated. Reboot both the router and the bold, then try connecting the wifi.
    03-02-09 11:40 AM
  13. playa4real007's Avatar
    i did all the above guys but i'm still unable to connect all other devices connects with no problems (i rebooted the router few times) nothing happened......

    anyway i think the problem is with the bold itself (as i can't connect to any other network "malls, coffee shops, my family's home ...etc")
    03-02-09 11:45 AM
  14. arch378's Avatar
    Is it a company BB???
    03-02-09 01:33 PM
  15. playa4real007's Avatar
    Is it a company BB???

    i didn't understand..

    when i bought it they told me it's a factory unlocked "blackberry Bold"

    i bought it because at my hometown provider they only have the old curve and older models
    03-02-09 02:35 PM
  16. Duramax911's Avatar
    I had the WiFi on my Bold shut off on me today and I was not able to turn it back on without pulling to battery, not sure what the issue was, but all is well now
    03-02-09 02:36 PM
  17. anon(1634494)'s Avatar
    this has happened to me before.

    i simply pulled the power on my wireless router and waited 10 secs, then plugged it back in.

    voila it worked.
    03-02-09 03:42 PM
  18. playa4real007's Avatar
    i did take of the battery and unplugged my router but nothing worked.

    even in other network it wont connect (it keeps telling me unable to obtain ip and so on). !!!

    should i update and try (will it be unlocked after update or not)? (or should i format it without updating)?

    i'm running out of ideas
    03-02-09 03:53 PM
  19. playa4real007's Avatar
    i did update the bold software and still not able to connect to wifi on any network!!!!!!!!!
    03-03-09 01:50 AM
  20. uptownken's Avatar
    I know its kind of late but try this (taken from the rim website):


    This issue is caused when message authentication code (MAC) address filtering is enabled on the Wi-Fi network, and the MAC address of the BlackBerry smartphone is not accepted.


    To resolve this issue, add the MAC address of the BlackBerry smartphone to the accepted MAC address list for the Wi-Fi network
    08-21-09 11:57 PM
  21. khrisz's Avatar
    My bold 9700 won't connect to my home wifi. It scans and finds it but fails to connect. I don't know what to do.
    05-15-10 10:43 PM