05-18-09 05:49 AM
68 123
tools
  1. kasw3670's Avatar
    nope! still no joy for me. gonna give up i think.
    01-29-09 05:49 PM
  2. mediyoga's Avatar
    This is what worked for me initially - for the first time it glowed a beautiful white . I upgraded my os to .216 and lost it! Now it connects to my wifi but does not turn white. I get only the white dash mark next to wifi when I turn it on. Yet I seem to be able to connect and work . Confirmed this by shutting off the mobile network and using a hot spot browser. I am sick of Bold.
    01-29-09 06:26 PM
  3. msaririan's Avatar
    I hear you. Fortunately for me, my problem seems to me limited to my wifi at work. Home network works just fine with auto connect.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-29-09 06:55 PM
  4. mediyoga's Avatar
    1) deleted all BB connections on my router
    2) freshly added Mac address and assigned an ip for my BB in my router
    3) BB says failed to obtain IP address!
    4) Nevertheless the wifi shows up as connected !
    5) able to browse with hot spot browser!
    6) But wifi is grey!
    7) confirmed that wifi is working by turning off radio

    Ultimately dont know whats happening!!
    Last edited by mediyoga; 01-29-09 at 07:58 PM.
    01-29-09 07:56 PM
  5. Freakyweakywoo's Avatar
    I have had a similar experience, no blackberry infrastructure and a grey wifi icon, yet I'm browsing using wifi. I have no idea how. Wifi on the bold is messed up. Mine is totally random and unreliable, I just use 3g to be honest.
    01-31-09 11:40 PM
  6. danny595's Avatar
    Ive recently had an issue similar to a majority of users of the Bold where at one point in owning the device they were able to successfully use wifi and at a later date cannot.

    The problem im specifically talking about is where you can connect to a saved wireless network, but the wifi icon never turns "bold" or white and stays gray...which means you aren't utilizing your wireless network.

    Several people have suggested battery pulls, wiping the hand held, resending service books and reconfiguring your wireless router but as I have been reading, this doesn't seem to do the trick.

    I believe i have found the solution, and i came up with the answer from another forum that i cant honestly remember now because i was so deep into the internets frantically searching for the answer i didn't pay attention. Just for the record though im not taking credit. Anyway this is what i did, and it worked:

    Make sure Wi-Fi is turned off and navigate in your settings to: Options -> Advanced Options -> Host Routing Table and highlight the wi-fi[60] item. Hit the menu button and select "Register now"

    You should get a message saying that your device was successfully registered to the network, and for me the "ATT Navigator" icon reappeared on my home screen (not sure why as i had previously hidden it)

    Anyway, I turned Wifi back on, it connected to my saved network and the wifi icon immediately lit up bright white. Seemed to do the trick.


    see if this works for you...
    Thanks for taking the time to post this. I tried it and it worked like a charm!
    02-01-09 03:56 AM
  7. duyducle's Avatar
    Hi,

    I have no "wi-fi[60] item" when I enter HRT in options. Any ideas???
    same here. my bold persistently reject any wifi connection, very annoying!
    02-01-09 10:20 AM
  8. joe79's Avatar
    this might be a stupid question, but do you have to configure or select the Hotspot browser to fully take advantage of wifi's speed while browsing the internet?

    If so, do you also have to make the Hotspot browser the default browser while on a wifi connection?

    thanks...
    02-01-09 12:51 PM
  9. NeilW's Avatar
    Ok, I've been lurking here for a while but registered because this problem is really starting to bug me!

    Until about two days ago I had no problem with the Wi-Fi on my Bold, it was connected through an Airport Extreme. I could browse the internet in Browser and was connected to BIS through the Wi-Fi. The Bold then randomly dropped the Wi-Fi connection to Blackberry Infrastructure. I can still browse the internet over Wi-Fi if i switch the radio off, but its is using 3G as its preference, and the Wi-Fi symbol is grey rather than white. In Wi-Fi diagnostics I have a red cross next to Connecting under Blackberry Infrastructure. All of the settings in the Wi-Fi section of diagnostics are ok.

    So, with that in mind, here is what i have tried so far.

    Deleted wi-fi connection and re entered all the details
    Re-registered the Wi-Fi(60) entry in host routing tables
    Battery Pulls
    Updated software from version 4.6.0.162 to 4.6.0.216 but downgraded back to the .162 after there was no change in wi-fi, in case I need support from Orange UK
    Wiped handheld and started again
    Re-sent service books from BIS

    I can successfully ping rcp.eu.blackberry.com:443 from the blackberry and also via telnet, which discounts it being a router issue. I also tested the network with my girlfriend's Bold, with the exact same contract on Orange UK and software version, and hers had no trouble connecting to BIS and the wi-fi logo turned white.

    This has got me stumped,as I think I've tried pretty much everything in this and similar threads to resolve it! I would really appreciate any advice for things to try, and if not I will be off to contact Orange UK. This is my first Blackberry and I love everything about it, just wish this would work now!

    Thanks for reading!
    Neil
    Last edited by NeilW; 02-01-09 at 01:27 PM.
    02-01-09 01:24 PM
  10. mav4life's Avatar
    I dont have the Wi-Fi(60) entry in host routing tables


    do i need a data plan for that?
    02-01-09 01:27 PM
  11. BluCheze's Avatar
    After some reading and on site experiments, it does look like you need a data plan with your voice plan. BUT! here is the trick:
    Trail 1:
    Having data services set to "OFF" the wifi did pick up my router but failed ip.
    tried several times with unencrypted and encrypted wifi, still no go
    trail 2:
    I set the data services to "on". Changed default browser to Hotspot Browser.
    searched for my router, typed the key and BOOM it connects with no problem.
    then i use the hotspot to browse the web.


    Conclusion:

    it looks like the wifi is somehow connected to the data services. Meaning even tho you dont have a data plan (me included) you still have to enable the data services just for the wifi. I know it is using my internet because the light on my router blinked constantly while i was on my BB.
    02-01-09 03:33 PM
  12. clarkeys's Avatar
    NielW - I'm in exactly the same situation as you. Until last week I had perfectly good WiFi operation including email. I left the WiFi enabled all the time as there is poor Orange coverage in my house. The WiFi icon was always bold / white when connected.

    It's now doing the grey wifi icon thing, I can browse the web via WiFi, but no connection to the Orange BIS for email. The same thing happens at work on a different WiFi network. This makes me think it is device, or Orange specific.

    I've not knowingly changed anything on my device, so wondered if Orange had changed settings to prevent BIS connection via WiFi?

    I've tried the same tricks as you, pulled from a number of forums....

    Deleted wi-fi connection and re entered all the details
    Re-registered the Wi-Fi(60) entry in host routing tables several times
    Battery Pulls
    Re-sent service books from BIS
    Updated to latest device firmware

    All with no change. I can see in the WiFi diagnostics that the device is not getting a connection to the Blackberry infrastructure via WiFi, but no idea why this is the case. Pinging the IP address and DNS lookup of the addresses it's trying to use all work perfectly.

    I'm thinking of calling Orange too, but doubtful whoever I speak to will be able to offer anything useful ;-)

    Did you find anything further? Anyone else with the same problem using Orange UK?

    Very frustrating........
    02-02-09 12:44 PM
  13. davidb55's Avatar
    Hi guys,

    I am an Orange customer, and I too started suffering this greyed-out wifi problem a few days ago. I can date it pretty accurately as sometime last week, between the 26th and 30th Jan (I spend weekends in a cottage without Orange coverage where I rely on a wifi router to get BBM and emails on the Blackberry - it worked on Monday 26th am, and didn't on Friday 30th at 5pm...).

    I am using 216 at the mo, though have also tried 217. Don't think it's OS related. Have done battery pulls, router resets, deleting router entries on BBerry. And as it's happening on two routers from different manufacturers, I now think it may indeed be an Orange issue. Who shall we holler at??

    David B.
    02-02-09 03:40 PM
  14. TheBlade's Avatar
    I don't know -- I do have a data plan.
    02-02-09 06:43 PM
  15. Dvx67's Avatar
    My wifi worked fine for 2 days but now the icon has disappeared. I tried re-enabling it and the tip mentioned here and shut down/restart but no luck. Any ideas?

    Posted from my CrackBerry at wapforums.crackberry.com
    02-02-09 09:28 PM
  16. Dvx67's Avatar
    Update... Tried battery pull, still nothing. So I scanned for networks and it started working. Problem solved but why did it shut down wifi? Any easier way to turn it back on?

    Posted from my CrackBerry at wapforums.crackberry.com
    02-02-09 09:51 PM
  17. clarkeys's Avatar
    NeilW and Davidb55,

    This sounds like an issue with the Orange service to me as we all have the same problem independent of handset or WiFi connection. Maybe they have knowingly disabled this part of the service to protect revenues? I have an unlimited data plan, so that would be a bit pointless on their part.

    My BB is provided by work, so I'll ask our IT guy to pursue with Orange. Maybe you could give their customer service a try too?
    02-03-09 05:37 AM
  18. davidb55's Avatar
    I rang Orange business support (345), described the problem, and was told that they would swap my handset tomorrow am. I keep SIM (my media card) and battery cover.... guess that means a refurb? anyway will know in less than 24 whether it is hardware or not.... More later....

    David B.
    02-03-09 11:19 AM
  19. NeilW's Avatar
    Still no change here, I'm going to take it down to the local Orange shop when the snow clears here.

    I could understand it being a change in the Orange service if I had had the same problem on Saturday with my girlfriends Bold when she visited, a couple of days after mine stopped working. I set up the wi-fi on her phone from scratch here, and it connected straight away, including the connection to Blackberry Infrastructure, white logo, everything!

    Guess it might be hardware then.

    Interested to see whether a handset swop solves the issue davidb55.

    NeilW
    02-03-09 11:56 AM
  20. davidb55's Avatar
    I will certainly report back here when I have the new handset.

    It will be interesting to see what OS version is on the machine; hopefully something a bit newer than Orange were putting out back in September or whenever they launched.

    DB.
    02-03-09 05:50 PM
  21. davidb55's Avatar
    Neil W, Clarkeys,

    No joy.

    New handset. OS 162. No wifi! Same old same old. Greyed out Wifi icon, logged onto my router, but not connecting to the BlackBerry Infrastructure...

    I rang 345 again. Got nowhere. Said I should contact my broadband supplier.

    I wiped the whole machine using JL Commander. Loaded 217. Tried again (before loading my data and apps). No joy.

    So. Where are we now? I think it is most likely to be a network problem?

    Any ideas??

    David B.
    02-04-09 07:16 AM
  22. davidb55's Avatar
    Update at 4.50pm.

    Found an old number for Orange Data support (shhh... it's 328). Spoke to someone sensible.

    They don't support the "UMA service" on the Bold. Found it was unreliable early on, and they don't support it.

    Did say that Orange and RIM are working on it.....

    He said that the 8820 was a better bet!!

    I might try going back to an earlier OS?

    Hey **. As someone said, we are not at the cutting edge, but the bleeding edge!

    DB.
    02-04-09 10:55 AM
  23. clarkeys's Avatar
    Thanks for the update David B - sounds like they've turned the facility off, or maybe didn't realise it was even operational in the first place..? Can't say I ever had any reliability issues with it when it was working.

    One aside though, I thought UMA stood for Universal Mobile Access, which is where a WiFi capable phone can use the WiFi interface to place calls etc rather than using the mobile network.

    I wouldn't have thought the handset accessing a BIS server via WiFi counted as UMA. Isn't it just standard TCP/IP to the BIS server??

    I think Orange have disabled something on their side, or there is some obscure handset configuration issue causing this. Given that it was working last week, the claim that they don't support the service is a bit dubious. Either they are talking about the wrong service, or talking cr@p.

    I guess that's a dead end then. ** Hum.
    02-04-09 01:11 PM
  24. clarkeys's Avatar
    Is it me or is this forum not happy with the word **, as in Hey ** and ** Hum. Will the asterisks get their way?

    ;-)
    02-04-09 01:14 PM
  25. NeilW's Avatar
    Thanks for the update. It was my understanding also that UMA and the connection to BIS were two separate things.

    If it is a service thing then that makes it all the more confusing. From my point of view, the fact the other Bold I tested here worked first time means that my internet connection is ok, routing is ok, and the service must be provided here?

    The only difference i can think between the two phones here was the age of the handset? Mine was purchased around mid-October and the other working model was purchased in December.

    Will try to contact Orange tomorrow and see what they have to say here.

    Neil
    02-04-09 06:32 PM
68 123
LINK TO POST COPIED TO CLIPBOARD