1. firemedictj's Avatar
    I sufficiently searched and found nothing that works so here goes...

    I have a BB Bold 9000 on AT&T with unlimited texts, and web and email. I am running OS 4.6.0.237 (platform 4.0.0.197)
    I have a Netgear WPN824v3 Wireless MIMO router for my home network. I can see the network and it says that it is my active network under Manage Connections, however it only gives me a - sign instead of a check mark. The error I get is: Unable to find the requested server, even though its google.com or crackberry.com. I have changed the channel on my home network to one that no one else in range is using. On the WiFi Diagnostics screen everthing looks good till the connecting part, where i have a red x or the - sign. It never makes it to authentication of the router or server. I have also tried designating the BB MAC address through the wireless gateway as a static IP address, but I'm not sure I did it right, but no luck the way I had it. Any ideas?

    And yes I know i can use my data plan to connect to the internet but my wifi is much faster than the 3g that att has to offer.

    I am using WPA-PSK [TKIP] for security encryption. Does BB not support this? I tried the router and BB with WEP too and no luck. But when I leave the network open with no security its connects just fine.

    Edit: After some searching on BB.com, WPA-PSK [TKIP] is supported supposedly.
    Here is what I get when I run Wi-Fi Diagnostics:

    Wi-Fi
    Current Profile: XX
    SSID: XX
    AP MAC Address: "Insert Blackberry MAC Address"
    Security Type: Pre-Shared Key (PSK)
    Association: Successful
    Authentication: Successful
    Local IP Address: 192.168.1.3
    Signal Level: -47 dBm
    Connection Data Rate: 54 Mbps
    Status: Network acquired
    Authentication Failure Reason:
    Network Type: 802.11b/g
    Network Channel: 3
    Pairwise Cipher: TKIP
    Group Cipher: TKIP
    Gateway Address: 192.168.1.1
    DHCP: Successful
    Primary DNS: 192.168.1.1
    Secondary DNS: 0.0.0.0
    DNS suffix:
    Subnet Mask: 255.255.255.0
    Server Domain Suffix:
    Certificate: Not Applicable
    Software Token: Not Applicable
    L3 Auth:

    VPN
    Current Profile:
    Concentrator Address:
    Contact: N/A
    Authentication: N/A
    Secure Device IP:
    Status: VPN profile is not found.
    Resolving Concentrator: N/A
    Concentrator IP:
    Primary DNS:
    Secondary DNS:
    DNS Suffix:
    Secure Subnet Mask:
    Retry at:
    Session Lifetime:
    Re-login at:
    Failed Login Attempts: 0
    Certificate:
    Software Token:

    BlackBerry Infrastructure
    Address Used: //xxx.xxx.xx.xx:443
    IP Used:
    Connecting: Trying...
    Authenticating router: N/A
    Authenticating server: N/A
    Last Contact At:

    I am on a blackberry specific data plan, I have also tried WEP in hex and not in hex. I'v spent numerous hours on the phone with att, blackberry and netgear. Any Ideas? PM me and I'll send you a link to a forum listing everything I have tried.
    03-03-09 09:34 PM
  2. firemedictj's Avatar
    I also tried some different settings and they are as follows.

    Wi-Fi
    Current Profile: xxxxxxxx
    SSID: xxxxxxxxx
    AP MAC Address: blackberry MAC address
    Security Type: Pre-Shared Key (PSK)
    Association: Successful
    Authentication: Successful
    Local IP Address: 192.168.1.3
    Signal Level: -42 dBm
    Connection Data Rate: 54 Mbps
    Status: Network acquired
    Authentication Failure Reason:
    Network Type: 802.11b/g
    Network Channel: 1
    Pairwise Cipher: TKIP
    Group Cipher: TKIP
    Gateway Address: 192.168.1.1
    DHCP: Successful
    Primary DNS: 4.2.2.2
    Secondary DNS: 4.2.2.1
    DNS suffix: lv.cox.net
    Subnet Mask: 255.255.255.0
    Server Domain Suffix:
    Certificate: Not Applicable
    Software Token: Not Applicable
    L3 Auth:

    VPN
    Current Profile:
    Concentrator Address:
    Contact: N/A
    Authentication: N/A
    Secure Device IP:
    Status: VPN profile is not found.
    Resolving Concentrator: N/A
    Concentrator IP:
    Primary DNS:
    Secondary DNS:
    DNS Suffix:
    Secure Subnet Mask:
    Retry at:
    Session Lifetime:
    Re-login at:
    Failed Login Attempts: 0
    Certificate:
    Software Token:

    BlackBerry Infrastructure
    Address Used: //rcp.na.blackberry.com:443
    IP Used:
    Connecting: RED X
    Authenticating router: N/A
    Authenticating server: N/A
    Last Contact At:

    And still no luck.
    03-03-09 09:35 PM
  3. bt224's Avatar
    Try rebooting your router right before you hit connect on your Bold.
    03-03-09 09:37 PM
  4. firemedictj's Avatar
    Already reset everything and started from scratch, modem, router, and a powercycle on the phone.
    03-03-09 09:44 PM
  5. papped's Avatar
    Just for kicks, you could try setting the Bold (make it a static ipaddres) to the DMZ host in your router settings.
    03-03-09 09:51 PM
  6. bt224's Avatar
    Already reset everything and started from scratch, modem, router, and a powercycle on the phone.
    Ok, just checking. Sometimes I have to reset, if I do not get the timing right it will not work. Also try a battery pull on the phone. Never hurts to try.
    03-03-09 10:04 PM
  7. firemedictj's Avatar
    I'm pretty sure that I have tried that. My printer is a wireless network printer and I have the print server set to a static IP. I tried setting the MAC address of the Blackberry to a static IP a few different times with a few different configurations, and no luck.
    03-03-09 10:07 PM
  8. arch378's Avatar
    Your BB is getting an IP from the router so that's a good sign. Does it connect when your router is wide open?
    03-03-09 10:19 PM
  9. firemedictj's Avatar
    Yea it connects when there is no security encryption on the wifi network, but as soon as I put any type of security on the network it no longer will let me browse, saying that the server was unable to be reached. Even google? come on! I have tried both security options that will still allow both of my home computers to connect as well and I have come up with no options that seem to work.
    03-03-09 10:23 PM
  10. arch378's Avatar
    Are you also using MAC Address filtering?
    I have a Netgear WPN824v2 with WPA-PSK [TKIP], and I was able to connect from OS .167, .221 .237 .241.
    What's your router's wireless settings?
    03-03-09 10:31 PM
  11. in2vibe's Avatar
    A couple thing I would try are as follows:
    Set your router to assign an IP address not using a static one.
    On the Bold open the connmection manager.
    Turn wifi on, the go down to wifi setup.
    This time choose setup manually.
    Type your exact ssid
    Select pka shared key(make sure this is the setting on your router as well)
    Enter the used key and connect.
    Give it a couple moinutes to change from - to check mark.
    Also is your wifi symbol on the main screen white or greyed out.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-04-09 07:41 AM
  12. firemedictj's Avatar
    A couple thing I would try are as follows:
    Set your router to assign an IP address not using a static one.
    On the Bold open the connmection manager.
    Turn wifi on, the go down to wifi setup.
    This time choose setup manually.
    Type your exact ssid
    Select pka shared key(make sure this is the setting on your router as well)
    Enter the used key and connect.
    Give it a couple moinutes to change from - to check mark.
    Also is your wifi symbol on the main screen white or greyed out.

    Posted from my CrackBerry at wapforums.crackberry.com
    Tried it over night to try and see if that was enough time, and nothing. The sign is greyed out, and it never turns white unless there is no security enabled.
    03-04-09 02:10 PM
  13. firemedictj's Avatar
    Are you also using MAC Address filtering?
    I have a Netgear WPN824v2 with WPA-PSK [TKIP], and I was able to connect from OS .167, .221 .237 .241.
    What's your router's wireless settings?
    I just sent you a PM
    03-04-09 03:03 PM
  14. a_silent_song's Avatar
    I had this exact same problem with a Linksys Wireless-N router. We had it set on the highest security level, but we had to go in and change it to the next highest, as my dad and I couldn't connect. Have you tried this? It worked for us.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-04-09 04:11 PM
  15. smartcarbits's Avatar
    hi
    had the same problem for a long time, one of the crackberry experts suggested resetting the router channel selector, went from auto to manual to channel 10, lasted one night
    next day selected channel 6, left on manual; now,been working ever since, every time i enter the house it connects.
    router is a netgear type.
    hope this works for you
    regards
    pete from the UK
    11-16-09 11:30 AM
  16. phive's Avatar
    FIXED!

    The fix for me was to deselect "Auto (WPA or WPA2)" and select it just to WPA on my manual wireless configuration page.

    Hope this helps!

    ~ Phive.
    03-20-10 11:07 PM
  17. chevysol's Avatar
    A couple thing I would try are as follows:
    Set your router to assign an IP address not using a static one.
    On the Bold open the connmection manager.
    Turn wifi on, the go down to wifi setup.
    This time choose setup manually.
    Type your exact ssid
    Select pka shared key(make sure this is the setting on your router as well)
    Enter the used key and connect.
    Give it a couple moinutes to change from - to check mark.
    Also is your wifi symbol on the main screen white or greyed out.

    Posted from my CrackBerry at wapforums.crackberry.com
    this might be an old thread but I just got my bold with 4.6 something updated to new .509 and my wifi wasn't working just tried what you said and boom my wifi is working again thanks.
    03-25-10 03:19 AM
LINK TO POST COPIED TO CLIPBOARD