1. rsamuel613's Avatar
    Hi Everyone

    I just got the new Balckberry Bold 9700 and for some reason difficulties to pair the blue with my Mercedes GL 550 that carries Bluetooth Module Adaptor MHI . I used to have the curve and had no problem to connect one to the other except transfering contact but I cant even map it on my cell phone...even If I activate the mercedes phone system while I m pairing the bluetooth on my phone it does not read or see the MB system that use to work on my curve.

    Can anyone help me on the process ? and if you know the answear how can I transfer succesfully contact to my car.

    Thanks.

    RS
    01-14-10 03:06 PM
  2. AZBBFAN's Avatar
    Mercedes is the worst manufacturer that exists for bluetooth in vehicles. They have a website that shows compatible phones, I would start there and make sure they have the 9700 on the list and then follow the directions they have online to prevent any problems. I am not a Mercedes hater by the way, I have been selling highline vehicles for 8 years and mercedes always has the most bluetooth problems
    01-14-10 03:08 PM
  3. AZBBFAN's Avatar
    Go here:

    Mercedes-Benz Bluetooth Connectivity

    Based on your vehicle it will tell you if the phone is compatible
    01-14-10 03:12 PM
  4. rsamuel613's Avatar
    ty I checked they have the BOLD 9000 but not mine ( 9700 ) I have no idea what should I do then ...
    01-14-10 03:53 PM
  5. anoxia187's Avatar
    whats year is ur GL ? 2007 ? I have the new 9700 with rogers, i have a ML 320 Bluetec 2009 model i have no issues connecting to bluetooth. It works great..
    01-15-10 08:58 AM
  6. rsamuel613's Avatar
    i have a 2008 gl do y know if maybe I should buy a new module?
    01-15-10 09:10 AM
  7. bonfeinberg's Avatar
    We have 2 blackberry 9700 (ATT) and new MB E550. I was able to connect one phone to car - and then 2nd phone to car - and tried to switch between them -- that didnt work -- didnt even always want to connect when you got in/out of the car. But PROBLEMS RESOLVED!

    I know you will think this the simplest craziest = but its true.
    I spent two visits at MB and read the book = and my MB techie figured this one out as he was throwing up his hands in frustration too....the last resort.

    If you too are having problems, or can connect your phone to car - but doesnt always want to connect when you get in........
    TAKE OUT PHONE BATTERY - Let phone reset and I DONT KNOW WHY but it worked on both our phones!!
    And we can do everything - auto connect - change phones as we change drivers.

    Just remember
    a) when you first pair phone to car and phone asks you if ok -- be sure to check "dont ask me again" when you say Yes.

    b) when 2 of you in car with phones, Disengage bluetooth on one of the phones (driver?) as the car does not like have both at the same time.
    04-02-10 11:03 PM
  8. bonfeinberg's Avatar
    It doesnt matter that your BB model isnt listed on Mercedes site. My dealer tells me they are two steps behind the times. My 9700 isnt listed but works perfect now -- along with my husbands. Start by taking out battery on your phone and re-boot it. It updates and made all the difference with mine.
    04-06-10 06:30 PM
  9. KleeneFotze's Avatar
    You may need to have the bluetooth module updated my mercedes.
    04-07-10 12:08 AM
  10. tomnorthshore's Avatar
    I too have this problem and found an interesting solution. It seemed that the mercedes adapter was hung up since it took 20+ seconds to pick-up and end a call. After deleting the MB paired device I also changed the Bluetooth Options to Disable the Contacts Transfer. Since I have over 3000 contacts they exceed the storage capacity of the Module. So, I figured why have this active if it doesn't work anyways. I then went and paired the MB Device using the Search method. The result is now the phone works great. My assumption is that when the phone was connecting it was struggling to sync with the Address Book function with the MB phone system (since it tries to pull up caller ID). Give it a try. Hope this helps.
    Last edited by tomnorthshore; 04-26-10 at 05:27 PM. Reason: misspelling
    04-26-10 05:26 PM
  11. bonfeinberg's Avatar
    Thanks. We solved our problems (don't know why) by just taking out batteries of bb and then linking with car bluetooth -- worked like a charm -- keeps working the way it should. 3000 contacts ???
    04-26-10 09:37 PM
LINK TO POST COPIED TO CLIPBOARD