1. The_Original_Modifier's Avatar
    Hello all, been lurking for sometime now and have finally upgraded my handset from an 8130 Pearl to a Bold 9700.

    I have been trying for hours to get it to find ANY bluetooth device, including my old Pearl. The Bluetooth is checked (enabled) under Manage Connections and has a - sign.

    I go to search for any and all devices- which were checked on both my old Pearl and the wifes new Apple iPhone. All show up and can be paired with.

    The devices I have tried pairing with are a Motorola (Motopure) H12, Plantronics 520- and a Plantronics (model number escapes me) stereo headset, And even the Pearl can connect to her iPhone. Not one of these devices shows on my 9700 during a search. I have even put the 9700 into discovery mod and nothing.

    Would anyone have other suggestions before I take it back to the store?

    Thank you,

    Mod
    04-10-10 12:47 AM
  2. jeffh's Avatar
    What do you mean,
    I go to search for any and all devices- which were checked on both my old Pearl and the wifes new Apple iPhone. All show up and can be paired with.
    That sounds like you are finding devices.
    04-10-10 08:30 AM
  3. The_Original_Modifier's Avatar
    What do you mean, That sounds like you are finding devices.

    Thank you friend for the quick reply. Sorry for not being a bit clearer, lol. Frustration got the best of me.
    On the wifes new iPhone and Pearl yes, but for the Bold 9700 no

    Mod
    Last edited by The_Original_Modifier; 04-10-10 at 08:15 PM.
    04-10-10 08:10 PM
  4. jeffh's Avatar
    Is the Bold in discoverable mode? Does it have a device address? You can see both in Options / Bluetooth / Options
    04-10-10 08:31 PM
  5. The_Original_Modifier's Avatar
    I love this fourm! I wasn't expecting that quick of a reply, lol.

    Ok This is what the Bluetooth Options screen says:

    Device Name: BlackBerry 9700
    Discoverable: Yes
    Allow Outgoing Calls: Always
    Contacts Transfer: All Entries
    LED Connection Indicator: On
    Security Level: High
    Connect On Power Up: Yes
    Device Address:30:7C:30:45:15:59
    Services: Headset, Hands free are checked, Serial Port Profile and subs are not.
    Dial Up Networking: not checked
    Audio Source: Checked
    A/V Remote Conrol Target Checked

    I hope that somewhat tells you something, I greatly appreciate you help friend.

    Mod
    04-10-10 08:44 PM
  6. jeffh's Avatar
    Depending on what you are trying to sync to, there may not be any corresponding service. If I disabled dial up networking, for example, I couldn't connect to my PC, because that's the only profile my PC supports. But you should be able to pair with your Plantronics headset.
    04-10-10 08:52 PM
  7. The_Original_Modifier's Avatar
    Many thanks for trying my friend. I greatly appreciate your assistance. Possibley could it be a bad device (9700) ?


    Mod
    04-10-10 08:55 PM
  8. jeffh's Avatar
    Possible. Did you put the Plantronics in discoverable mode and try to find it with the 9700? Did you put the 9700 in discoverable mode and try to find it with the Plantronics?
    04-10-10 09:11 PM
  9. The_Original_Modifier's Avatar
    Lol yes, I put all the devices into discoverable mode (one by one) and nothing was found unfortunately.

    Thank you,
    Mod
    04-11-10 10:39 AM
  10. jeffh's Avatar
    The only other suggestion I can think of is to enable the remaining Bluetooth functions, in case there is some unintended interaction between the modes. There's precedent for that idea. In earlier OS versions, it was impossible to maintain a Bluetooth connection if you turned off the LED. Apparently the LED function also served to keep the connection live.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-11-10 11:54 AM
  11. The_Original_Modifier's Avatar
    I thank you once again for the quick replies friend. I just tried it, and no luck, lol. I think I may have to go back to the store to see if they have any tricks up thier sleeves to possibly get it going.

    Due to a new law here in Canada, we have to use hands free devices while driving, hence no texting and no electronic devices are permitted in the drivers hands, including iPods etc. A great law and it seems to have cut down on accidents.
    Unfortunately with no working bluetooth I can't answer calls to my customers while on the road.

    I greatly appreciate your advice to say the least. Hopefully it can be figured out easily and its just something simple, I love this thing!


    Mod
    04-11-10 01:44 PM
  12. jeffh's Avatar
    One option that might be worth considering. There's a device sold here that plugs into your speaker jack and transmits thru an unused FM channel on your car radio. That supposedly gives you a nice big speaker sound. I haven't tried it yet.
    04-11-10 02:06 PM
  13. xxSullyxx's Avatar
    Not to jack you're thread, but I am having the same problem and I thought I might post inside this thread before starting a new one myself. I have a Verizon issued Tour 9630. All was well with the bluetooth up until yesterday. I did install OS 5.0 when verizon put their stamp on it, but it was working with it for a week or so, so I'm not sure if that was the problem. I downgraded back to 4.7.1.65,than 4.7.1.61 yesterday hoping to correct the bug and nothing. I didn't care for 5.0 anyhow, due to some of the bugs.

    Anyhow, I noticed the problem because it stopped linking up to either of my cars, which were paired and working a few days ago. So I tried to delete them and re-pair them and the phone can't even find the bluetooth devices in either car, or my earpiece. The phone also can't find my wifes phone, or my iMac, while her phone works perfectly with all functions. I've done battery pulls, and ripped and reinstalled OS's like ive said, and have nothing. The only thing I havent done is tried the bluetooth after an OS install, before restoring backed up stuff. But as far as i know no system stuff is backed up, just contacts and settings and the like. I've tried everything, and oddly enough, after 1 of the many battery pulls it was able to discover my earpiece, so i ran out to the car to try again, and nothing. i did another battery pull and nothing. so i deleted the LG earpiece and then tried and found my car. I then proceeded to pair the car to the phone and it worked, but won't stay connected. Tried searching for the other car, and the earpiece again and nothing. Very odd. Probably similar to what is happening to you. I don't know what to do. Bluetooth in the car is my favorite feature!
    04-12-10 11:31 AM
  14. The_Original_Modifier's Avatar
    Turns out to be a device issue. I get my new bold 9700 tomorrow and they promise all will be well. Thank you for your help it is truly and greatly appreciated.
    The staff at Aztech Communications in Barrie are wonderful to work with, they diligently worked to try and get the unit to function with the bluetooth units in store as well. After a quick call to a blackberry tech, they surmised that the units bluetooth was not functioning and tod me that the new unit will be in tomorrow morning.

    The staff tried everything that JeffH above had suggested as well. Many thanks friend for your time and patience.

    Mod
    04-12-10 04:39 PM
  15. xxSullyxx's Avatar
    Yea it seems its a hardware issue at this point for me too. The problem is, I bought my Tour on ebay like 3 months ago and Verizon won't warrantee or even repair it for a fee as far as they've told me.

    Last night, just to try another angle, i used jl cmder to qwipe the OS and the reinstalled it. From there I tried pairing before restoring my backed up file, in case something was corrupted in there. Nothing. I also tried to restore a file i found on here that was a blank bluetooth profile. Nothing. This is so annoying because I love the bluetooth. Id rather lose the internet on the darn thing! Both of my cars have the handsfreelink and now for nothing until my "new every 2" is up in 13 months.
    04-13-10 08:42 AM
  16. Babymi2009's Avatar
    Hi Everyone.
    I bought an unlocked t-mobile Bold 9700 in March from buy.com for use in Europe and West Africa where I live (my network carrier is Zain).
    Right off the bat, the phone locked me out 2 days after I set up and had been using my password. It did a security wipe and rebooted. (At this point it occurred to me that if my BB is stolen, all the thief needs to do is enter the password wrongly a maximum of 10 times which will get the phone 'security wiped' and voila! thief gets a new BB!)
    Anyway, after the security wipe, I reset my password, taking care to note the numbers I used. Not 10 minutes afterward, I was locked out again. Luckily, I was able to disable the password option. Strangely enough, it accepted the password to allow the disabling. WEIRD.
    The next problem is the Java execution illegal execution message I started getting every time I switched the phone on. This only started after the security wipe. I have tried removing the battery and sim while phone is off/on, but no luck.
    The last two problems occurred simultaneously. My Bluetooth function just stopped working. I cannot even access the options on my phone. Also, I cannot access the pictures - I can see them but that's about it. Can't scroll, send or use any of them.
    I have tried updating the software - nothing. I was going to wipe and reload but after seeing xxSullyxx's post, I wont bother. I just hope someone has a solution!
    So, I am pretty frustrated, and more so because I never wanted a BB to start with - hubby hounded me into getting one (which he paid for!)
    05-02-10 05:23 PM
LINK TO POST COPIED TO CLIPBOARD