1. jeeves86's Avatar
    Sorry if this has already been posted already, I haven't been able to find something similar.

    Since I bought my Bold 2 I've been having off and on WiFI issues. I have an N-router at home, and the BB is allowed to access it, there's no conflicts with anything else on the network, but for some reason the Blackberry will only stay connected for a little while. It doesn't matter where I am in the house, I have other things that will remain connected all of the time.

    I can however force a connect if I turn off all other connections and then simply connect with the WiFi. This seems like a glitch, because if it wasn't going to connect, it wouldn't connect at all. Is there a known fix for this glitch? Any help would be greatly appreciated.
    05-03-10 03:36 PM
  2. alextop30's Avatar
    I don't think it is that much of a glitch as it is a wifi connection error - BB does not do very well with wireless N signal (I guess RIM have no love for N) - Try downgrading the signal to mixed mode b/g/n if that is fine look and make sure the BB has the DHCP enabled from the router page. Sometimes there might be a drop on that and it has to reconnect. Check and see how many devices can be connected on to the network at any time and so on.

    Also for further help can you let us know what it says on the Diagnostics page of the Wifi settings that will be very helpful.
    05-04-10 12:24 AM
  3. jeeves86's Avatar
    Haha! Sorry for taking so long to respond, but shortly after I posted the message, I had to do some work, and when I got home I wasn't having the problem. Much as right now I don't seem to be having the problem, but it did show up....

    What I got from looking at the WiFi diagnostics was that the BB found the router, but just wasn't connecting to it. My SSID showed up, but there was a line through the box where there's usually a check or an X.

    It works right now, so it's hard to say when it will fail on me again, but I will keep you posted for sure.
    05-11-10 09:31 PM
LINK TO POST COPIED TO CLIPBOARD