1. spike_h's Avatar
    Hi

    I have recently purchased a CoPilot Mini S3 GPS receiver which works very well. (The S3 appears also to be available in several guises -CoPilot/Emtac/RightWay)

    I seem unable to store/save the pairing infomation, and every time I switch on the S3 to use it I have to delete and then add the device again.

    I have tried disabling encryption, setting 'trusted' to Yes, but no luck.

    However, if I leave the S3 on, I can power off/on the 8520 or even reboot, and the connection is retained.

    Am I missing something - the CoPilot supplier insists it is due the the Blackberry software, but my car handsfree pairs happily every time. I get the feeling that it is the S3 that is not saving the pairing info - anyone had similar problems?
    09-05-11 12:08 PM
  2. Mitsbom's Avatar
    Hello Spike. Was this issue ever resolved? I have a Garmin Nuvi 3490lmt which used to work with my blackberry bold, but all of a sudden stopped. I've tried everything to resolve, but still no luck.
    12-28-11 07:31 AM
LINK TO POST COPIED TO CLIPBOARD