1. dudus's Avatar
    Im using BlackBerry z10 stl 100-2 which i bought last August 27, then for only one week when i used to charge my phone their is always getting out in the screen saying that in order to charge faster i need to use the original charger that came in the box. What does it mean? My charger is fake even though it came from the original box.. and another thing is in my pictures icon, when i opened it their is always a black square or tiles maybe, and when i clicked it, thats the time i will see that picture.. so annoying..
    BlackBerry z10-img_00000503.png
    BlackBerry z10-img_00000504.png

    Posted via CB10
    10-17-13 09:46 AM
  2. tanko65's Avatar
    z10 blackberry phone tracker deleted photos
    10-17-13 09:47 AM
  3. fanisk's Avatar
    It has happened to me once while I was charging the phone in an old hotel.
    I suspect that this has to do with the lower voltage of the supplier and not with the phone.

    Sent from my Z 30
    10-17-13 02:16 PM
  4. 19andy91's Avatar
    Yeah I get that with offical blackberry chargers from legacy devices lol

    Posted via CB10
    10-17-13 02:37 PM
  5. si001's Avatar
    I get that only when I charge in the car, with the car charger.

    Posted via CB10
    10-17-13 03:33 PM

Similar Threads

  1. Injecting new CDMA number to Z10 STL100-4
    By manicstreet in forum BlackBerry Z10
    Replies: 27
    Last Post: 02-23-14, 11:08 PM
  2. Blackberry Z10 or Z30
    By AaronDeVante in forum Verizon Wireless
    Replies: 3
    Last Post: 12-03-13, 10:14 PM
  3. This is why I will stick with BlackBerry to the end
    By bitek in forum General BlackBerry Discussion
    Replies: 303
    Last Post: 10-22-13, 03:43 PM
  4. BlackBerry Z10 Error (8) Using FastTube
    By dudus in forum BlackBerry 10 Apps
    Replies: 1
    Last Post: 10-19-13, 12:01 AM
  5. Questions About Z10, Durability, etc.
    By mparrott in forum BlackBerry Z10
    Replies: 8
    Last Post: 10-17-13, 12:36 PM
LINK TO POST COPIED TO CLIPBOARD