1. Dennis9360's Avatar
    Hello guys,

    I am new to this forum and have just created this account for this question. Yesterday night I updated my OS system to 7.1 from 7.0, I then left it on charge for the whole night as usual and in the morning I woke up and the battery was not charged. I then paniced and realised that my Blackberry although is being connected via charger is not charging the battery. I then thought it was the OS 7.1 I quickly downgraded back to OS 7.0 and there is still no change. I've done many battery pulls, reset my phone nothing helps what can I do? I have used both old and new chargers, tried charging it via computer USB and still not working.
    03-22-12 12:07 PM
  2. glucotrol's Avatar
    This worked for me just last week when I had the same problem. Solved by removing battery and leaving battery charger plug in. Then reinserted battery with charger plug in, after 30 sec device loaded and battery charged to full power and held charge. I used the wall charger and not the USB computer charger. It might take a couple of tries to make it happen, but this worked when other solutions I tried failed.
    03-23-12 03:02 AM
LINK TO POST COPIED TO CLIPBOARD