1. Olympus's Avatar
    I have a Blackberry 9000 and a BMW 5 series. Although I can get the BlueTooth to connect, more often than not none of the contact details transfer across. Sometimes only from letter L transfer across and sometimes they all do!!!
    What can I do? Any help appreciated.
    11-25-08 05:51 AM
  2. Heresy's Avatar
    Will the bmw sync with outlook? If so just copy your contacts there then use desktop manager to sync your contacts to your blackberry

    Posted from my CrackBerry at wapforums.crackberry.com
    11-25-08 07:54 AM
  3. m5manny's Avatar
    I have a Blackberry 9000 and a BMW 5 series. Although I can get the BlueTooth to connect, more often than not none of the contact details transfer across. Sometimes only from letter L transfer across and sometimes they all do!!!
    What can I do? Any help appreciated.
    I have no problem, my Curve and my wife's Curve both sync with full upload of the address book.

    Go into the settings menu in the Idrive and delete the pairing and re-pair the phone again.

    The BMW does not sync with Outlook directly, has to be done with the Blackberry.

    Good luck.
    11-25-08 12:56 PM
  4. Olympus's Avatar
    Thanks for the reply. I have now been into the dealer and they tell me the Curve is supported by the internal BMW software but not the Bold! something to do with constant data transfer?????
    Thanks for your reply anyway.
    11-26-08 10:37 AM
  5. kmc979's Avatar
    But the Bluetooth still connects right? My friend has an x5 and she will either be getting a curve or bold this week, I'm gonna push for the bold so I can play but it might be too big for her. As long as she can connect to her Bluetooth connection via her x5 that's all she needs, she always just dials straight from her phone contact list.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-26-08 04:38 PM
  6. Olympus's Avatar
    Thats the problem. The bluetooth connect with ease. but the contacts dont transfer over to the screen. Sometimes if you switch it off then on again, the contacts appear.
    Good luck.
    11-27-08 07:07 AM
  7. slovak's Avatar
    Wow that's odd. Almost sounds like BMW ought to be the ones to fix that issue since you paid a mighty pretty penny for a 5 series. Just my $.02 worth
    11-27-08 08:01 AM
  8. m5manny's Avatar
    Even though he paid a ton of money for his 5 series and God knows i know, i have a fully decked out 550 sport that my wife has the pleasure of driving that listed for $72k, however, it's not BMW's responsibility to ensure data transfer between every cell phone with varying OS's and platforms etc. I worked for BMW for 11 years and let me tell you, there was a period 4 years ago where NO Blackberries loaded the phone book into the Idrive. They soon figured it out and with a reprogram of the Idrive OS they were up and running.

    That being said, I assume you have an 08 5Series, correct, if you do, relax, BMW just released the updated Idrive in all the new cars, that frimware should make it's way into the older versoin cars, if you have an 09 car, your next service appointment will most certainly include some kind of OS patch for different things that are constantly being upgraded. That's the wonderful part about BMW, always getting caught up with new TECH and making sure their vehicles run the most up to date firmwares.

    If your BOLD isn't working today,it will very soon. Have your dealer fill out a customer inquiry to BMW NA and they will track it when the new OS comes out, you will be notified.

    Have fun!
    11-27-08 09:58 AM
  9. jcttw's Avatar
    That does seem quite odd that it won't link. I have an 05 530i and the contacts/bluetooth sync perfectly with my BB Storm.
    12-01-08 10:08 PM
  10. gigifrench's Avatar
    I have a 750 BMW and it syncs perfectly with my Bold that I just regretfully returned today. If it syncs with a BB it will sync with the Bold. I switched over to a Curve temporarily until the Storm becomes available. My service with the Bold was terrible! Much to my dismay a great phone doesn't do me any good if I can't have great service. Check with the dealership to make sure they have updated your IDrive software. Every 6 months or so when I have my seasonal tires changed I double check on the updated IDrive software. That is where I believe your problem lies. Should the software be current in the IDrive I would exchange the Bold for a NEW ONE. I went thru 3 bolds in 30 days trying to get better service. With each one I have more icons than the last and more improved throughout. Nothing technical other than terrible service. I wish Verizon would carry the bold!!!
    Good Luck!
    12-03-08 10:49 PM
  11. Foll478trap's Avatar
    Hi, - have a 525 estate, the BB Bold connects fine with the idrive, my only tips would be
    1) Have the bluetooth on the phone enabed before entering the car.
    2) Have the BB on autoconnect
    3) Delete and re-pair the BB if necessary.

    Hope this helps

    Posted from my CrackBerry at wapforums.crackberry.com
    12-04-08 05:02 AM
  12. irajay26's Avatar
    I had similar problems connecting my Storm 9530 with a 2007 530. My phone has my company's entire contact database on it & the BMW bluetooth couldn't transfer the 3,000+ contacts. After pairing the Storm with the BMW, I went to Manage Connections/Bluetooth Options/Menu Key/Options/Contacts Transfer & selected Hotlist Only. Its worked perfectly ever since.
    04-04-10 05:48 PM
  13. canook's Avatar
    Hey there,

    Who's is your cell phone carrier? I know up here in canada, telus bb's have issues sending data thru to the car's idrive.

    Update your OS.
    Go to the dealer and see if any idrive updates are available. Could be a programming issue.

    Another thing. What OS are you running? While the phone may be supported only 1 or 2 OS' will be supported by BMW.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-05-10 10:19 AM
LINK TO POST COPIED TO CLIPBOARD