1. joshrock25's Avatar
    I have a Blackberry Curve 8530 on CricKet Wireless.

    Okay here is the problem. So everything was fine until one day I downloaded vlingo (from the blackberry app world). I used it and really didn't think of anything was wrong. Then i was like this is stupid, cause it was the free one. So I didn't think anything of it. So I deleted it.

    Then I was going to a different state so I turned of my mobile network. Then the next day I was just messing around with my phone and then BAM!!! white screen that says "App Error 523"(then underneath) "Reset". So I reset the phone.

    Then it worked and then BAM!!! white screen that says "App Error 523"(then underneath) "Reset". So I reset the phone.

    The Security Check passed 100%.

    Then I noticed that when I reset, it says "uncaught exception: Index 4 >= 4".

    So I clicked "OK"

    Then came up literally 10 pages of "Uncaught exception: ApplicationRegistry.getOrWaitFor(0x7c802477365c398 5) owner died Thread[Thread-72074240,5]"

    The last part changes every time: "Uncaught exception: ApplicationRegistry.getOrWaitFor(0x7c802477365c398 5) owner died Thread[Thread-XXXXXXXX,X]"


    So I click "OK" literally 10 times.

    Then it works and then at random times when it is working normal it will say "Uncaught exception: ApplicationRegistry.waitFor(0x7c802477365c3985)tim eout"

    Then when the screen goes black when I try to turn the screen on I get "App error 523"

    So when I was out of state I noticed that the green (answer phone) and the red (hang up phone) buttons don't work. I thought that this was normal since I turned off the mobile network.

    So I get back in town and turn on the mobile network.

    Then, I noticed that I cannot even exit applications using the red (hang up button).

    If I use the green (call button) then the phone application will not open.

    I cannot use the key numbers pad to dial.

    So I check in the menu and the phone app icon was not there.

    So I hold down the menu and scroll over to phone icon and "click", and nothing happens.

    So I go to contacts and press call on a contact and then it doesn't call.

    So i go to applications in options and noticed that the phone app is still there under core.

    If someone calls me then it just rings and rings on there phone, until it goes to voice mail for them. On my phone it shows no sign that I was ever called.

    I cannot send sms either.



    Please tell me that there is a way to solve this without actually plugging it in to the computer, because the blackberry software is not compatible with my computer.

    Is there a way to fix this without using the computer?

    Thanks for the answers.
    12-30-10 10:48 PM
  2. dehrlich01's Avatar
    Dude - wipe your phoone and start over. Definitely not normal.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-30-10 11:02 PM
  3. CASH's Avatar
    Basically you need your computer.
    12-30-10 11:13 PM
  4. Pilot Prop's Avatar
    There is a thread around here talking about how to fix things like this, try the search...I don't remember exactly how it goes but this happened to me with my 9700 a while back
    12-30-10 11:27 PM
  5. stackberry369's Avatar
    Ownner died?

    Posted from my CrackBerry at wapforums.crackberry.com
    12-30-10 11:48 PM
  6. Fret Madden's Avatar
    Try a physical battery pull, the app error 523 reset isn't going to fix anything. I'm with CASH on this one though; you're going to need a computer that can run the desktop software. You'll most likely wind up needing to reload the OS.
    12-31-10 12:18 AM
LINK TO POST COPIED TO CLIPBOARD