1. Karozu's Avatar
    Hey guys,

    When I go in the blackberry appworld app and want to download something, it brings me to the login screen and I add my email and password and try to log in but it just goes back to the login screen. I tried reinstalling it, tried another email. Is there any way to fix this? I have the blackberry curve 9300 if that helps.

    Thanks in advance
    12-05-10 01:28 PM
  2. Fubaz's Avatar
    Rumor has it BB App World is down right now.
    12-05-10 01:44 PM
  3. Karozu's Avatar
    Oh alright, do you know when it'll be up again?
    12-05-10 01:57 PM
  4. amazinglygraceless's Avatar
    App World is running fine for me.

    I think your issue is how you are trying to login. Did you actually create an account
    in App World. You can't just use any email and password, you have to make an
    account first.
    12-05-10 02:07 PM
  5. Karozu's Avatar
    I did make an account and i tried logging in and doesn't work. I even went on the site and to try to log in and it works perfectly fine.
    12-05-10 02:15 PM
  6. amazinglygraceless's Avatar
    Only thing that comes to mind is the password. If there are numbers or capital
    letters be sure you are entering them correctly.

    For instance if your p/word is 1234 and you don't hold the ALT key for each you are
    actually entering "wers"
    12-05-10 02:23 PM
  7. decypher44's Avatar
    I'm having the same problem. I can view everything, but can't get past the authentication screen.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-05-10 07:17 PM
  8. anon2100101's Avatar
    I have another VERY annoying problem with this halfhearted Appworld: Some apps aren`t offered in CB or directly MobiHand. So you are forced to purchase them over the gimmickry BB Appworld. I always pay using my paypal account which works (normaly) even at the southpole under water...but not in the BB appworld. You were conducted until you have to lock in to your paypal-account. I always pay by direct debit authority from my bank account. (To repeat it again- it works in every way!) But the native browser of the BB doesnt support the (flash)buttons of the paypal-webside and other browser (cut and paste) ask for a "number of the security code" I have to add behind my password?!? This f++++g "number of the security code" doesnt exists anywhere... So I avoid to buy over BB appworld... Have anybody the same problem or can explain what happens? :-)
    01-26-11 06:38 AM
LINK TO POST COPIED TO CLIPBOARD