1. SebasCvdB's Avatar
    Surfing around on the Internet on another forum i FINALLY found the answer for at least the Belkin N Router, i would assume it works other routers too but here we go:

    .
    Wi-Fi enabled BlackBerry smartphones cannot connect to Belkin N Wireless Routers and Belkin N1 Vision Wireless Routers

    Doc ID : KB14677
    Last Modified : 2008-01-09
    Document Type : Support


    Environment

    * BlackBerry smartphone
    * SDR149479


    Problem

    Wi-Fi enabled BlackBerry smartphones cannot connect to Belkin N Wireless Routers (Model: F5D8233-4) and Belkin N1 Vision Wireless Routers (Model: F5D8232-4). The Wi-Fi enabled BlackBerry smartphone shuts down and restarts repeatedly when attempting to connect to the Belkin wireless router.


    Resolution

    Note: The resolution to this issue may not be available from all wireless service providers.
    To resolve this issue, upgrade to BlackBerry Device Software 4.2.2.338 or later. For instructions, see KB03621.


    Additional Information

    BlackBerry Device Software 4.2.2.338 consists of the following:

    * Applications 4.2.2.184
    * Software Platform 2.5.0.40

    Note: The Applications and Software Platform version numbers are found on the About screen in Options on the BlackBerry smartphone.

    So Basically You Have To Get A Software Upgrade for Your Blackberry
    05-25-08 01:08 PM
  2. Reed McLay's Avatar
    Excellent news, I have lost count of how many Belkin routes have been advise to replace with the Linksys version, solving the problem.
    05-25-08 07:14 PM
  3. SebasCvdB's Avatar
    Nope for many people who don't want to install Beta versions have to wait for the real upgrade before it works.

    One day further into it: no outages, wifi works fine on Belkin N Router with Beta 4.5.0.37
    05-26-08 12:13 PM
  4. SebasCvdB's Avatar
    Currently i am installing Orange Curve 8320 4.2.2.388 upgrade (posted as sticky on forum to see if that works) if people don't want to try the beta and f up there phone than this will be another solution which according to what i posted should work
    06-07-08 12:11 PM
  5. intellekt's Avatar
    I have my 8320 running on .37 and I have a N1 Vision router it still doesnt work. When my network is non-secure (no password) I can connect just fine, but when my connection is secure it doesnt work despite inputting the password. I'm not sure what I'm doing wrong please let me know.
    Last edited by intellekt; 06-12-08 at 06:39 PM.
    06-12-08 06:37 PM
  6. SebasCvdB's Avatar
    It reboots or what does it do? Did you update firmware on router?

    Posted from my CrackBerry at wapforums.crackberry.com
    07-02-08 11:00 PM
  7. bmcclure937's Avatar
    Remember the password is case-sensitive!

    And make sure you have matching security on the Berry and router!
    07-03-08 11:25 AM
  8. d_from_stb's Avatar
    I have a Belkin G Router, and was 10 minutes from returning it when (after my 3rd call to their Tech. Support line) I got a knowledgeable service rep.

    After I set the network up, all my computers ran fine, but my Blackberry Curve (T-Mobile) would log on to the network and then not function - dead air when I made calls and the internet would sometimes work fine and then other times crawl so slow it would have been faster to just turn off Wi-Fi and use EDGE.

    The tech. rep walked me through the following steps and my service is perfect now:

    -Delete the saved profile in the Blackberry from the network that hasn't been functioning.

    -Go to 192.168.2.1/ (can't post direct link as I'm a new user)

    -On the left hand side, go to "Channel and SSID" under the "Wireless" heading.

    -Set "WMM Mode" to OFF.

    -Change "Wireless Channel" (mine was on 6 and I changed it to 9 - not sure if the number matters or not.)

    -Make at least a small change to the network name where it says "SSID" (rename or add a number, etc.)

    -Click "Apply Changes."

    ***If asked for a password, as at the time I hadn't made up one, I just clicked "submit."***

    -On the Curve, under "Wi-Fi Options" scan for networks and find the new one. When asked to set-up WPS or whatever it says (I forget now) scroll to no.

    -Enter in the PSK you originally used with the network.

    You should be up. Hope that helps.
    04-21-09 09:53 PM
  9. bostonbear916's Avatar
    I have a Belkin G Router, and was 10 minutes from returning it when (after my 3rd call to their Tech. Support line) I got a knowledgeable service rep.

    After I set the network up, all my computers ran fine, but my Blackberry Curve (T-Mobile) would log on to the network and then not function - dead air when I made calls and the internet would sometimes work fine and then other times crawl so slow it would have been faster to just turn off Wi-Fi and use EDGE.

    The tech. rep walked me through the following steps and my service is perfect now:

    -Delete the saved profile in the Blackberry from the network that hasn't been functioning.

    -Go to 192.168.2.1/ (can't post direct link as I'm a new user)

    -On the left hand side, go to "Channel and SSID" under the "Wireless" heading.

    -Set "WMM Mode" to OFF.

    -Change "Wireless Channel" (mine was on 6 and I changed it to 9 - not sure if the number matters or not.)

    -Make at least a small change to the network name where it says "SSID" (rename or add a number, etc.)

    -Click "Apply Changes."

    ***If asked for a password, as at the time I hadn't made up one, I just clicked "submit."***

    -On the Curve, under "Wi-Fi Options" scan for networks and find the new one. When asked to set-up WPS or whatever it says (I forget now) scroll to no.

    -Enter in the PSK you originally used with the network.

    You should be up. Hope that helps.
    Sadly this doesn't work for the Bold 9700 (t-mobile). Enter the pin on the website doesn't work and when the back button on the phone and enter the passkey into the phone it says it is the incorrect pin. Sadder than that I was connected to this router on my Bold since December when I go the phone until today when I password protected the router. URGHHHH
    04-27-10 10:22 PM
  10. bk1022's Avatar
    I believe the problem regards AES. Turn off protected mode, and set the Belkin router security protocol to be WPA2-PSK/TKIP only.
    05-23-10 02:29 PM
LINK TO POST COPIED TO CLIPBOARD