1. Hippie798's Avatar
    Just got a 9650 from son who was on sprint. Changed it over to gsm an put my sim card in
    Works fine except my 8900 charging cord will not charge the 9650 even though they seem to be just alike any ideas ? phone works just fine but i have to charge battery in my 8900 to use in my 9650 ?
    10-19-10 11:07 AM
  2. Hippie798's Avatar
    I think i have to have a BB charging cord that puts out 700 miliamps instead of the universal one i have that puts out 500 ????
    10-19-10 12:44 PM
  3. Hippie798's Avatar
    Well it looks like this boards dead cause nobody had an answer for sure
    10-23-10 02:24 PM
  4. albee 1's Avatar
    You didn't get an answer because there are probably not many people with 9650's trying to charge them with 8900 chargers. Get the right one for the 9650 and call it good. Self explanatory.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-23-10 09:42 PM
  5. bodeb's Avatar
    You didn't get an answer because there are probably not many people with 9650's trying to charge them with 8900 chargers. Get the right one for the 9650 and call it good. Self explanatory.

    Posted from my CrackBerry at wapforums.crackberry.com
    +1 My 9650 charges just fine with the appropriate charging cable.
    10-23-10 09:49 PM
  6. spiraleze's Avatar
    Well it looks like this boards dead cause nobody had an answer for sure
    You answered the question as to the charging problem yourself. You were using a charger with insufficient output for the 9650. This is not new information, a simple search would have provided confirmation in multiple threads.
    10-23-10 10:47 PM
LINK TO POST COPIED TO CLIPBOARD