1. withnail69's Avatar
    Something I don't get. I have 3 models of blackberries so not an issue specific to one device. Something I have noticed is that after around a year of owning one the battery life rapidly deteriorates. EVEN if I buy a new battery and put it in the device. The battery life is terrible. Does anyone know why this is? I Charged my battery to full capacity last night around 9pm. It is now 4:45pm the next day and I only have 60% battery life yet. I've hardly used it.
    12-17-10 10:45 AM
  2. 1812dave's Avatar
    it's something you've got running, most likely, or signal level is very low
    12-17-10 11:13 AM
  3. withnail69's Avatar
    Good points but I'm not running anything that I haven't been for the rest of the year and there is definitely a difference. Something in the handset rather than the battery
    12-17-10 11:21 AM
  4. 1812dave's Avatar
    Good points but I'm not running anything that I haven't been for the rest of the year and there is definitely a difference. Something in the handset rather than the battery
    I guess it's possible that something in the hardware is depleting the battery--I've seen that happen with other electronics. rare, but possible.
    12-17-10 12:02 PM
  5. JWWDUKE's Avatar
    I'm using my storm(still!!!!!) and I don't notice any difference since my phone was brand new. I got my storm on Dec 24 2008. I still get about a day and a half under my normal use. I almost always charge it every night and have around 30-40% when I go to bed. My previous phone was a Razr and after 2 years it dropped off dramatically. So much so I bought a battery off eBay. I'm expecting my storms to start dying sooner but as of right now it still seems ok. This is my first BB so this is my only experience with them.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-17-10 06:10 PM
  6. Beethoven9th's Avatar
    Something I don't get. I have 3 models of blackberries so not an issue specific to one device. Something I have noticed is that after around a year of owning one the battery life rapidly deteriorates. EVEN if I buy a new battery and put it in the device. The battery life is terrible. Does anyone know why this is? I Charged my battery to full capacity last night around 9pm. It is now 4:45pm the next day and I only have 60% battery life yet. I've hardly used it.
    Funny, I've been experiencing the exact same problem myself. I've had my Bold 9000 for almost 2 years now, and the battery life has become a joke. As an experiment, I charged it overnight and disconnected it when I woke up at 9:00am. I kept it on but did NOT use it at all (nothing running in the background either). By 6:00pm, the battery was under 50%.

    I figured that after 2 years it was probably just the battery, so I purchased a brand new OEM BlackBerry M-S1. I popped the new battery in, charged the sucker up (thinking all my problems were solved), but to my horror the new battery behaved the same way as the old one!

    And if I actually use the phone (which, after all, is the whole purpose of having it), the stupid thing is dead after just 6-8 hours.

    I love my Bold, but this battery problem is ridiculous.
    Last edited by Beethoven9th; 12-20-10 at 08:55 AM. Reason: Typos
    withnail69 likes this.
    12-20-10 08:52 AM
  7. JRSCCivic98's Avatar
    Are you using a RIM branded charger or a 3rd party charger and are you using any car chargers (RIM or otherwise).
    12-20-10 12:55 PM
  8. pcgizmo#IM's Avatar
    it's something you've got running, most likely, or signal level is very low

    FAIL!!!!


    Have you done an OS update recently?
    12-20-10 03:21 PM
  9. Beethoven9th's Avatar
    Are you using a RIM branded charger or a 3rd party charger and are you using any car chargers (RIM or otherwise).
    Don't know about the OP, but I'm doing everything exactly the same way as I have been for the past 2 years. I never use any equipment other than that manufactured by RIM (battery, case, charger, etc). Like the OP said, it must be a problem with the handset itself since neither of us is doing anything different from the way we've done things in the past.
    12-20-10 04:32 PM
  10. withnail69's Avatar
    i'm same at beethoven. Battery is at 50% by about 12 hours after charging. nightmare
    12-23-10 09:11 AM
  11. JohnMidnight's Avatar
    Had it happen with my Bold 9000 prior to getting the Torch. Updated to a new OS and the problems vanished.
    12-23-10 12:39 PM
LINK TO POST COPIED TO CLIPBOARD