1. mszilard's Avatar
    Hi. This is an another post about connection problem with wifi
    I have at home a wifi router (dlink di524) and i cannot connect to it. At work, with different models of router I am able to connect to wifi and browse the net.
    I tried different approaches at home (with, or without security encryption, changing the channel of the router, assigning static ip for the bb) but nothing works.
    It happend one time, and one time only that i could connect to my home network (the wifi logo became white instead of grey) after a complete battery discharge and phone reboot. After disconnect I wasn't able to reconnect again ever since (I did try a battery pull out, it didn't work).
    Specifics about the problems, the phone picks up my home network, but at menu/manage connections after my home network name i have a "-" sign instead of the ok sign.
    At wifi diagnostics I get an ip adress from the router, the encryption settings are ok, signal is good, but at the "BlackBerry Infrastructure" i have a nasty red x or yellow "-", instead of the green ok sign.

    If anybody could help me i would appreciate it.
    03-13-10 07:19 AM
  2. bklynbruiser's Avatar
    I had this same problem at home but not at other places. Then I realize I had the problem with many of my other devices (motorola cliq, iPhone etc). Then I found my problem was at home I have a router that supports Wireless-N. Soon as I switched back to my regular b/g router everything worked perfectly.

    Check and see if that may be your problem also. If you do have a Wireless-N supported router you can try turning on your wifi on BB then reboot your router. That seem to do the trick until I just replaced the router.

    Hope that helps
    03-13-10 08:57 PM
  3. kwkid's Avatar
    I had this same problem at home but not at other places. Then I realize I had the problem with many of my other devices (motorola cliq, iPhone etc). Then I found my problem was at home I have a router that supports Wireless-N. Soon as I switched back to my regular b/g router everything worked perfectly.

    Check and see if that may be your problem also. If you do have a Wireless-N supported router you can try turning on your wifi on BB then reboot your router. That seem to do the trick until I just replaced the router.

    Hope that helps
    You might also want to log into the router and make sure it is not strictly using N Class. It should be in mixed mode. Once I put my N Class router in mixed mode my 8520 had no problem connecting anymore.
    03-13-10 09:23 PM
  4. g_patkar's Avatar
    I seem to be having the same problem with my D-Link DIR 615 router (So it seems to be a problem with newer D-Link routers. My older D-Link router was just fine).

    I am in mixed mode B/G/N with WEP security and the phone seems to connect briefly before disconnecting (Usually 3 - 5 minutes). Other times, it just leaves the (-) minus sign on the 8520, as though it cannot connect.

    In the log it says Failed to authenticate device (After it disconnects) or something along those lines. I will post the original log message when I get back home.

    This is really annoying, as I frequently use my wifi connection on the 8520 to stream music and youtube videos.

    Any help would be MUCH APPRECIATED. Help!
    03-14-10 01:00 AM
  5. diegonei's Avatar
    So far the solutions for this seems to be as BB King stated, changing the router settings to b/g and checking if the security settings are right (I cant remember if AES or PSK).

    PS: Your kid? Makes me want one. Since RIM will have a plant here in Brasil, I'll just might get a few spare 8520 so my 1stborn can droll over/under/inside...


    03-14-10 08:59 AM
  6. mszilard's Avatar
    the di524 is not n mode capable. i tried mixed b/g and only g mode too, with no luck. i think the problem is with the router, because i had the same problem at another place too, with the same router.
    the question is, is there some sort of settings that solves the problem or should i change my router. the thing that bugs me is that i managed to connect once (so it is possible), but never again.
    03-14-10 09:07 AM
  7. kwkid's Avatar
    the di524 is not n mode capable. i tried mixed b/g and only g mode too, with no luck. i think the problem is with the router, because i had the same problem at another place too, with the same router.
    the question is, is there some sort of settings that solves the problem or should i change my router. the thing that bugs me is that i managed to connect once (so it is possible), but never again.
    Well if that is the case here is what I would try before investing in a new router. Do a factory reset on the router. Once the router initializes, try connecting to the router. If it still won't connect, it has to be an issue with the router as the BB connects with other routers. If it does connect, make one change at a time. As soon as the change is made, log back in with the BB. Eventually, you will either be connected always, or you will find the setting that is causing all the issues. Time consuming I know, but hopefully you will find the culprit and can share the solution with all of us here. If I had that particular router, I'd be glad to test it for you, but I have a different brand and model.
    03-14-10 11:56 AM
  8. mszilard's Avatar
    i tried the factory reset a couple of times. it didn't help. i did try to change one setting a time. it didn't help either. except that one occasion when i found my phone connected to wifi, i never managed to connect.
    03-14-10 03:17 PM
  9. bklynbruiser's Avatar
    So far the solutions for this seems to be as BB King stated, changing the router settings to b/g and checking if the security settings are right (I cant remember if AES or PSK).

    PS: Your kid? Makes me want one. Since RIM will have a plant here in Brasil, I'll just might get a few spare 8520 so my 1stborn can droll over/under/inside...


    I find a simple b/g router works flawlessly. I will hook back up my N router and take a deeper look into the settings and see if I can come up with something. Some Very good suggestions here..

    And Yes.. Thats the lil one.. playing with an old 7290. Looking at him you would swear he knows what he's doing. LOL.
    03-14-10 08:45 PM
  10. mszilard's Avatar
    i bypassed the problem by buying a new router . it's a cheap belkin, but the wifi works flawlessly.
    03-17-10 09:04 AM
  11. g_patkar's Avatar
    Try switching your router's Wifi security to WEP 64 Bit Hex and only use a 10 digit numeric key!

    I was facing this problems forever with my D Link router when a D Link technician suggested the change. Gets connected fast and stays connected!

    Please let me know if it worked for you!
    04-06-10 07:38 AM
  12. Mulder1981's Avatar
    Just posted in the 83xx forum but here I guess is the best place, so sorry for the double posting.
    Turned the WEP protection back on and currently showing "ISP error. DNS server cannot be reached."

    Done a Batter Pull as suggested but makes no difference and with WEP off I get "ISP or Wireless network error"

    Not sure what else I need to do in order to get the UMA connection to show a green tick!

    ---
    Hi,

    I have looked at some of the UMA/WiFi threads but nothing there seems to have fixed the issue.

    I have purchased an unlocked 8320 (formerly Orange) which I am using on the O2 network.

    I have updated to the latest OS (4.5) .
    I have a Netgear router and have changed it to G&B only and Channel 11 as recommended by another thread (from Auto 108 and 6) but no difference.

    I do get a difference when WEP is turned Off but still no UMA.
    When WEP is off I get "ISP or Wireless network error", with WEP on I get a DNS error message.

    Currently the Servicing UNC address is unc.singlephone.orange.co.uk:14001 and gateway is singlephone.orange.co.uk

    I dont know if that is what the issue is, how to change it and what to change it to, if that is what the issue is.

    Network is O2 and Broadband is with Plusnet (Force9)

    There is a tick for UMA WiFi available but red cross for Connection.
    I dont get UMA in upper or lower case appearing on the homescreen (just GPRS).

    Also any idea how to change the Orange Welcome screens to something else?

    Thanks in advance.
    04-07-10 08:57 AM
LINK TO POST COPIED TO CLIPBOARD