1. skrible71's Avatar
    Ok, I'm not exactly technology illiterate but this Wifi problem has gotten me stumped! I've logged on to my building's secure hotspot, changed my browser's configuration to Hotspot Browser instead of my carrier's EDGE/ WAP connection (I'm in Thailand, and when the world is about to move onto 4G, we still don't have 3G ) and chose the Start BB connection option. but the Wifi Logo still remains gray not white?!?!?! why?? please help. Thanks.
    08-25-10 10:37 AM
  2. mandony's Avatar
    08-25-10 11:40 AM
  3. xpdamus's Avatar
    I had this problem too. It really baffled me for a very long time...

    I've searched and searched everywhere and to me it seems like there are several possible reasons for the wifi icon to grey out.

    A simple start is to delete all wifi profiles and reboot. Then go to options > advanced options > host routing table and pressing the menu button and clicking 'register now'. then reboot. After the phone starts, try setting up the wifi again.

    I've found that if another device on the network is using a secured connection to the access point (i.e push button/pin set up) that my blackberry will refuse to connect to the blackberry infrastructure on the ssl connection to rcp.eu.blackberry.com (replace 'eu' with your locale)

    This may well be just my router (Netgear WNR2000) but it may help.

    Another issue to check is to find out if your router allows this secure connection on port 443. or if your ISP blocks this port (i've read that some do)

    If you have checked these and don't see any problems, try disconnecting other devices and deleting the wifi profile for your router and testing each type of setup method (push button/pin/manual/scan)

    HTH.
    08-25-10 11:58 AM
LINK TO POST COPIED TO CLIPBOARD