1. 8330Crackhead's Avatar
    Hello. Has anyone downloaded the new 4.5 version of amAze on a Verizon 8330. I can not pick up a satellite signal. The download worked perfect and I set the region as Maryland but in the top left corner, the satellite stays red and picks up no signal. Am I doing something wrong or is there some sort of setting that I have to change. PLEASE HELP!!!
    Thanks!!
    Last edited by 8330Crackhead; 12-30-08 at 12:02 AM.
    12-29-08 10:11 PM
  2. Hynr's Avatar
    I did this upgrade today. Not sure what you mean with your second sentence. I don't see a satellite icon (I'm probably blind). I test my unit with BB maps: I go outside, select that BB maps, select GPS Navigation from the options. The software indicates that it is looking for satellites and after finding some (it takes a few seconds), shows the current location on the map. I did have the GPS settings turned on (Options, Advanced, GPS).

    Edit: I just noticed that you are talking about something called amAze - I have no clue what that is. I thought you were asking about the Verizon 8330's operating software.
    Last edited by Hynr; 12-29-08 at 11:56 PM.
    12-29-08 11:52 PM
  3. 8330Crackhead's Avatar
    Yeah, sorry for the confusion. I should have been more clear. It is a navigation software download that I can't seem to get to pick up a satellite ping. Thanks for the quick response :>)
    12-30-08 12:05 AM
  4. hubermania's Avatar
    Same problem on my Flip with BT GPS. Have to start BB Maps to link GPS, then start amAze. Quite a PITA but amAze has voice nav and much better map data than BB Maps or Google Maps. Went on joy ride yesterday, and amAze is the first nav system I've ever heard announce a state line crossing. Will be pretty cool for family road trips.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-30-08 03:52 AM
  5. irie's Avatar
    No matter what I do, i cannot get Amaze GPS to work on Blackberry Storm, I have tried running BB Maps in the background and that still didn't help. Anyone have any pointers?
    12-30-08 08:50 PM
  6. 8330Crackhead's Avatar
    I have done the same thing. I still have no satellite. Does anyone know how to get this app up and running on a Verizon Curve 8330. I have tried EVERYTHING that I can think of.
    12-30-08 10:43 PM
  7. trucky's Avatar
    Verizon GPS is pretty much disabled for all programs except their own VZNav program and I think, BBMaps.
    01-02-09 09:00 AM
  8. 8330Crackhead's Avatar
    Thanks so much. I pretty much figured that. I cant get anything to work. Thanks
    01-02-09 12:38 PM
  9. cmjones2008's Avatar
    Verizon GPS is not locked on Blackberries. It is unlocked for any 3rd party apps you want to run. According to the admin on the amAzeGPS site, they are having trouble with the application signature on all Verizon phones. They are currently working on a fix and hope to have one soon. In the meantime, take a look at Nav4All. Yes, it's more minimalistic than amAzeGPS, but it works for the moment with the Storm. Hopefully the folks at amAzeGPS will get it working soon with Verizon.
    01-09-09 11:22 AM
  10. cjadair's Avatar
    Has the fix come out? I cannot use it right now. I've tried it off & on for a few weeks. It shows the satellite in red with no signal. I also tried it again after I started gps on bbmaps as described above, but still not working. Anymore info would be appreciated.
    01-16-09 01:46 PM
  11. cjadair's Avatar
    Also, checked the forum on the amAze site. There was a post that suggested that Verizon only allows for the bbmaps & vznav to use the gps function, saying they won't allow 3rd party programs because of security reasons. The amAze admin said, if that was the case, then it's a Verizon issue and he couldn't do anything about it.
    01-16-09 03:12 PM
  12. conazo's Avatar
    Having same problem, GPS on top left corner is red, and is not locking any sats. anyone with a solution to this amaze application on the storm please help out.
    01-24-09 04:43 PM
  13. delta_foxtrot2's Avatar
    try installing the telenav demo, don't have to run/use it, but supposedly it unlocks the GPS.
    01-24-09 05:46 PM
LINK TO POST COPIED TO CLIPBOARD