1. nwr91's Avatar
    I have a Torch with an unlimited data plan in Chile, and I am now in the States. I have had my data services off while roaming all the time, because i know the minute i turn it on it will start transferring MB's at about $20 each.

    The thing is, when i turn on WiFi, and connect to a home network, i get good access to the internet through the browser, but no connection to the BIS server. I have no bbm, blackberry mail, etc...

    I tried this with the mobile network on and off, and with apn settings (my carrier asks for apn blackberry.net with no username and password) on and off too...

    Thanks
    Last edited by nwr91; 01-06-11 at 10:00 AM.
    01-06-11 09:57 AM
  2. kccman's Avatar
    Not sure if this makes a difference, but choose "Data off when roaming" as opposed to turning data off completely. This is what I do when I hit a wifi hotspot while in the states.
    01-06-11 11:21 AM
  3. aznlgcy's Avatar
    If you turn off your data while roaming you won't have access to BIS at all.
    01-06-11 11:49 AM
  4. prebetsabu's Avatar
    Never tried with torch.. But with my previous bold 9000, if I off my data, I still can access d bbm etc... So how to do this with torch? Data while roaming sure will cost u a abomb.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-06-11 11:52 AM
  5. webmeister's Avatar
    Not sure if this makes a difference, but choose "Data off when roaming" as opposed to turning data off completely. This is what I do when I hit a wifi hotspot while in the states.
    That is the correct answer! I've had lots of experience with that while travelling in the States. With the above setting, your Torch will automatically try to find the BIS servers at RIM through your WiFi connection.

    Specifically, in your "Mobile Network Options" set the following:

    Data Services: ON
    While Roaming: "OFF" or "PROMPT".
    01-06-11 12:33 PM
  6. nwr91's Avatar
    That is the correct answer! I've had lots of experience with that while travelling in the States. With the above setting, your Torch will automatically try to find the BIS servers at RIM through your WiFi connection.

    Specifically, in your "Mobile Network Options" set the following:

    Data Services: ON
    While Roaming: "OFF" or "PROMPT".
    actually, i've been in "off while roaming" all the time, and tried the off completely mode too. it doesn't work either way...
    01-06-11 06:36 PM
  7. nwr91's Avatar
    I tried turning on the data roaming just for 5 seconds while connected to a WiFi network. I started receiving emails and bbms immediately, and a message that said: "Your handheld has been registered with the wireless network"

    I also have an app for monitoring data traffic, which differentiates roaming from wifi, and roaming data transfer stayed in zero, so i guess no charges apply.
    01-06-11 08:52 PM
  8. webmeister's Avatar
    I tried turning on the data roaming just for 5 seconds while connected to a WiFi network. I started receiving emails and bbms immediately, and a message that said: "Your handheld has been registered with the wireless network"

    I also have an app for monitoring data traffic, which differentiates roaming from wifi, and roaming data transfer stayed in zero, so i guess no charges apply.
    That "Your handheld has been registered with the wireless network" message comes from the phone registering over the the carrier's phone network and typically only happens on a phone that's been newly activated and whose SIM has not been "seen" on the network before. The phone is registering to RIM's infrastructure, using the carrier as a go-between. You should not have seen that message if the phone has been registered before, but it *does* indicate that your problem should be solved going forward. But....monitor your usage and make sure you've reverted to "OFF" or "PROMPT" while roaming for your data settings or you will be in for mundo big data charges when you get back home!
    01-06-11 09:41 PM
  9. owlyn's Avatar
    I don't have a Torch yet (getting one), but with my Bold 9000, if you turn off Mobil Network, and turn on WiFi, I am able to get all my BES and BIS emails via WiFi only. Under Mobil network options, Data Services = On, While Roaming = On.
    01-07-11 06:29 AM
  10. nwr91's Avatar
    I don't have a Torch yet (getting one), but with my Bold 9000, if you turn off Mobil Network, and turn on WiFi, I am able to get all my BES and BIS emails via WiFi only. Under Mobil network options, Data Services = On, While Roaming = On.
    i tried that and it didn't work until i turned the data roaming for a small while. however, by that config you are not getting any calls or sms
    01-07-11 11:58 AM
  11. xavand32's Avatar
    I travel quite a lot with my torch and previous bb's and try to keep my roaming charges down. With my 8520 and 9300 i set mobile network options to data services 'on' while roaming to 'off', one prerequisite is that you turn your data on for a few seconds to register on the carrier network you are using, once you receive that confirmations message you should be able to turn off data while roaming and solely use the wifi but this network registration is needed for the BIS or BES to work over wifi. You know it's working because the wifi symbol will go from greyed out to white.

    For the torch more or less the same process need to get the registration message and leave the settings the same, i dont know if this is just my carrier but you can also set the connection preference to wifi only so you wont incur any other data charges. You know you are connected to BIS or BES because the BB logo appears next to your wifi logo in the upper right hand corner. Also service status should show connected via wifi.

    hope it helps.

    *excuse bad grammar and punctuation.
    01-08-11 12:58 PM
  12. leto13's Avatar
    I have a problem to access to the appworld while roaming, I'm now in Ivory Coast and I have a blackberry Torch, my data service is ON and service while roaming is OFF, but I have the BIS (the blackberry sign appear) over wifi and I receive my emails and I can access to internet and to BBM,
    but I can't access to the appworld, it said to me your device radio is off.
    I don't understand, I tried to access to appworld on my computer but it said the same message, it's very annoying, impossible to install new apps or download upgrades.
    Someone has the solution, or I have to wait to go back home in two months?
    And I don't want to pay 10 euros per Mo......

    Thanks for answer, and sorry for my grammar.
    03-20-11 06:22 PM
  13. royfakhry's Avatar
    I have the same problem, I am currently in the states, and using a blackberry torch 9800.
    I can successfully connect to the wifi use the browser and any application which is not downloaded from blackberry world. I can't user the BBM service nor the Email service, and I don't see the blackberry symbol next to the wifi icon and the signal is GSM and not edge.

    My friend who is on the same carrier (alfa-lebanon) has the same plan but a bold 2 handset, and when he's on wifi he can successfully connect to all blackberry services. I think the problem is in the Torch handset configuration or something, so please if anyone can offer his insight on how to fix the problem it would be great!

    Thanks
    03-20-11 07:15 PM
  14. Tony2255's Avatar
    royfakhry

    you should be able to turn your data to on while roaming for a few seconds until it registers and then turn it back off or to prompt. I had issues with mine too until I did this and then it started to work fine. Good luck
    03-26-11 01:29 PM
  15. royfakhry's Avatar
    The problem is that there is no carrier agreement between my Carrier (alfa-lebanon) and any of the carriers in the U.S so I can't register the device. I asked them to send the service books again and they did, still with no luck. I guess I am stuck for now....but what surprises me is that this only happens with the Black Berry Torch
    04-03-11 09:36 AM
  16. kitegurl's Avatar
    just "upgraded" to a torch. Ha upgrade = not.

    Data services =on
    data services =off while roaming

    I am with Telcel in Mexico as my provider. Yet here I am in Canada roaming on Rogers and can not get browser to work

    yet when i try to go to hotmail.com for example i get a message that says
    "data services disabled- go to mobile network services to enable"
    so what is going on here ?
    thanks
    04-20-11 10:08 PM
  17. JKST's Avatar
    I think I might have the same issue as other people.

    I'm with Rogers in Toronto, and currently on a trip in Hong Kong. I got a SIM card from a local provider, stuck it in the phone, have setting as Data ON Roaming OFF (wifi-preferred). I'm trying to use wi-fi for everything but phone calls. I can use the browser perfectly, but I can't seem to access use BB e-mail and BBM.

    Can someone confirm that by doing this I won't incur charges when I get the bill at home?

    And is there a reason why BBM and email won't work through wi-fi directly? (if anyone ever got it to work in Hong Kong, which provider did you use?)

    Thanks.
    Last edited by JKST; 05-02-11 at 07:20 PM.
    05-02-11 07:17 PM
LINK TO POST COPIED TO CLIPBOARD