1. Spartangr01's Avatar
    greeetings from Greece
    I just got my new Bold 9780 but i dont have an active plan ... yet
    i am considering of getting one
    but until then i ll rely on wifi

    and there is the problem
    my phone "see's" my wireless network, i install it with success on the BB
    but it wont go online

    the wifi symbol at screen will remain grey and just wont get white

    are there some settings i have to fix either on BB or on my router??




    any help guys would be much much appreciated
    please excuse me for my english
    thanx
    01-01-11 02:09 PM
  2. Phill_UK's Avatar
    The wifi symbol will only go white when it is connected to BIS... which you don't have
    01-01-11 02:12 PM
  3. Spartangr01's Avatar
    thanx phil
    but do i need BIS to go online from a WiFi network??
    01-01-11 02:24 PM
  4. Motorcycle Mama's Avatar
    For many carriers, use of WiFi is dependent on a Service Books which you won't get until you have an active BIS plan.
    01-01-11 02:32 PM
  5. Spartangr01's Avatar
    by carrier you mean my cellphone services provider??

    but how my carrier can prevent my phone from going on line from a Wifi net??

    again sorry if i ask stupid questions
    i am quite a newbie here
    thanx
    01-01-11 02:40 PM
  6. Phill_UK's Avatar
    Yes, carrier/service provider/network... all mean the same

    All data passage (network and wifi) on a BlackBerry is controlled by service books, which are pushed to your device by your service provider.

    If you don't have a BlackBerry data plan, chances are you won't have the service books either
    01-01-11 02:57 PM
  7. Motorcycle Mama's Avatar
    1. Yes. Carrier = cellphone service provider

    2. Because on a BlackBerry many things are controlled by Service Books. WiFi access is one of those things. Service Books are pushed by the carrier to the device. You won't get them without a data plan.
    01-01-11 02:58 PM
  8. Spartangr01's Avatar
    thanx guys
    but just one more question
    i check my phone and i see under Service Books
    WiFi tcp/ip browser and WiFi tcp/ip transport
    among others
    are these what you are referring??
    arent these enough for wifi connections??
    01-02-11 07:15 AM
  9. Phill_UK's Avatar
    Do they have a tick next to them, to show they're active? Can you browse the internet yet?

    If not... get yourself that BB data plan

    Posted from my CrackBerry at wapforums.crackberry.com
    01-02-11 07:23 AM
  10. Spartangr01's Avatar
    yes they do have the tick
    but no i cant browse

    i ll get that plan but due to various reasons propably in a couple of weeks
    so until then i would really like to go online through wifi

    Phil do you think by any chance there are some settings i need to fix in order this to work??

    for example does it matter if my wifi is WEP or WPA2?

    thanx
    01-02-11 07:51 AM
  11. Phill_UK's Avatar
    If you're connected to your router, which you already are because the wifi symbol is showing, then it doesn't matter which security setting is used.

    I still don't think you'll be able to browse on wifi until you have an active data plan

    Posted from my CrackBerry at wapforums.crackberry.com
    01-02-11 08:01 AM
  12. micci's Avatar
    sorry, but im from sg so ya i think my carrier works a bit different...

    i have just got a plan from my carrier and its 1gb which only allows me to bbm fb and msn.. i cant surf the net with that limitation(only if i pay more i can get to surf the net with it).. so i would like to ask if i on the data services and connect to my wifi.. do i need to pay the charges for surfing the net with it?

    im not very familiar with the system of wifi and stuff..
    01-04-11 02:27 AM
  13. Spartangr01's Avatar
    it finally works
    i dont what happened
    one moment it just started to work
    so conclusion you dont need an active plan to browse the net through WiFi
    thanx everybody
    01-05-11 08:11 AM
  14. mrbelloso's Avatar
    I have this problem, i can surf the web if the wifi it's disconnected but when i connect the bb to the wifi network it doesn't surf the web. I have a BIS plan with Optus and i have the both services books for the wifi. I have a BB 9780.
    02-14-11 02:47 AM
LINK TO POST COPIED TO CLIPBOARD