1. ItsaRaid's Avatar
    Hello:

    I have a AT&T BB9700 running .979 AT&T's latest update for the 9700. When I go into a Starbucks, I consistantly get a WIFI Log In Screen. I should simply be able to go into Starbucks and the 9700 should seamlessly switch to wifi.
    I get a red star in the display wifi and a red star in set-up. If I log in everything is fine and dandy for that session, or it will ask for a credit card and WIFI ID#. I have tried a Battery pull several times and whats weird is when the device boots up, it switches to WIFI without a problem, or going back to the original, after a hour or so, the 9700 will switch to wifi on its own-

    Dont know if my 9700 needs a Exorcism, but thought I would post here hoping to get some answers. I have repeatedly called AT&T, they are of no help, they stated that they do not support or provide support for WIFI-

    I have gone into profiles, everything apppears set correctly, its set on automatic as well-
    11-14-10 10:47 AM
  2. starchit's Avatar
    From what I'm reading, there's nothing wrong with the phone. Starbucks is requiring you to log on to their site. If a router is asking for credit card #, then it's not free WiFi.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-14-10 12:11 PM
  3. dangerousfen's Avatar
    Yes, I get the same issue in the UK at Wetherspoons. It's free wifi but they require a login each time you enter the premises. You then get 1 hour of free wifi.
    11-14-10 12:23 PM
  4. WolfmanRobby's Avatar
    The problem is that that login is when you have to agree to their terms to use the WiFi.

    They are requiring you to AGREE to the terms by logging in every time. In other words, the wireless access point does not remember your phone (Usually by WiFi MAC address).

    This is nothing wrong with your BlackBerry, but rather in the security setup on their wireless.

    I travel a lot. I run into this with StarBucks and many hotels. A lot of the hotels I have to "Log In" to their WiFi every 12 to 24 hours for every device that tries to access it (My laptop, my BB, my Android tablet...).
    11-14-10 01:26 PM
  5. Rootbrian's Avatar
    Nothing wrong with your blackberry. I had to do the same thing in mexico, login, to access anything, same with my netbook.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-14-10 08:18 PM
  6. ItsaRaid's Avatar
    Not that I want to seem unappreciative of the advice given, AT&T and Starbucks have a agreement, "Free Wifi" No Log in, Its totally Open wifi to all AT&T Customers. My son has a I-Phone and walks in to starbucks and the phone switches automatically to wifi- without any log in screen.
    I have several friends who are Starbuck Addicts and have 9700 BB. They dont get a log in screen as well.
    I went into a AT&T retail store today thats next to a Starbucks in a strip shopping center (Next Door) One of the Reps had a Torch- we turned WIFI on, the phone switched to wifi before we could take it into the Starbucks Store, No Log In. We also turn wifi off and went into the Starbucks store and then enabled wifi, the Phone switched seamlessly to wifi without any problems or notices
    Very Perplexing-
    Last edited by ItsaRaid; 11-15-10 at 02:15 PM.
    11-15-10 02:13 PM
  7. Fubaz's Avatar
    try logging in once, and from there see how it acts.

    Its like the same for me in Canada because Bell and Starbucks have the agreement here.

    I have to login once every so often.

    Also have you changed your browser config to HotSpot browser.... ive had issues using FireFox as a mask in my browser with some hotspots because it thinks its a laptop.
    Last edited by Fubaz; 11-15-10 at 02:26 PM.
    11-15-10 02:16 PM
LINK TO POST COPIED TO CLIPBOARD