1. ronmcse's Avatar
    Hi, I recently switched from windows xp pro 32bit, where my Bluetooth setup was flawless, to Windows 7 Home premium 64 bit. My laptop sees the bluetooth phone and adds it. It shows up under devices and on my curve the PC shows up under bluetooth devices. BUT, under windows, no services are installed for the phone. all information for the phone shows as unavailable and nothing populates under the serverices tab. I have installed blackberry DTM and downloaded and installed modem and usb drivers for my curve 8530 and deleted the device over and over, but everytime, no services will be installed. There are no yellow exclamation points anywhere or under device manager.
    07-09-10 12:48 PM
  2. diegonei's Avatar
    Try this file. Bluetooth drivers.exe - 4shared.com - online file sharing and storage - download

    The "!"s should show after that. My 7 never manages to tell who is who thou and I always end up doing trial and error. Some times I get them right, some others (like now) Remote control stops working.

    Good luck!
    07-09-10 01:31 PM
  3. ronmcse's Avatar
    thanks for trying, but it didn't help. I d/l the file, ran and installed it. I then deleted my device from the Bluetooth devices and off my phone, rebooted the PC. I then added my phone back under bluetooth devices. It paired and connected fine. But When I go to the properties of the phone, there are no services listed. When I go under bluetooth settings in my phone's menu, all the services have check boxes enabled, for some reason Windows 7 will not add any services what so ever!
    07-09-10 03:09 PM
  4. diegonei's Avatar
    Did you actually go to the device manager and see if there were any devices needing driver updates? Marked "!" ?
    07-09-10 04:45 PM
  5. ronmcse's Avatar
    yes, I have been uninstalling, refreshing, installing drivers all day in device manager, I never get any Exclamation point or question mark. The Bluetooth drivers show without errors or exceptions. The bluetooth is built onto motherboard ( Dell Studio laptop) Dell wireless 365 bluetooth module is what is listed in Device manger under Bluetooth USB, and Bluetooth PAN network adapter is under "Network adapters" Both working correctly. As stated, My Phone will pair, just no services will install. I want the Dialup Networking service to install from the phone, but nothing will load.
    07-09-10 06:38 PM
  6. ronmcse's Avatar
    Ok, the problem fixed itself over night. I finally gave up last night and closed the lid on my laptop. This morning when I opened the lid, signed on, BAM - windows updates popped up and said it was updating my bluetooth devices, It did this for a couple of mins and magically, my services started showing... Oh well, don't know how, but at least it works!
    07-10-10 11:01 AM
LINK TO POST COPIED TO CLIPBOARD