1. xavand32's Avatar
    I have been having a nightmare connecting my 8520 to the network in my house.

    I am currently living in europe, with my home network being orange uk. I have a small travel bundle set up to allow me to receive mails will I am out of the apartment but I can not for the life of me get the BB to connect to the home network.

    I have data on and enabled. I have taken all security off of my router. I have turned both on and off, have done a battery pull, have reset the router. I have changed the channels, I have reset the router. It was briefly at one point this evening connected. Then dropped the connection again.

    I get wifi in grey and not in white. I had it working shortly but now it seems to not be interested.

    I am running the OS 5.0.0.411, and was thinking maybe that was an issue but have searched on the forum and havent seen anyone that has stated they have had problems with wifi and this particular build, maybe there was but under different model.

    Please I need to use the wifi as to not max out my bundle, the town here has wifi throughout the city, so i need to get it working.
    01-05-10 09:19 PM
  2. papped's Avatar
    Are the wifi options in the service books?

    Options > Advanced Options > Service Books
    Wi-Fi TCP/IP Browser [BrowserConfig]
    Wi-Fi TCP/IP Transport [WPTCP]

    Could always try re-sending the service books.
    01-05-10 09:29 PM
  3. xavand32's Avatar
    yes they are.
    How would I do that and would it work outside of the home networks country?
    01-05-10 09:31 PM
  4. papped's Avatar
    Click on the Email Settings icon, Menu > Service Books > Send Service Books
    01-05-10 09:38 PM
  5. xavand32's Avatar
    That would be within the settings folder with set up wifi and similar? I see it there but when i press menu dont get service books option?
    01-05-10 09:47 PM
  6. papped's Avatar
    There's an actual icon somewhere called "Email Settings". Not a folder, it's an actual "app" icon.
    01-05-10 09:55 PM
  7. xavand32's Avatar
    Found it, (better to be thought an *****, then to open your mouth and prove everyone right) :S ok, then what?
    01-05-10 09:59 PM
  8. xavand32's Avatar
    I actually dont have that service books option, I was looking within the email settings even youtubed it, to find instructions.
    01-05-10 10:12 PM
  9. papped's Avatar
    You can try creating an account on your carrier's BIS site:

    BlackBerry Internet Service

    Create a new account and give your PIN + IMEI. Once you login on that site you can resend the service books in there also. If you don't have a blackberry data plan this is all pointless though.
    01-05-10 11:12 PM
  10. xavand32's Avatar
    I do have data plan. I filled the information and was told have to do thise via my handset, I am going somewhat crazy with this problem.
    Last edited by xavand32; 01-06-10 at 08:46 AM.
    01-06-10 08:42 AM
  11. jackbox's Avatar
    Sounds like you have a bad wifi radio in your device. Take it in under warranty and get it exchanged.
    01-06-10 10:41 AM
  12. gr1zzly2121's Avatar
    no i am pretty sure he doesent, as he already connected once.. i am having the same trouble with my dads 8520. it was connected for 6 days straight, then i restored some options through dm and now it wont connect anymore, just grey.
    01-06-10 10:59 AM
  13. xavand32's Avatar
    I was thinking that maybe it was having some issues with WEP security on my router, I reset it against my better wishes as it was difficult to set up in the first place with our Media player, the three computers and TV. It seems to solve the problem but is reluctant to connect with the WEP key on!
    01-06-10 01:28 PM
  14. papped's Avatar
    I was thinking that maybe it was having some issues with WEP security on my router, I reset it against my better wishes as it was difficult to set up in the first place with our Media player, the three computers and TV. It seems to solve the problem but is reluctant to connect with the WEP key on!
    Have you tried wpa? I connect without any issues on WPA and WPA2 on my 8530. WEP is basically useless anyways. You might as well get rid of it completely and just use mac address filtering and hide the SSID.
    01-06-10 01:37 PM
  15. JRF_1986's Avatar
    Have you tried wpa? I connect without any issues on WPA and WPA2 on my 8530. WEP is basically useless anyways. You might as well get rid of it completely and just use mac address filtering and hide the SSID.
    Can you do this with any modem? I'm in Mexico and the modem I have came free with the internet service. I usually just search and add the wep key whenever I buy a device with wifi. How can I set up the WPA and mac address filtering thing?
    01-06-10 05:09 PM
  16. papped's Avatar
    Need to login to the router settings.

    Type in 192.168.0.1, or 192.168.1.1 in the address of your browser, one of those should probably work.

    I'd read up on changing the security settings if you don't know how to do it though.
    01-06-10 05:12 PM
  17. g_patkar's Avatar
    Try switching your router's Wifi security to WEP 64 Bit Hex and only use a 10 digit numeric key!

    I was facing this problems forever with my D Link router when a D Link technician suggested the change. Gets connected fast and stays connected! Please let me know if it worked for you.
    04-06-10 08:33 AM
LINK TO POST COPIED TO CLIPBOARD