Built for Business - Learn more about BlackBerry KEY2
  1. VetteVert's Avatar
    I have a 8330m and my wife has a 8330 with the same rural carrier. They don't lock down their phones in any way. I can get gps to work in bb maps and telmap, but not in google maps 3.0.2. I can't remember what version my wife has. On hers, it will give a triangulated location and say something about searching for gps until it finds it. Mine says nothing about gps. I have made sure the privs for google maps are all set to allow...

    Any ideas?

    Posted from my CrackBerry at wapforums.crackberry.com
    03-28-09 03:53 PM
  2. xliderider's Avatar
    Are you trying to get a GPS lock outside, the GPS needs a "clear view" of the sky, so it might not work while indoors.
    03-28-09 03:57 PM
  3. VetteVert's Avatar
    Yes. I tried the phones side by side. Mine didn't act like it was even trying, where hers said something about searching...(Don't have hers in front of me atm)

    Posted from my CrackBerry at wapforums.crackberry.com
    03-28-09 04:04 PM
  4. TheHeartlessHero's Avatar
    What OS are both phones? Same or different? Try upgrading both to the latest.

    Have they both been updated through *228? May be a reason.

    Does her phone work in bbmaps and telnav as well?

    Google Maps 3.0.x has an option called My Location. Click Menu then my Location. It will find a cell tower triangulation first then a GPS lock if possible.

    Try getting a lock in BBmaps then try Gmaps to see if you can get the GPS lock.

    Have you tried a battery pull?

    If all else fails, you can try my guide here
    Last edited by TheHeartlessHero; 03-29-09 at 01:02 AM.
    03-28-09 09:44 PM
  5. VetteVert's Avatar
    I appreciate the response. I have looked through your guide, but since I use such a small time carrier I would be stumped at some of the steps.

    Her phone is at whatever the latest official OS from BB for the 8330 is (I recently updated it). Mine is at 127. Both 4.5 obviously.

    I have enabled location on both. Hers actually says acquiring gps, where mine does not. I tried doing the bbmas thing first, then jumping into google maps without closing bbm but get the same results.

    I have an option in my google maps for bluetooth gps which I don't remember seeing on hers.

    Her phone does work with any gps app I have tried.

    I am seeing other posts on the board with the same issue on 3.0.2 with curves. I work with ppl with 3.0.2 on verizon storms and theirs works.

    Thanks again!
    03-30-09 06:25 AM
  6. TheHeartlessHero's Avatar
    The latest curve 8330m update is .138. It is under the 83xx board.

    http://forums.crackberry.com/f52/new...nguage-185702/

    I would recommend updating to it first and trying again.

    Also, this is NOT the latest update for the 8330 model. That is .131.

    Also, what exactly is the difference between 8330 and 8330m o_O Why do they require separate updates and such, I got no clue.

    Anyways, update your 8330m to the update I linked to and see if that fixes your problem.
    03-30-09 04:22 PM
  7. xliderider's Avatar
    Also, what exactly is the difference between 8330 and 8330m o_O Why do they require separate updates and such, I got no clue.

    Anyways, update your 8330m to the update I linked to and see if that fixes your problem.
    The m is for MEID vs. the ESN version of the Curve. There is a whole thread discussing it.
    03-30-09 04:34 PM
  8. TheHeartlessHero's Avatar
    Yea, I found the thread after posting it but I just left my post up here.
    03-30-09 05:11 PM
  9. VetteVert's Avatar
    The latest curve 8330m update is .138. It is under the 83xx board.

    http://forums.crackberry.com/f52/new...nguage-185702/

    I would recommend updating to it first and trying again.

    Also, this is NOT the latest update for the 8330 model. That is .131.

    Also, what exactly is the difference between 8330 and 8330m o_O Why do they require separate updates and such, I got no clue.

    Anyways, update your 8330m to the update I linked to and see if that fixes your problem.
    I was saying the latest BB OS update that is established for my carrier. The one for download at bb.com.

    I will try updating as soon as I can.
    03-30-09 06:48 PM
  10. VetteVert's Avatar
    updated to 138. No difference. Deleted, reboot, batt pull, re-install...still won't even attempt to use gps.

    Working:
    telmap
    LifeInPocket
    amaze
    bb maps
    gpsed

    Not Working:
    Google maps

    VV
    03-31-09 07:12 PM
  11. TheHeartlessHero's Avatar
    Does anyone else with an 8330m have Google Maps working? Maybe all 8330m models can't get google maps to work.
    03-31-09 07:37 PM
  12. rorycalhoun's Avatar
    I have an 8330m as well and I cannot get google maps to use GPS either. Hope this is fixed soon.
    04-10-09 12:36 PM
  13. pntless's Avatar
    Same here with my 8330m. Google maps doesn't even seem to try to use the GPS while all other GPS applications I have tried work fine.
    04-10-09 01:08 PM
  14. viper157's Avatar
    Ditto here. 8330m with the .128 OS. Lots of gps software works but not google maps

    Posted from my CrackBerry at wapforums.crackberry.com
    04-11-09 10:24 PM
  15. VetteVert's Avatar
    I have tried every GPS app out there. To me, LIP was a dud. Way too cumbersome. I use Telenav if I want actual gps guidance, but Google maps is great for mapping (and latitude).

    VV
    05-27-09 06:34 AM
  16. VetteVert's Avatar
    Did you read the title of the thread? Or the section you are in?

    In no way did I say anything positive about amaze, just that GPS worked on an 8330m. This is about 8330 vs 8330m and Google Maps. I *want* Google Maps to work....

    VV
    06-11-09 04:30 AM
  17. leftie12's Avatar
    The latest curve 8330m update is .138. It is under the 83xx board.



    I would recommend updating to it first and trying again.

    Also, this is NOT the latest update for the 8330 model. That is .131.

    Also, what exactly is the difference between 8330 and 8330m o_O Why do they require separate updates and such, I got no clue.

    Anyways, update your 8330m to the update I linked to and see if that fixes your problem.
    My 8330m came out with .138 and my GPS doesn't work either.
    12-07-09 04:12 PM
  18. Gunnyman's Avatar
    There is a NEWER version of Google Maps 3.2.1. It works perfectly on my 8330m.
    12-07-09 04:26 PM
LINK TO POST COPIED TO CLIPBOARD