1. Seanior's Avatar
    I have a curve 8330m
    Carrier Cellular South

    GPS works GREAT with BBMAPS, AMAZE, Trek Buddy...
    No Dice with Blackstar, GPSED, Google, Gmaps...

    So, I decided to try the GPS FIX, and everything took! All the settings stick, but there is absolutely no change in what apps work and what ones don't.

    The strange thing is that GPSED, and Blackstar Lock after a search for 5 seconds or so, but lose the lock forever after 5 seconds?

    I "think" these apps are crashing the GPS because its a few minutes before any other apps will lock on. I went to the home screen and hit alt/LGLG and the event log shows LOCATION API - ERROR....

    My questions is - is this SOFTWARE or Hardware related?

    I am with Cellular South, so in QPST should I change server IP settings to another Service / Port??

    If NOTHING worked it would be one thing... I know there is Drama with Google Maps, so I won't go there, but these simple little programs that worked fine on a regular 8330 won't work now on the 8330m?

    Any direction, guidance, help, input, advice, relief???
    05-14-09 11:18 AM
  2. Seanior's Avatar
    Am I really the only dude in this spot?
    05-14-09 11:38 AM
  3. rasmith3530's Avatar
    I've also got the "m," mine with US Cellular. I could barely get GPS to work (twice over the course of a week) until I did the fix that TheHeartlessHero documents on these forums.

    Since then, I have had success with BB Maps, amAze, Nav4All, Telmap Navigator, and Trapster. I haven't tried the two you mention as giving problems, and I believe the Google Maps issue is fairly well documented. It don't work!

    That said, I find that my Curve must be reset ocassionally in order for the GPS to be detected. I don't know why this occurs, but it does. Once reset, I can open Nav4All and see a dozen satellites in 10 seconds or less.

    I do believe that the server IP and port are essential to success, so you need to get the settings appropriate to your carrier.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-14-09 11:50 AM
  4. Seanior's Avatar
    Thanks for your response. The wierd thing is that (on those other 2 apps) the GPS LOCKS and then goes away forever until a restart of the app several minutes later. Could you maybe try the blackstar or GPSed app? GPSed Seemed to lock on while BBmaps was running, so I am slowly getting a little farther!

    GPSED link http://wap.gpsed.com/bb/gpsed_bb.zip
    BLACKSTAR link Blackstar Navigation - Download Now for Free

    The funny thing is that the only reason I am beating the bushes on this issue is that I have a fishing trip and all the Hot Spots lined up so I need a straight line navigation app to get me there! I guess I am just to cheap to go buy a gps for a single fishing trip!

    As for the IP address. I can only assume nothing would work if the IP and port were wrong. The only changes I had to make in QPST was to check all the boxes. The speed that the gps locks seems faster, so its not a total wash.

    Any feedback would be greatly appreciated!

    05-14-09 11:59 AM
  5. Seanior's Avatar
    Anyone Out There Experiencing This Issue With Any Gps App?
    05-14-09 02:22 PM
  6. Seanior's Avatar
    Bump! Help Me!!!
    05-20-09 04:49 PM