Built for Business - Learn more about BlackBerry KEY2
  1. Krickette's Avatar
    OK, so, I have an 8320, which I love. I use the wifi all the time, with no problem. I do not have any sort of data plan, I just use the wifi.

    My dad recently got the same phone. He got it *for* the wifi.

    His does not work.

    I went through, and every setting is the same on his as it is on mine, yet his will not work.


    When you scan for networks, you can choose one, and it will say that it's connected, but it doesn't give the normal options after of logging onto the hotspot browser. When I go on the browser, it doesn't work. I can't remember the exact error message, but it doesn't work.


    He's called ATT, he's emailed them, he's gone to stores, he's gone to the warrantee center, and none of them have helped. They either stared at it and saw that it says it's connected and handed it back to him saying it's working, or they've said that he has to have a data plan to use wifi, which is bull.

    can anyone think of a reason it might be doing this?!


    eta:

    OK, so reading more, it seems ATT might require a data plan, or something. However, I don't have a data plan, and online, i have no charges so far for internet/media usage. So....
    Last edited by Krickette; 03-26-09 at 07:33 PM.
    03-26-09 07:13 PM
  2. vp0392's Avatar
    I have a similar issue. we purchased two blackberry 8320 from ATT for * Wifi * . i have no data plan and want to use my wifi connection as a stand alone wifi connection and not get charged for data usages. Ive only had ATT for 3 months and because i don't have a data plan they charge me every time i use my browser. Ive gone through some of the guides and the wifi is still spotty, and i still get charged for data usage.

    I wanna know how i can use WIFI only with no data package and not get charged for anything. please advise
    Last edited by vp0392; 03-31-09 at 09:21 PM. Reason: i didn't spell check
    03-31-09 09:20 PM
  3. Krickette's Avatar
    well, I figured it out!
    My dad had gone to manage connections, and under mobile options, he turned data to "off". I hadn't even thought to look there, because I didn't realize it needed to be on until I was experimenting with my phone one night.
    He didn't want to turn it on because he was afraid of accidentally getting charged, but he didn't understand that our data is blocked, so we couldn't use data if we wanted to, and that way we can't get charged.
    Once he turned it on, it's been working just fine!
    so, that was our fix!
    04-01-09 02:42 AM
LINK TO POST COPIED TO CLIPBOARD