1. playplay1978's Avatar

    I understand that this issue has been discussed before and i've read posts about it but none of them can actually solve my issue. I'm really struggling and i have spent more than 2 days to no avail.

    I'm using JDE 4.70.

    I'm creating a library project which has a few classes in it and can be imported into app project. Firstly, the project works in both simulator and phone when i include all the source files and build them.

    However, what i want is a library which can be imported into other app project.

    Then, i took out those relevant java files and put them into a new Library project in a new workspace. So, i compiled it into jar, preverified it with

    preverify -classpath "C:\Program Files\Research In Motion\BlackBerry JDE 4.7.0\lib\net_rim_api.jar" "your_jar_filename" and got it from bin\output

    Firstly, i did this without deleting cso, cod and csl from the jar files. This followed by copying the jar file into "lib" folder of a new project

    i) just add the jar file into a new app project (although by default, there's no selection of "jar" in the dialog box). I built it successfully. I tried to run the project in both simulator and phone. Nothing happens. It seems like the app is hidden or what.

    ii) I tried "Properties->Build->Imported Jar Files". I built it successfully but same thing happened like in i) where it seems like the app is hidden or what.

    iii) So, i tried to create 2 projects in same workspace where 1 project is the app project and the other one is a library project with the jar file. I also set the project dependencies of the app project to the library project. I built it successfully but when i tried to run in simulator, it gave me

    "Exception java.lang.ClassCastException"

    Secondly, i repeated the compilation and preverification but this time i removed cso, cod and csl from the jar file. Then, i tried i), ii) and iii). I could not build for all these 3. It kept giving me errors, i.e.

    "Cannot Find Symbol"...

    Other than that, i also have tried setting the project to be of CLDC App type and then, got the jar file and repeated i), ii) and iii). All gave me some sort of error or did not work supposedly.

    I really don't know what else i can try... i'm really flattened now...

    Thank you sooo much...

    06-24-10 10:26 AM
  2. playplay1978's Avatar
    Anybody, please...

    Or, is there a sample which involves clear step by step which works?
    06-24-10 06:51 PM
  3. anon(5342392)'s Avatar
    I have answered this question before in the BlackBerry Java Development Forums, here is the link.

    Re: How to use lib project with blackberry project... - BlackBerry Support Community Forums

    As for the ClassCastException will be caused by an error in your programming logic which you will have to trace and fix, this is not a library issue, it will most likely be a programming issue.
    06-27-10 11:40 AM