1. 51smoker's Avatar
    Hi,
    I'm new to blackberry world. I tried to connect my bold 9780 to my computer through usb cable, but the desktop software cannot detect my device. I tried the clean uninstall that I found in this forum, and reinstall the desktop software, it didn't work.
    p.s, I also tried to repair the desktop software on my PC, but it says blackberry desktop software.msi is missing

    Anyone has clue what i can do to solve this problem?
    11-07-10 09:09 AM
  2. greggebhardt's Avatar
    Delete the current desktop software on your computer. Find a good registry cleaner and make sure ALL elements have been removed. Then try a new clean install and I think it will work fine.
    11-07-10 10:48 AM
  3. horheit's Avatar
    Hi! I am new Blackberry user and just bought a 9780 last Thurs. However, the desktop software is giving a me a lot of sleepless nights and grief until today.

    In short, Desktop Software version 6 can't run on my Windows 7 32bit. After installing, I launched it and the first thing that crash was Rim.Autodesktop.Update.



    After which, Desktop Software opened up nicely. I connected it and it could see my 9780. But when I click on "Configure Settings" in "Organizer", it crashed again. Gah...



    I looked through tons of forums (too many to count =)) and tried tons of suggestions. Did clean uninstall, clean up registry & reinstall (crashed); uninstall Outlook 2007, install Desktop Software 6 and ran it, crashed; turn off antivirus, clean uninstall & clean up registry and reinstall as administrator and ran the program as admin, crash.

    I am running out of ideas. I looked in the Desktop.log and noticed the lines:

    04:45:02.634|FATAL|26|Rim.Desktop.Shell|0|Fatal Application Error
    System.Security.SecurityException: Requested registry access is not allowed.

    So I tried another suggestion and tried taking ownership of HKEY_CURRENT_USER & HKEY_LOCAL_MACHINE. This somehow disabled my net access and I had to restore back to a previous restore point.

    Any ideas? The phone has been great this past one week, but the Desktop Software has been driving me nuts. All my work contacts and schedule is on my outlook 2007 and I really need to get it on the phone.

    PS: Oh, I forgot to add that when I installed it on my office public PC running Windows XP, it worked fine. And I notice that there's a difference. On the Windows XP machine, I could see the option to select the type of data you want to sync on the "organiser" page, but not so on the the Win7 machine.
    Last edited by horheit; 12-09-10 at 04:27 AM.
    12-09-10 03:56 AM
  4. horheit's Avatar
    FIXED!

    Software: Desktop Software 6
    OS: Windows 7 Professional 32 bit

    Ok, as I stated above, "Rim.Desktop.Autoupdate" was crashing whenever I launched "Desktop Software" version 6. On top of that, whenever I clicked on the [Configure settings...] button on "Organizer" in "Desktop Software", it will run for a while before the whole program crashes. And even if I were to close the program without doing anything, it too will crash.

    After combing through countless forums and stuff, I checked out the Desktop.log file and found an interesting entry:

    Date|Log Level|Thread ID|Module ID|Log ID|Message [2010-12-09 04:42:39.308]
    04:42:39.326|INFO |1|Rim.Desktop.Shell|1|Application Started
    04:42:39.338|INFO |1|Rim.Desktop.Shell|2|Rim.Desktop.exe Version: 6.0.0.43
    04:42:39.338|INFO |1|Rim.Desktop.Shell|2|OS Version: Vista [Microsoft Windows NT 6.1.7600.0]
    04:42:39.338|INFO |1|Rim.Desktop.Shell|2|CLR Version: 2.0.50727.4952
    04:42:39.343|ERROR|1|Rim.Desktop.Common|0|Failed to read registry key.
    System.Security.SecurityException: Requested registry access is not allowed.
    at System.ThrowHelper.ThrowSecurityException(Exceptio nResource resource)
    at Microsoft.Win32.RegistryKey.OpenSubKey(String name, Boolean writable)
    at Microsoft.Win32.RegistryKey.OpenSubKey(String name)
    at Rim.Desktop.Common.Utils.Utilities.GetPathFromRege x(String key, String keyname, RegistryKey regkey)

    I took up someone's suggestion and tried to take ownership and permission of HKEY_CURRENT_USER and HKEY_LOCAL_MACHINE. But that only screwed up my network connections completely. But thanks to Windows 7 "Restore this computer to an earlier point in time" utility in Control Panel, I was able to reverse the damage.

    Then it occurred to me to try to take ownership and permission of "HKEY_CURRENT_USER\ SOFTWARE\Research In Motion" and "HKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion".

    Taking ownership of the former went well but trying to do so for the latter threw up the error message "Registry Editor cannot set Owner on the key currently selected, or some of its subkeys." So I decided to take ownership of each individual sub-keys in "HKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion" to see where the problem was.

    I finally manage to narrow it down to "HKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion\AppLoader".

    But of course the challenge now was to figure out how to take ownership of this sub-key. I found this site Grant Read Write (Full Control) Permissions on Registry Keys (Fix Cannot Import and Access Denied Error in RegEdit) My Digital Life and followed the instructions there.

    After that, I tried launching Desktop Software 6 again. This time round, it worked. "Rim.Desktop.Autoupdate" didn't crash and neither did Desktop Software when I click on [Configure settings...] or tried to exit the program.

    The steps to edit the registry.

    1) Make a back up of the registry file or just make sure that Windows 7's restore program has the latest image of your system.

    2) Click on the Windows start button on the lower left corner of your task bar. That's the one with the Windows logo on it.

    3) In the space above it with the magnifying glass on its left, type "regedit" (without the quotation marks of course) and hit [Enter].

    4) Look for "HKEY_LOCAL_MACHINE", click on it and scroll down to look for "SOFTWARE". Click on that and then look for "Research In Motion"

    5) Within that sub-key, you should see "AppLoader", "Blackberry", "Blackberry Transcoder", "Common" and "DesktopAutoUpdate".

    For the steps on how to take ownership, please refer to Grant Read Write (Full Control) Permissions on Registry Keys (Fix Cannot Import and Access Denied Error in RegEdit) My Digital Life (I am too lazy to type it out in full and I am not sure if I will be infringing on their copyright if I just copied and pasted)

    Oh, and please remember to make sure your userID or the user group you belong to has Full Control over those sub-keys.
    Last edited by horheit; 12-09-10 at 04:02 PM.
    12-09-10 03:38 PM
LINK TO POST COPIED TO CLIPBOARD