1. JRFI's Avatar
    I also posted this in the Bold group discussion thread under "New or Refurb" but thought I might get some feed beck here as well.

    When I connected the phone to the BlackBerry Desk Top Manager for the first time and clicked on Device Properties the number displayed in the Phone Number field is not mine.

    The PIN and IMEI numbers match but the phone number is not mine though it is in my area code. I tried a reverse look-up and it came back as an AT&T mobile number. I tried calling it but the call went to voice mail.

    I bought this phone NEW or at least thought I did! Now, I think it may have been used and returned to stock and re-sold as new. Any thoughts on how this could happed or instructions on how to replace the displayed phone number with mine would be appreciated.

    I will be going back to the retailer tomorrow.
    07-28-09 03:35 PM
  2. JRFI's Avatar
    No one can provide any info on this?
    07-31-09 12:43 AM
  3. darkknightuga's Avatar
    Never heard of one randomly doing that before. Interesting...

    Have you tried to activate (read: reprogram) it using *228? Maybe the OTA programming will fix the issue.
    07-31-09 06:47 AM
  4. Sith_Apprentice's Avatar
    Go into your options > advanced options > SIM card and list the number that is shown there. Also, *228 is a VZW/CDMA thing
    07-31-09 06:53 AM
  5. darkknightuga's Avatar
    Ah, true. I completely forgot to look at the carrier. Thanks Sith
    07-31-09 07:06 AM
  6. Sith_Apprentice's Avatar
    No worries at all. I am assuming the number that the SIM is showing may be incorrect, while the actual number on the SIM is correct. Also, what does it show as your number when you make a call, on your screen, not another person's caller ID.
    07-31-09 07:10 AM
  7. MobileMadness002's Avatar
    Call the phone number from an different phone and tell us what happens.
    07-31-09 08:21 AM
  8. JRFI's Avatar
    Never heard of one randomly doing that before. Interesting...

    Have you tried to activate (read: reprogram) it using *228? Maybe the OTA programming will fix the issue.
    It isn't random, does it every time.
    Go into your options > advanced options > SIM card and list the number that is shown there. Also, *228 is a VZW/CDMA thing
    The number here is mine.
    No worries at all. I am assuming the number that the SIM is showing may be incorrect, while the actual number on the SIM is correct. Also, what does it show as your number when you make a call, on your screen, not another person's caller ID.
    It shows mine.
    Call the phone number from an different phone and tell us what happens.
    I called the mystery number once and it went to voice mail. If I call my number the phone rings.

    I'm going out today to check on the Tour at Verizon. (I know it lacks Wi-Fi )
    I was on Verizon for a few years after the initial contract expired and just cancelled this month. They said since I left in good standing I can sign up again as a new account and be entitled to all rebates.
    07-31-09 11:22 AM
LINK TO POST COPIED TO CLIPBOARD