1. ultiblue99's Avatar
    So I tried downloading some software a month ago, not sure as to which was the right one, and it made it almost through the download when it said something went wrong and couldn't finish. Ever since then my comp won't recognize my blackberry and the desktop manager won't either. This means no recharging through my comp, sync..etc.

    This wasn't a huge problem, I figured I would call and ask someone how to fix it. The big problem is over the last few weeks, buttons seem to have a mind of there own. I think it is mainly the ball since it will press itself all the time, sending multiple calls to the last person, hitting mute and unmute a thousand times while I am in the middle of the call. I need help, how can I fix the problem if it is a software problem when I can't even hook it up to my computer!

    Hopefully someone knows, since my phone is unusable right now and I need it daily for work.

    Thank you anyone for advice or help.

    06-17-09 09:34 PM
  2. BigBadWulf's Avatar
    Delete your USB port driver for your device, restart your PC, and reconnect your device. The driver should load automatically and have you back in business.
    06-18-09 04:42 AM
  3. ultiblue99's Avatar
    not sure how to do that, sorry, thanks for getting back to me so quickly
    06-18-09 06:28 AM
  4. BigBadWulf's Avatar
    My computer, control panel, ports, find the one listed that says blackberry, right click on it and select delete.

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by BigBadWolf; 06-18-09 at 09:03 PM.
    06-18-09 06:55 AM
  5. krokus's Avatar
    If that fails, try a System Restore. Go to Start, Help, System Restore and then choose the closet date before you downloaded the software that caused the problem.
    06-18-09 12:17 PM
  6. ultiblue99's Avatar
    that worked, my bb hooks up to my comp, hopefully going through the steps for the new software fix the other problems.
    06-19-09 04:22 PM
  7. BigBadWulf's Avatar
    Super, you using my guide to free up memory?

    Posted from my CrackBerry at wapforums.crackberry.com
    06-19-09 04:27 PM
  8. ultiblue99's Avatar
    So I am trying to install that guide for the new software, but now I can't connect anymore. I downloaded the three programs, and then tried to connect my phone to the comp again and it won't do it. I then tried deleting the drivers again and restarting the comp, but when I plugged the phone in, I got nothing like before prompting me to download the new drivers again. It just won't connect. What do I do now?
    06-20-09 07:08 AM
  9. BigBadWulf's Avatar
    Reboot your PC, and then plug in your device. It should recognize the new hardware through the USB. If it doesn't the first time, disconnect it and try it again.
    06-20-09 07:11 AM
  10. ultiblue99's Avatar
    nope, still won't connect
    06-20-09 07:20 AM
  11. BigBadWulf's Avatar
    I just went through similar with mine. I ended the DM through task manager, and when I restarted it wouldn't recognize my device. I closed and reopened DM and then it read it. You can also click on none, and then select the USB port. You should have a device manager icon in your task bar active processes you can use too.
    06-20-09 07:30 AM
  12. ultiblue99's Avatar
    none of that is working, not sure what to do now, system restore like the other guy said and just forget trying to download the new software? Or can I still put the new software on with the old desktop manager?
    06-20-09 07:43 AM
  13. BigBadWulf's Avatar
    You don't want to do a system restore. Try running the application loader, even though it says the device is not present.
    06-20-09 07:48 AM
  14. ultiblue99's Avatar
    tried a system restore already, went back to the old desktop manager. Only problem is it still won't connect and when I go into device manager it doesn't show any ports, so I can't even delete anything!
    06-20-09 08:04 AM
  15. BigBadWulf's Avatar
    Go into control panel, system, device manager, usb hubs, root hubs, power management, uncheck the boxes to have it save power on all root hubs, reboot your system and try it again.
    06-20-09 08:40 AM