1. clancyberry's Avatar
    I need to run an earlier version of Desktop Manager than v5.0.1 that I am running now in order for my Franklin Covey PlanPlus software to work. I am told I need v4.7. Can someone walk me through this process?
    05-04-10 03:36 PM
LINK TO POST COPIED TO CLIPBOARD