1. ssbtech's Avatar
    I have a computer sitting around running Server 2003. Nothing fancy.

    I attempted to install BB Link onto it hoping I'd use that for remote file access since my Win7 system is off most of the time that I'm out (and RFA doesn't work properly on it).

    Installation went fine, but after the reboot it shows "BB Peer Connection Manager encountered a problem and needs to close, blah blah..."

    BB Link boots up, but there's nowhere to enter my BlackBerry ID. Clicking on "Sign in" just gets a "could not connect" error. There's nowhere for me to enter my login credentials.

    Any ideas? Thanks.
    11-06-13 10:49 PM
  2. pkcable's Avatar
    My guess is that BB Link is just not compatible with that older version of Windows Server.
    11-08-13 01:40 PM
  3. RyanGermann's Avatar
    EDIT: Copying the registry wasn't necessary: making the .exe files under "Common Files/Research In Motion/Tunnel Manager" run as Administrator was necessary, adding IP6 support to the physical network addaptor was necessary, and the trick with getting the certificate by right-clicking in Link when you get the Login screen, copying the long URL from the Properties panel, opening in IE and accepting blackberryid.blackberry.com certificate and into the "trusted sites" was necessary. I've just reinstalled WHS 3.0 on my old HP Media Smart server from scratch and had to try this again, but this time I left out the registry jiggery-pokery, and vee-ola, it works.

    Read on, just don't bother with the Registry copy / import.

    My guess is that BB Link is just not compatible with that older version of Windows Server.
    I have a Windows Home Server which is based on Windows Server 2003 and I tried installing BlackBerry Link on it (because it's on that server where the file shares I want to have Remote Access to reside) but it crashes at launch. I haven't tried to debug it... but if I could get it working that would be the ultimate home server add on, to access via my Z30 from anywhere in the world where I have a WiFi connection. Suck THAT, Apple "iCloud" lovers! :-P

    EDIT: I have a few minutes: I'll try now! :-)

    EDIT SOME MORE: BlackBerry Link operates over a VPN that requires IPv6. On my WHS, IPv6 wasn't installed on the WHS network adapter. I installed it and it's still not working... I'll keep trying stuff.

    EDIT I got a bit further: I went into the "Program Files \ Common Files \ Research In Motion" branch and allowed the apps I found in there to run "as any user" or whatever... the apps profiled here:


    and then I reinstalled BB Link on my WHS (via Remote Desktop)... and now I can get Link to load and I can click "Sign In" at the top of the window and it shows me a form in which to enter my BBID and Password: but clicking the "Sign In" button below fails silently. Note I have Windows Firewall disabled on my WHS (I have a hardware firewall) so that shouldn't be interfering... but it's not quite there yet.


    Ok, this is bizarre, and kind of proof that I'm gifted :-P

    First, I went through every executable under the "Common Files..." branch above and made sure they were all allowed to run as any user.

    I try to log in via BB Link and it still fails silently.

    I went to my windows registry on my Windows 7 computer which does work with Link / Remote File Access and I exported the branch of the registry that contained all the BlackBerry settings: it was at:

    HKEY_USERS\XXXXX\Software\Research In Motion

    where XXXXX is a long GUID-like key that is unique to my user account on Windows 7.

    So I looked up the user account for my main WHS user (not Administrator: same ID as I use on Windows 7) and copied that from the registry and in the .REG file I replaced the Windows 7 GUID with my WHS user GUID... so




    in the .REG file and then I imported that into my WHS registry.
    Then, from within BBLink on my Windows Home Server and I right click in the area of the Login screen and I get a context menu suspiciously like that of Internet Explorer.

    I do a "Properties" thing and see that within there is a "callback URL". I copy and paste the callback URL into Internet Explorer and I get a popup about how https://blackberryid.blackberry.com isn't trusted so I elevate it to trusted.

    At some point I see a "View Certificate" button and click it and choose "Install Certificate".

    Oh, and I right-clicked in the BB Link and changed the encoding to "Auto Select".

    I then I go back into BB Link and log in... AND IT WORKED. I see my BB10 device listed there and have access to Remote File Access... and there it is, my server, showing up in File Manager on my Z30... and as I type this, I'm listening to "More than a Woman" by the Bee Gees, with my Z30 resting nicely on my desk with it's stellar built in speakers putting a big smile on my face.

    I love being a genius. It's so convenient!

    Now, to test if it persists across a WHS reboot...

    EDIT: Yes, it does, and I don't have RDP into the server either and log in then close the RD window, and no, Link doesn't have to be running (it's background services are taking care of everything evidently as suggested above).
    Last edited by RyanGermann; 02-14-14 at 03:57 PM.
    11-08-13 02:52 PM
  4. RyanGermann's Avatar
    Dammit after a clean install of Windows Home Server, I get errors when trying to install Link, because the "tunmgr.exe" service won't start. I wonder if I use an older version of Link than the current (1.2.3) it will work?
    08-04-14 12:05 AM

Similar Threads

  1. Facebook Account Event Syncing Problem on Z30
    By BadGoliath42 in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 04-02-15, 09:30 PM
  2. Replies: 11
    Last Post: 11-11-13, 08:13 AM
  3. Replies: 2
    Last Post: 11-08-13, 10:29 AM
  4. Replies: 11
    Last Post: 11-07-13, 12:04 AM
  5. BB Q10 Software Update Fail! Help Please!!!
    By seasonsgreetings in forum BlackBerry Q10
    Replies: 3
    Last Post: 11-06-13, 09:54 PM