1. Natedogg14's Avatar
    Issue kinda grew from this thread.

    I just replaced my Sandisk 32Gb ultra with 64Gb extreme plus (both exFAT I believe). Getting the "the handle is invalid." when I click on the Y mapped drive for the SD card. When I switch to mass storage it works fine. I am running Win 7 with most recent versions of link and BB10 and rebooted both devices.
    06-04-14 12:42 PM
  2. DiscoKing426's Avatar
    I have the same issue when switched to exfat on my 64gb SD card.

    Posted via CB10
    06-04-14 02:54 PM
  3. r3m00r3's Avatar
    Same problem here. It's a little quirky as BlackBerry Link can see and access the files, as well as Microsoft rich tools (used it to move data back to my sdcard), but windows explorer and the command prompt can't.

    Posted via CB10
    06-05-14 01:30 PM
  4. Heinz Katchup's Avatar
    Same issue here. WTF?!? Happened after recent SD format to exFAT.

    Posted via CB10
    06-05-14 04:37 PM
  5. Natedogg14's Avatar
    BB10 seems to work fine with 64 Gb. Mass storage mode works and connects to link fine for sync of music, etc.

    Looks to be a Link issue to me. Seriously though Blackberry, I've always been a fan, but how do you not test for that before releasing an update... That is basic functionality of the software.
    06-06-14 08:35 AM
  6. Natedogg14's Avatar
    BB, still waiting for a fix on this. I really used to like dragging and dropping files through windows explorer...

    I just got the latest OS update today and still no worky.
    07-01-14 12:02 AM
  7. nmckinlay's Avatar

    Just bought a SanDisk 64gb card. It's out of the box exFat, and Q10 prompted to download drivers. Everything works great but I get the "handle is invalid" when attempting to access the fileshare via explorer.

    BB, please get this fixed ASAP!! How can we report this bug to them???
    07-13-14 05:50 PM
  8. Stwutter's Avatar
    Just had the same issue with my 128gb SD in my Z30. Last week I dragged/dropped in the usual way I always had with 32/64gb cards, but today got the 'Handle is Invalid' prompt.

    If you enable mas storage mode, you can drag drop files from the SD card which should show up under drive 'E' on your PC.

    In case it helps.
    07-21-14 04:49 AM
  9. Merboy6969's Avatar
    mass storage is not usable (option is greyed out) if you have encrypted your sd card. Just a heads up.
    Hope this is resolved soon, what a pain.
    07-28-14 04:03 PM
  10. jope28's Avatar
    EDIT: Got a small OS update today. Just ignored it at first since the OS version didn't change. Just thought it was some carrier settings or something.
    And it turns out that I can now access the exFat formatted 64GB card through wifi!

    Same issue here.
    I bought the Sony 64GB card that was posted on the CrackBerry front page not too long ago and now can't access the mapped drive from wifi on Windows 7 like I could my old 32GB cars.

    Weird thing is, that my Xbox360 can access the SD card through wifi to open media files. I can open and stream movies from the card on my Q10 through the local network just as I did before. I believe that uses DLNA though.

    Frosty white Q10/
    Last edited by jope28; 08-12-14 at 09:51 PM.
    08-10-14 10:51 AM
  11. C Man1's Avatar
    Had the same problem as everybody else (Handle Invalid) on a SDAX card. Rechecked to find USB Mass Storage was off so turned it on and also had to set a Wi-Fi Storage password. Wi-Fi still doesn't allow the card to be recognised but now connecting with USB cable adds a new connection as a normal media card and totally accessible.

    I know it is a work around but anything that works is good.
    08-16-14 07:36 AM
  12. jope28's Avatar
    Issue is again present on the leak Q10SQN100-1/

    Frosty White Q10S/
    08-23-14 09:24 PM
  13. amirnabilkamelsaad's Avatar
    Got this problem again after I Installed Blackberry Blend for my new 10.3. After I ran into problems, I uninstalled Blend, restarted my computer and then installed the same version of Link but, now I have the handle is invalid error.
    Very frustrating...any solutions yet?
    09-26-14 08:56 PM
  14. amirnabilkamelsaad's Avatar
    I think it is a windows problem rather than Blackberry per se, the web is riddled with this error message from various causes and mostly related to wireless connections/network.
    09-28-14 02:19 PM
  15. westshield's Avatar
    I suddenly ran into this problem after I upgraded to a z30 from my z10. previously it worked just fine. I installed my 64g sd into the z30 and now this??? What gives. I find it easier ot organize my data via explorer than link, but now I can't. I formatted the card and still get the same message.
    12-19-14 08:56 PM

Similar Threads

  1. theScore is now an Android port!
    By the_game969 in forum BlackBerry 10 Apps
    Replies: 147
    Last Post: 10-15-14, 09:27 PM
  2. Image on the Armchair CEO thread
    By louzer in forum General BlackBerry News, Discussion & Rumors
    Replies: 8
    Last Post: 06-05-14, 11:37 PM
  3. Bold 9790 missing BB Maps
    By colinstone in forum BlackBerry Bold Series
    Replies: 1
    Last Post: 06-05-14, 11:55 AM
  4. Be in BlackBerry coz I am
    By avnishsp in forum BlackBerry 10 OS
    Replies: 10
    Last Post: 06-04-14, 07:00 PM
  5. Handheld Mic for BlackBerry 10
    By rpimpsner in forum More for your BlackBerry 10 Phone!
    Replies: 1
    Last Post: 06-04-14, 12:30 PM