1. jmimac351's Avatar
    I and many other have had trouble getting BlackBerry Link to sign into their BB ID. There was no rhyme or reason for why my work machine (PC) was able to sign into my BB ID on BB Link, but my home machine (PC) was not. I tried enabling / disabling / being annoyed that "RIM can't make this work?" and nothing worked... playing with firewall settings... NOTHING WORKED!!!

    This evening I downloaded the BlackBerry Blend Software found here for my PC:

    BlackBerry Blend ? Desktop Software for BlackBerry - US

    As I went thru the installation process for this software, there is a screen that offers you 3 options for installation and "UPDATE"

    1 - It gives the checkbox option to INSTALL BlackBerry Blend

    2 - It gives the option to UPDATE BlackBerry Link

    3 - I think the third option was to UPDATE Device Drivers or something along those lines.

    I allowed it to do all three options. I then restarted my machine, as it said was needed, and I opened BlackBerry Link. I then clicked on Sign In (figuring the same annoying... "Cannot login check your internet connection blah blah..." message would be displayed) and don't you know... after a few seconds I was presented with a BB ID login screen!

    I then logged into my BB ID with no problem.

    After doing some digging, this may be the issue... I now have BB Link software version on my machine.

    If you go to the BlackBerry download page for BB Link, it shows the BB Link version as

    The version I have is later than what is posted on the BlackBerry website and, who knows, maybe that's the fix.

    Worked for me. Good Luck.
    10-28-14 08:43 PM
  2. hamsterwheel's Avatar
    Yes the blend software apparently has newer drivers as well as new link, and the new leaks require this. Glad you finally got it to work.
    10-28-14 10:25 PM
  3. ubizmo's Avatar
    Yes! It worked! You'd think BB Support would have thought of this, but I'll take a solution from any source. For the first time, I have Remote File Access on my home PC!
    11-02-14 08:54 AM
  4. jmimac351's Avatar
    Yes! It worked! You'd think BB Support would have thought of this, but I'll take a solution from any source. For the first time, I have Remote File Access on my home PC!
    11-03-14 08:03 AM
  5. MobileMadness002's Avatar
    Although I loaded the Blend software before anything this time around, it is great that you shared your solution with us. Thanks.
    11-03-14 08:05 AM
  6. chrissym68's Avatar
    Ok this is weird. I have a Passport. I downloaded the BlackBerry blend software which included the drivers and BlackBerry Link.

    Blend does not open. I have Windows 8.1 64bit. BlackBerry Link opened but similar to the OP it wouldn't allow me to sign into BlackBerry ID. This is version. 24 on the end.

    After reading the OP I unistalled the whole BlackBerry software package and installed just BlackBerry Link. Version. 56. Hey presto I can now sign into BlackBerry ID but if then install BlackBerry Blend it replaces Link version. 56 with the older version. 24. So back where I started.

    So I deleted everything again and have now just got Link installed version. 56 which works with BlackBerry ID.

    When I installed Blend a window appeared giving options to install Blend Link and Drivers. Link and Drivers were greyed out. But when it starts to install it continues to replace the newer version of Link with the older one.

    Can I just download Blend I wonder? This might cause Blend to actually work on my PC having the newer version of Link installed.

    Any thoughts?

    Posted via CB10
    11-05-14 08:22 AM
  7. jmimac351's Avatar
    I would keep the Link version that works and try to download Blend and not do the update to Link during install. I was able to select or deselect to update Link during the Blend install. I would install Link first, then Blend. I suspect if you try to install Blend without having Link installed it's going to force you to install it, and it may not be the one that works for you?

    Good luck.
    11-05-14 07:21 PM
  8. Anilu7's Avatar
    The new Link is the one that doesn't work for me. The old Link works - allows me to sign in. Blend never has worked. It just does nothing when I click on the icon on my desktop - whether double-click or 'run as administrator'.

    By the way, if you try to install Blend on top of the older Link (uncheck the new version) it uninstalls Link altogether.
    11-16-14 01:23 AM
  9. chrissym68's Avatar
    This is exactly the same problem I originally had. Only a complete re-install of Windows allowed me to get Blend and the latest version of Link to work.
    11-16-14 01:27 AM
  10. Anilu7's Avatar
    What Windows version did you have before and did you upgrade or re-install the same one?

    Posted via CB10
    11-30-14 12:06 AM
  11. chrissym68's Avatar
    What Windows version did you have before and did you upgrade or re-install the same one?

    Posted via CB10
    11-30-14 04:25 AM
  12. chrissym68's Avatar
    I had 8.1 installed. So had to re-install 8.1. Try scanning your whole system for any bugs or malware first. This might solve the problem without having to re-install.
    11-30-14 04:28 AM
  13. Anilu7's Avatar
    Already done multiple scans and changed my security software. It's also set up to allow all Link and Blend exe files through.

    Posted via CB10
    11-30-14 02:11 PM
  14. chrissym68's Avatar
    Looks like there is only one option left then. The fault isn't the Blackberry software. It's something in your Windows OS that is stopping the app to work. A complete re-install is your only option left. Has to be a proper wipe though. I tried a Windows Refresh but that didn't work. Good luck.
    11-30-14 02:15 PM
  15. jenkitp's Avatar
    I have the issue that I can log in with my BBID on v1.2.3.56 but not on v1.2.4.24. Same laptop so it is not the Windows software. Also I cannot deselect the Link or Drivers when I try to install Blend only. Run as administrator does not change anything. Any suggestions? (running Windows 7 SP1 64-bit)
    12-01-14 02:29 PM

Similar Threads

  1. Replies: 75
    Last Post: 12-16-14, 09:17 PM
  2. Why is my snap2chat glitching so much?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 11-20-14, 09:55 PM
  3. Replies: 1
    Last Post: 11-05-14, 10:01 AM
  4. Blackberry Blend IS working on my Z10
    By Gab iRepare in forum BlackBerry Z10
    Replies: 34
    Last Post: 10-30-14, 12:11 PM
  5. Problem with downloaded app
    By EagleStephen in forum More for your BlackBerry 10 Phone!
    Replies: 2
    Last Post: 10-29-14, 03:29 PM