1. Avery8900's Avatar
    I have an unlocked Z10 that will not connect via usb cable. I have researched on the forums but it seems everyones problems are a little different from mine. Link is installed on windows 7 x64 machine and can and does sync media with he device. I occasionally get an error saying the device drivers failed to install but everything still works fine.

    I want to do a back up so i can upgrade without losing all my data. I've updated my phone several times without doing a back up but its frustrating losing contacts apps and data. Is there a way to force install the drivers or has anyone found a way to make the cable connect?
    10-23-13 09:07 PM
  2. Elite1's Avatar
    Have you tried some simple troubleshooting like trying a different USB cable and/or a different USB port on the PC?
    If you have access to one, it might be worth trying on a different PC too, just to know whether or not that works.

    Have you uninstalled DM from your PC? If not, do so through Control Panel, reboot PC, try again.

    PS Fixed your thread title typo.
    10-23-13 09:10 PM
  3. Avery8900's Avatar
    I have tried different cables and all the ports on my laptop. I haven't had access to another computer to try that but that was going to be my next attempt. I am pretty sure I removed all legacy software and downloads when I encountered this problem when I first got my Z10. I will double check today when I get home from work and try again.
    I bought my phone unlocked from gsmnation could that have anything to do with the failed device drivers or anything?

    Thank you for fixing the typo. I prefer my Z10 keyboard to all other keyboards

    Posted via CB10
    10-24-13 08:08 AM
  4. misterabrasive's Avatar
    I have the same Win 7 64 and also get the same device drivers failed to install, but I can still backup my Z10 with Link without any problems. Don't know why. Everything connects eventually. Sometimes have to wait a few minutes. Syncs without any problems, too.

    Never, but Never, Question the Engineers Judgment!
    10-26-13 08:41 PM
  5. Avery8900's Avatar
    That's the thing my device can sync, but I will not do a backup. All my media syncs but cannot do a back up.

    I used an old xp machine and was able to download link and do a backup. Perhaps it's just a 64 bit problem

    Posted via CB10
    10-27-13 11:17 PM
  6. joeldf's Avatar
    I can tell that it's not a 64 bit issue. I'm running Link on a Win 7 Pro 64 bit and have no such problems.

    Not that I can help much beyond simply letting you know that having a 64 bit OS isn't the problem.

    Posted via CB10
    10-30-13 01:58 PM

Similar Threads

  1. Replies: 24
    Last Post: 02-06-14, 12:27 PM
  2. Successful BBM Launch Points Out A Survival Route For BlackBerry
    By W Hoa in forum General BlackBerry News, Discussion & Rumors
    Replies: 39
    Last Post: 10-25-13, 11:47 AM
  3. BBM on Samsung Galaxy Tab 2
    By goodayeh in forum General BBM Chat
    Replies: 9
    Last Post: 10-24-13, 10:59 AM
  4. When is 10.2 release for Cambodia?
    By Monrieach7 in forum General BlackBerry News, Discussion & Rumors
    Replies: 2
    Last Post: 10-23-13, 11:51 PM
  5. How to backup BlackBerry Z10 password keeper infor
    By leslie_chow in forum BlackBerry Z10
    Replies: 2
    Last Post: 10-23-13, 11:35 PM