1. missmayberry's Avatar
    Alrighty then. First post.

    I've had my BB 8100 for several months, and recently bought a microSD card. Mass storage is set to on, no encryption, etc, etc. But when I open Desktop Manager, it still only says 'Device Memory' and doesn't see the SD card at all. I know at least a couple of others have had issues with this, but is it really common? Hopefully there's some kind of quick fix.

    TIA,
    Amanda
    Last edited by missmayberry; 01-06-08 at 05:20 PM.
    01-06-08 04:50 PM
  2. jsanders's Avatar
    woohoo, first post! Welcome!

    Well, it isn't really common, but it does happen. Can you see the SD card from the BB at Options > Media Card?

    It could need formatting.
    01-06-08 04:53 PM
  3. missmayberry's Avatar
    Okay, I went to check that, and I couldn't see this before, but now there's a notice at the bottom of the Media Card page that says 'the media card is not available because Mass Storage Mode is currently in use.' What does that mean?
    01-06-08 05:19 PM
  4. justdigphones's Avatar
    That means you have the phone plugged in with mass storage mode on. You can unplug the phone to see if it'll allow you to access it then.
    If so try this, Options>Advanced Options>Media Card>Menu>Format Card

    Hope this helps.
    Last edited by justdigphones; 01-06-08 at 10:02 PM. Reason: finish post
    01-06-08 09:55 PM
  5. missmayberry's Avatar
    No dice. Hmm... may be contacting support on this one.
    01-07-08 12:49 AM
  6. Bla1ze's Avatar
    Does your computer recognize the card when mass storage mode is enabled?

    ie...show up as an extra hard drive on your pc

    PS: AT&T will not help you out with this any further then anyone else here already has, it'll come down to a transfer to RIM for review or offer you a new device through warranty lol. (even though it may NOT even be a device issue)
    01-07-08 12:59 AM
  7. zerog46's Avatar
    You might need to rename the drive for it to show up on your PC.
    01-07-08 01:03 AM
  8. jyurick's Avatar
    you didn't mention the size of the card you installed either, it just may be that your device OS is not up to recognizing the card if it's one of the newer microSDHC ones (greater than 2gb). There is another post on here about the size limitations and the device OS you need to be running for the card to be recognized. If that's the case update your pearls OS and that may help out.
    01-07-08 10:36 AM
  9. missmayberry's Avatar
    The card is 1GB. How do I rename the drive?

    (Thank you guys so much for your advice, by the way!)
    01-07-08 01:29 PM
  10. teofil's Avatar
    Well I am a total newbie but I had the same exact question/problem. With my 8100 bb I can only see the media card through windows (ie My Computer) not through the desktop manager. I also get the mass storage mode message when I select media card with my bb plugged into my PC. I only see the device memory when I use the desktop manager \ media manager but I can see my bb as a removable disk drive (E: in my case) when I use windows explorer. What happens if you select the media icon with your bb not connected to your PC? Not sure if this is normal or correct but it is the way mine is working.
    01-07-08 08:58 PM
  11. teofil's Avatar
    Missmayberry,

    I played around with mine a bit more and think I have got it figured out.....If you want to use the Desktop Manager\Media Manager to manage your files on your memory card then you need to set the "Mass Storage Mode Support" to off. If you want to have your blackberry behave like a memory stick and be seen as an external drive when you plug it into your PC's USB port then you want to set the "Mass Storage Mode Support" to on, but if you do this your bb's media card will not be seen by the Media Manager. I have gone back and forth with mine and this is what I have found, I don't know if there are other considerations at this point and I am admittedly a newbie, hopefully someone with more experience can shed some light on this topic.

    I hope that helps.
    01-08-08 12:57 AM
  12. missmayberry's Avatar
    That worked beautifully! Who knew?

    Thank you so much.
    01-08-08 07:34 PM
  13. TGKJR's Avatar
    Had same problem of BB Tour. What I discovered is that on the phone I had to go to options, memory & say yes to auto enable mass storage mode when connected.
    05-07-10 10:40 AM
  14. joeldf's Avatar
    Missmayberry,

    I played around with mine a bit more and think I have got it figured out.....If you want to use the Desktop Manager\Media Manager to manage your files on your memory card then you need to set the "Mass Storage Mode Support" to off. If you want to have your blackberry behave like a memory stick and be seen as an external drive when you plug it into your PC's USB port then you want to set the "Mass Storage Mode Support" to on, but if you do this your bb's media card will not be seen by the Media Manager. I have gone back and forth with mine and this is what I have found, I don't know if there are other considerations at this point and I am admittedly a newbie, hopefully someone with more experience can shed some light on this topic.

    I hope that helps.
    Well, I'm not a newbie when it comes to my Pearl - had it for 3 years - but I only just last week bought my first sd card for it. A 4GB card, I stuck it in, the BB saw it immediately (no formatting needed), and with Mass Storage Mode turned on I can see it both as a directly accessible drive in Windows and DM's Media Manager sees it too.

    So I don't know what that means.
    Last edited by joeldf; 05-08-10 at 01:24 AM.
    05-07-10 06:50 PM
  15. joeldf's Avatar
    Okay, I have to update this.

    My 8100's SD card works in both Windows (as an accessible drive in the Explorer), and in the Media Manager on my work computer running Win XP 64-bit.

    However, at home running regular 32-bit XP, I found that I do have problems. With mass storage turned on, Windows does show a drive, but it's not accessible (I think its the device memory because that's what it's always done even before the SD was inserted). And Media Manager can't see it.

    Turn Mass Storage off and the MM can see the SD drive but Windows still can't see it.

    I guess the 64-bit driver just works better.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-12-10 12:39 AM
  16. Ophious's Avatar
    Simple problem (hopefully)!! I encountered a similar problem with my work computer. I couldn't get my card to show up in explorer at work but at home on my Windows 7 computer it didn't have any problems. I ended up going into Disk management (Start, Control Panel, Admin Tools, Computer Management, Disk Management). I noticed that my memory card drive (Storm 2 shows up as two drives when hooked up through USB) was labeled "H". In explorer I had a shared drive labeled "H" as well and it seemed to take priority over my Blackberry Memory card. Once I changed the drive label to another UNUSED drive letter it solved the problem.
    06-22-10 03:21 PM
  17. jovl's Avatar
    Hi people

    I have a similar problem, I have my blackberry pearl 8120 for couple weeks ago and I bought a new media card so I can store more pictures and music. The problem that I have is that my mac (i'm using mac leopard) doesn't recognize the card and I can't transfer anything to the blackberry. Also every time that I try to sync my blackberry when I try to add music a message shows up with this message "This Blackberry device requires mass storage mode to sync your music files. Turn it on your device options, reconnect your device and try again to sync with your media card." I went to the device option and I can't find anything that its says turn on or something like that and I really need help with this problem please... Any advice or someone that had the same problem who can help me out with this problem please

    thanks for your time
    10-16-10 06:09 PM
  18. Longjohn931's Avatar
    Just installed Desktop Manger 2.0 on my mac, when I connect my Storm it doesn't recognize a media card??? It is a verizon media card that came with the Storm. Any suggestions would be greatly appreciated.
    03-19-11 06:06 PM
  19. Happy 10's Avatar
    Missmayberry,

    I played around with mine a bit more and think I have got it figured out.....If you want to use the Desktop Manager\Media Manager to manage your files on your memory card then you need to set the "Mass Storage Mode Support" to off. If you want to have your blackberry behave like a memory stick and be seen as an external drive when you plug it into your PC's USB port then you want to set the "Mass Storage Mode Support" to on, but if you do this your bb's media card will not be seen by the Media Manager. I have gone back and forth with mine and this is what I have found, I don't know if there are other considerations at this point and I am admittedly a newbie, hopefully someone with more experience can shed some light on this topic.

    I hope that helps.
    It sure did !!
    06-19-11 04:29 PM
  20. SteamedRabbit's Avatar
    Hey guys,

    I'm having a similar problem. I have a Blackberry Curve 8310. I just bought a Lexar memory card, 8GB. I'm working on Desktop manager v4.5.

    The phone will see my memory card (I think), but my destop manager won't. When i try to select where the media files go, it only gives me the option of device. It won't show up on Windows Explorer as a removable drive either.

    Can anybody help? I'm a serious newbie and please use small words. ^_^
    01-31-12 08:47 PM
  21. Sakinyah McRae's Avatar
    I have a problem, I have a blackberry curve 8310 and i have a 16GB memory card but i cant get my phone to connect with my computer and when i plug it up my desk manager wont pick up the memory card, what should I do?
    02-28-13 08:28 PM
LINK TO POST COPIED TO CLIPBOARD