1. SheriG12's Avatar
    I'm at a loss! I've had my BB since February, and used the Desktop Manager (4.3) to sync my calendar with Yahoo with no problems.

    Out of the blue yesterday I started getting an error message when trying to sync (Error 4238). I uninstalled the DM and when I tried to install it again I got a new error (Error 1904).

    I've spent the last 24 hours searching through CB and other sites, and have tried everything (even did the Clean Uninstall/Reinstall numerous times). I'm finding others who have had the same problem, but there doesn't seem to be a single solution out there!

    Has this happened to anyone, and if so has anyone had any success with a resolution? Should I try and install an older version of DM? I don't know what to do - without a working DM, I'm never going to be able to sync!

    Thanks in advance!

    ~Sheri
    04-19-08 05:48 PM
  2. BlitzedATL's Avatar
    CAUSE
    This problem can occur when one of the following conditions is true: • The file is not installed correctly.
    • The file is corrupted.
    • Other programs, including memory-resident and anti-virus programs, are running and using any version of the file.

    WORKAROUND:
    Register the File Manually
    To register a specific file again in the registry, while you are working in Microsoft Windows, follow these steps: 1. Click Start and then click Run.
    2. In the Open box, type the following command, and then click OK
    RegSvr32 "filename"
    where filename is the name of the file specified in Error 1904.
    04-19-08 05:51 PM
  3. SheriG12's Avatar
    Thank you - I'll absolutely give it a try! Do I do a Clean Uninstall first, then reinstall after I follow your instructions?
    04-19-08 07:15 PM
  4. BlitzedATL's Avatar
    You shouldn't have to reinstall... Give it a try without reinstalling first, then if that doesn't work try the reinstall.. Don't waste time if u dont need to lol
    04-19-08 07:17 PM
  5. SheriG12's Avatar
    No dice .

    I did a Clean Uninstall/Reinstall just to be safe, and it still wouldn't work. When I try to register is tells me it failed and says the "Return code was 0x80070005".

    Here are the four errors:

    C:\Program Files\Research In Motion\BlackBerry\IS71 Connectors\ISGroupWise6.5.X\GW.dll

    C:\Program Files\Research In Motion\BlackBerry\IS71 Connectors\ISGroupWise6.5.X\GWApi.dll

    C:\Program Files\Research In Motion\BlackBerry\IS71 Desktop Setup\Desktop Setup_pb.dll

    C:\Program Files\Research In Motion\BlackBerry\IS71 Action Engine\SyncAE_pb.dll


    And just so all bases are covered, here's how I'm trying to register the program (I'll use the first as an example):

    RegSvr32 "C:\Program Files\Research In Motion\BlackBerry\IS71 Connectors\ISGroupWise6.5.X\GW.dll"

    Thanks so much for trying to help me with this!

    ~Sheri
    04-20-08 09:25 AM
LINK TO POST COPIED TO CLIPBOARD