1. intoflatlines's Avatar
    I've read lots of people prefer 4.6 to 4.7. Why?
    02-12-09 01:52 AM
  2. Tremortality's Avatar
    4.7 is more suited for the Storm

    Many folks have tried 4.7 and its buggy on their non storm devices. I personally experienced this with my curve so I went to 4.6 and have never once had an issue. Why it happens I have no idea but 4.5 or 4.6 are the way to go. I also prefer my versions to not have media manager since I think Roxio is bloated and useless
    02-12-09 02:09 AM
  3. wnm's Avatar
    People with 8300 series Curves have had problems updating the OS with DM 4.7.
    02-12-09 08:02 AM
LINK TO POST COPIED TO CLIPBOARD