1. rcleeman's Avatar
    Does anyone have the old version of desktop manager need 4.2.1.8 or earlier, Thanks!
    10-13-10 09:29 AM
  2. Username5300's Avatar
    I have an old cd that you could have. Provide info in a PM and I will send it out.
    10-13-10 09:53 AM
  3. Username5300's Avatar
    Wow I finally dug one up and mailing it you now.
    10-26-10 01:39 PM
LINK TO POST COPIED TO CLIPBOARD