1. MOBBerry's Avatar
    Hi, I new to the forums with a BB8830WE from Sprint. I cannot get desktop manager to connect and stay connected without enabling the media card and setting mass storage to auto-enabled. I am posting to this forum rather than the BB8830WE forum so I can hopefully get the most visibility. I am so frustrated with this. Here's what I've done/tried: Installed the DM with multiple versions 4.2 that came with it, 4.2 SP2 downloaded, and 4.3 uninstalling priors first. I am on my second device already and both have had this problem. When I plug the device in it recognizes it, I get the USB connected ding sounds and it shows charging for a few seconds on the device. It will also sometimes popup connected to desktop manager on the device and seems to start to try synching, then the "plug icon" on the device goes away and the dm shows disconnected. The device still shows up in XP's device manager... actually three. BlackBerry device, USB Composite Device, and USB Mass Storage device. The driver associated with the Blackberry Device is rimusb.sys as I understand it should be. The other two devices show with Microsoft SP2 general drivers. I have cleaned up ALL usb devices in the computer and let the OS redetect and reinstall the USB drivers. I have tried different ports on my computer with the same results. I have Onboard USB and a du520 dlink usb card and both have the same result. I installed desktop manager on my computer at work and it works fine with or without "mass storage" auto-enabled so it is something with my computer at home. it is XP SP2. If I unplug the cable after it goes to a disconnected state, I hear the USB dings again the devices disappear under XPs device manager. I discovered that if I "auto-enable" mass storage on the device then it will connect and stay connected. XP opens the media card folder on connection. The devices all look the same under XPs device manager when connected successfully. If I even say "prompt" for whether to auto-enable mass storage I get the prompt when I connect the device but it is not possible to respond quick enough and it disconnects again.. only auto-enable works. If i take the media card out totally it won't stay connected either. While auto-enable is obviously a work around to connect the device it isn't working as it should. With my first device I thought upgrading the device OS to the latest sprint OS might help but I couldn't complete the OS install. With auto-enable I got it connected but during the upgrade process once it's wiped the device it couldn't reconnect (presumably because there was no auto-enable anymore) to carry the connection and it would not get past a 507 (no os) and reinstall the OS. So I got sprint to replace the device (from a different store) so it's doubtful it is the device and I have tried multiple cables. As I stated this worked fine on my desktop at work. I have run out of ideas after many long nights working on this. Sorry for the long post but I wanted to try and state everything I've done so far so as to avoid suggestions I've already tried. I hope someone can help. THANKS!
    01-19-08 11:44 AM
  2. MOBBerry's Avatar
    I believe I have found the cause. I have a disk backup/imaging software called Shadow Protect that was apparently conflicting. It must be something to do with the BB being seen as a Mass Storage Device. Uninstalled Shadow Protect and now I can connect and stay connected. I have opened a case with Storage Craft, the maker of Shadow Protect.
    01-19-08 03:56 PM
  3. acolvin1's Avatar
    I have a drug book (medical reference) called Pepid that required my to turn off mass storage to install. It would not install until I did so. It then installed fine. Incidentally it installed the majority of the reference database to the card - just the launcher and much smaller files were installed to the device memory.
    I have no problems with the desktop manager and have no problems with the Pepid application on the device. I don't think I have turned mass storage back on though....? I don't really use the media manager and don't really worry about ring tones, movies, etc.
    So I - sort of - know where you are coming from. Hopefully as more applications (or at least the bulk of an application) can be installed to a card this is worked out.
    01-19-08 07:31 PM
  4. glieberman's Avatar
    I am having the same problem. I stop the ShadowProtect Service and my BB connects and syncs without any problem. I have cases open with RIM and ShadowCraft. RIM says they've never heard of this problem and ShadowCraft hasn't gotten back to me yet. I've tried turning off the mass storage option to no avail. For now I just stop the service, sync and restart it.

    1- net stop "ShadowProtect Service"
    2- connect the BB and start Disktop Manager.
    3- sync
    4- disconnect the BB and shutdown Disktop Manager
    5- net start "ShadowProtect Service"

    Note: you can also stop and start the service through the service manager. I just find the command prompt easier. I'll repost if I find a solution.
    03-26-08 02:58 PM
  5. glieberman's Avatar
    I heard back from StorageCraft:

    We have had a couple of reports of this problem recently and are currently investigating it. It may take some time to figure out what is happening, but I have noted the email addresses of those who have reported the problem, and will keep you updated on this issue.

    The other people who have reported this were using the BlackBerry 8830 (or at least 8800 series devices). Is that the model you are using?

    StorageCraft Support

    Will repost when I hear something.
    03-28-08 04:38 AM
  6. kashberry's Avatar
    Just hit cancel when it prompts your for that. I did and am able to sync files b/w desktop and bb
    03-28-08 06:16 AM
  7. MOBBerry's Avatar
    glieberman. Yes, I have a case that has been open with them for a couple months now. Never thought about stopping the service. I had uninstalled and was glad I figured out the problem. I spent many late / sleepless nights trying to fix the issue. I just emailed them again last night about status. Based on a previous reply we are on the back burner as desktop users with a few of us reporting this. I basically complained about it taking so long to get this looked at by SC but he did say they want to address it as it will likely become more problematic as time goes on and more people try/use the product. Did you let them know stopping the service would allow it to connect properly? I'll post back if I get a response today.

    kashberry, I don't think that will help... If in prompt mode and you cancel or don't reply VERY quickly, it disconnects. It appears to need the mass storage via windows to hold the connection open.
    Last edited by MMBB8830; 03-28-08 at 12:56 PM.
    03-28-08 12:53 PM
  8. MOBBerry's Avatar
    I just received a response on my question for status. They said they have ordered a blackberry and are waiting for it to arrive so they can reproduce / resolve the problem. In my previous email to them I asked if someone surely had a BB at their company they could test with but he said no but they would probably order one. They indicated they just spoke with someone (sounds like you glieberman) where they tested stopping the service as a workaround. Anyway that's what I know. Sounds like there is a ways to go yet to get a real fix but I will try reinstalling and then stopping the service tonight.
    03-28-08 03:28 PM
  9. glieberman's Avatar

    Yes, I did point out the work around to StorageCraft. I have also been keeping RIM up to date as well. My case was the first for RIM reporting this problem. I am sure StorageCraft will get more calls as PC Mag just did a story on the product. I would think their sales will jump and so will their calls as lots of folks have 8830 Blackberries. I am interested to know if the stopping of the service worked for you too.

    Last edited by glieberman; 03-30-08 at 10:18 AM.
    03-30-08 10:14 AM
  10. MOBBerry's Avatar
    I installed Shadowprotect 3.2 and XP SP3 and the problem doesn't seem to happen anymore... unfortunately I don't know which might have fixed it.
    05-14-08 08:41 PM