1. horheit's Avatar
    OS: Windows 7 32bit
    BB Desktop Manager version:
    Phone model: 9780

    I bought a new notebook a few days ago and tried to install the above software (latest version) from Blackberry's website. The whole thing installed fine but when I tried to launch it after installation WITHOUT plugging in my 9780, it shows the splashscreen and then I get the message:

    "BlackBerry Desktop Software has stopped working"

    I tried the clean uninstall with removal of folders and registry entries, rebooting it, running regsvr32 atl.dll and then reinstalling it and still I have the same problem.

    I had experienced a similar issue with my previous computer which I fixed by changing the permission and ownership of two registry keys "HKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion" and "HKEY_CURRENT_USER\SOFTWARE\Research In Motion". But this time round, I found that:

    1) There is no "HKEY_CURRENT_USER\SOFTWARE\Research In Motion"
    2) I can't find a "Desktop.log" in "C:\Users\<username>\AppData\Roaming\Research In Motion\BlackBerry Desktop" (which is empty) but I did find it in "C:\Users\<username>\AppData\Local\Research In Motion\BlackBerry Desktop\Logs"

    I have scanned through it and I can't find anything that says "fatal".

    Date|Log Level|Thread ID|Module ID|Log ID|Message [2011-06-13 05:37:51.612]
    05:37:51.637|INFO |1|Rim.Desktop.Shell|1|Application Started
    05:37:51.661|INFO |1|Rim.Desktop.Shell|2|Commandline: "C:\Program Files\Research In Motion\BlackBerry Desktop\Rim.Desktop.exe"
    05:37:51.661|INFO |1|Rim.Desktop.Shell|2|Rim.Desktop.exe Version:
    05:37:51.663|INFO |1|Rim.Desktop.Shell|2|Product Installation Variant: none
    05:37:51.664|INFO |1|Rim.Desktop.Shell|2|OS Version: Windows7 [Microsoft Windows NT 6.1.7601 Service Pack 1]
    05:37:51.665|INFO |1|Rim.Desktop.Shell|2|CLR Version: 2.0.50727.5444
    05:37:51.671|INFO |1|Rim.Desktop.Shell|2|AppLoader Version:
    05:37:51.677|INFO |1|Rim.Desktop.Shell|2|Device Manager Version:
    05:37:51.684|INFO |1|Rim.Desktop.Shell|2|BBDevMgr Version:
    05:37:51.702|INFO |1|Rim.Desktop.Shell|2|Serial USB Driver Version:
    05:37:51.703|INFO |1|Rim.Desktop.Shell|2|USB Driver Version:
    05:37:51.706|INFO |1|Rim.Desktop.Shell|2|PlayBook RNDIS Driver Interface:

    I have tried all suggested fixes that I can find but none work, such as:

    1) Moving the "Video" folders out of the "My Documents" folder.
    2) Trying to look for that intellisync folder to delete but I can't find any.
    3) Turning off antivirus and installing as administrator, no luck.
    4) Running the desktop manager as administrator, nada.

    (can't remember what else I have tried)

    I also tried to look into my Windows 7 Event Viewer to see what could be causing the crash, but that presented a different problem as the darn MMC cannot create the snap-in. Which is a separate problem from this. (I think...)

    Any suggestions? I am at my wits end after combing through this forum and other BB forums for the past few long days and nights.

    After going through so many phones in my lifetime, I do like the 9780's ease of use. But the desktop software really leaves a lot to be desired. I do understand that this may not be RIM's fault entirely and that Microsoft may have a part to play, but the issue is really vexing as I really need to sync my calendar and contacts for work.

    PS: I also need to add that I am using Outlook 2007.

    Thanks in advance!
    06-12-11 05:03 PM
  2. horheit's Avatar
    Oh, and I also tried to launch the DTM 6.1 with my 9780 plugged in and the result is still the same.

    "BlackBerry Desktop Software has stopped working"
    06-12-11 05:10 PM
  3. horheit's Avatar
    Well folks. I've had enough.

    The 9780 is a great phone, it's easy to use, practical and dependable. However, the Desktop Manager software has been giving me too many sleepless nights. On two occassions I must add: once at the end of last year when I bought it and only managed to solve it by myself after 4 weeks of trawling through online forums, blogs and other BB help sites and the recent one was last week when I tried to install it on my new Windows 7 notebook.

    I know this is not entirely the fault of RIM, Microsoft also has a part to play. But considering the state of technology these days, it shouldn't have to be so difficult. I want a phone and software that makes my life easier and not have to be a slave to it by trying days and nights to solve its problems.

    Hence, I have officially decom my phone and gotten an iPhone 4 instead. The switch ain't that difficult for me as I have always been platform neutral. As long it fits my needs, does it job well and doesn't give me too much headache, I'm cool with it.

    Ciao folks!
    06-14-11 01:18 PM
  4. crashplane's Avatar
    Having the same problem with my BB Bold 9000.

    Desktop manager crashes when I plug in my BB or if I have it plugged in and start Desktop Manager.

    To get it to work I can either take out my memory card or turn off mass storage mode.

    I didn't have this problem until I updated to 6.1.

    running windows 7 ultimate 32 bit.
    06-23-11 10:47 PM
  5. mjohn19468's Avatar
    I am having a similar problem. Windows 7 64 bit 100% completed administrative rights on the computer. Running DTM
    I plug in a blackberry several different models Bolds, Curves, World Editions and service providers (AT&T, Sprint, Nextel, Verizon ETC...) it detects the phone and let me do what i want. Once completed with my task (update or reload OS, back up or restore Blackberry) the loader and RIMDEVICEMANAGER freeze and i have kill them in task manager. I cannot connect another blackberry after this and perform any tasks unless i reboot my computer. If anyone could shed some light on this issue i would appreciate it. Prior to this BB DTM update i was using the first 6.0 DTM and on the same machine with specs and had no problem. The obviouse solution is the uninstall and revert back to the older 6.0 DTM.

    Here the errors from Windows 7 action center:

    Handheld Application Loader Wizard

    Stopped responding and was closed

    ‎6/‎27/‎2011 4:25 PM

    More data required

    A problem caused this program to stop interacting with Windows.
    Faulting Application Path: C:\Program Files (x86)\Common Files\Research In Motion\AppLoader\Loader.exe

    Problem signature
    Problem Event Name: AppHangXProcB1
    Application Name: Loader.exe
    Application Version:
    Application Timestamp: 4ddeb6d9
    Hang Signature: a8ef
    Hang Type: 32
    Waiting on Application Name: Rim.Desktop.exe
    Waiting on Application Version:
    OS Version: 6.1.7601.
    Locale ID: 1033
    Additional Hang Signature 1: a8ef34283a80fa363549201b843dff8d
    Additional Hang Signature 2: ec57
    Additional Hang Signature 3: ec577cdfb78b4924599b63c4e5864867
    Additional Hang Signature 4: a8ef
    Additional Hang Signature 5: a8ef34283a80fa363549201b843dff8d
    Additional Hang Signature 6: ec57
    Additional Hang Signature 7: ec577cdfb78b4924599b63c4e5864867

    Files that help describe the problem

    BlackBerry Desktop Software

    Stopped responding and was closed

    ‎6/‎27/‎2011 4:25 PM

    Not reported

    A problem caused this program to stop interacting with Windows.
    Faulting Application Path: C:\Program Files (x86)\Research In Motion\BlackBerry Desktop\Rim.Desktop.exe

    Problem signature
    Problem Event Name: AppHangXProcB1
    Application Name: Rim.Desktop.exe
    Application Version:
    Application Timestamp: 4dee095a
    Hang Signature: 3069
    Hang Type: 321
    Waiting on Application Name: RIMDeviceManager.exe
    Waiting on Application Version:
    OS Version: 6.1.7601.
    Locale ID: 1033
    Additional Hang Signature 1: 30699cd4794afffab3e1fd83a5b6a2c0
    Additional Hang Signature 2: 7f74
    Additional Hang Signature 3: 7f74dad33f373a02fdec4629af029d2f
    Additional Hang Signature 4: 24b9
    Additional Hang Signature 5: 24b92b246c10593094067bbc97a0d389
    Additional Hang Signature 6: 318d
    Additional Hang Signature 7: 318d837ff46df68b635cd0b966a67b25

    Files that help describe the problem
    06-28-11 10:35 AM
  6. bjm007's Avatar
    I've had so many problems with Desktop Manager, and spent countless hours on the phone with RIM tech support, that I had to roll back to Desktop Manager 5.x. and now even THAT is giving me problems.

    As an earlier poster said, there are compatibility problems with other programs, but this is getting rediculous. As much as I'm NOT a fan of Apple, and as much as I don't care for itunes, nobody I know with an iphone has had syncing problems with it. At least it runs!

    I am getting pretty frustrated with RIM as a company. They used to be reliable, and a company you could count on for business solutions, now as much as I like my 9800 Torch, I'm getting beyond frustrated at getting the OS and Desktop Manager to work like they should.

    RIM, please get your act together.....
    07-11-11 12:13 PM
  7. todbanner's Avatar
    I've tried every version of DM software back as far as 5.1 all the way up to latest 7.x beta.

    Some times it loads, most of the time it crashes, I got to do a complete back up of my PB once. The Torch however always throws it for a loop if you get it to load at all.

    I've currently got the 7.x beta loaded up.

    I've found some interesting things in the logs this time around.

    from desktop.log:
    15:05:29.070|ERROR|1|Rim.Desktop.Services.Configur ation|0|Unable to get Registry entry. Path: Software\Research In Motion\BlackBerry\ Key: FirstLaunch
    15:05:29.549|ERROR|1|Rim.Desktop.Services.Configur ation|0|Unable to get Registry entry. Path: Software\Research In Motion\DesktopAutoUpdate Key: AutoUpdateEnabled
    15:05:29.549|ERROR|1|Rim.Desktop.Services.Configur ation|0|Unable to get Registry entry. Path: Software\Research In Motion\Device Manager\Bluetooth Key: Enabled

    I've checked, those registry entries don't exist.

    From DesktopHelper.log:

    15:08:59.250|ERROR|8|Rim.Desktop.Media|18004|EXCEP TION: System.ServiceModel.EndpointNotFoundException -- MESSAGE: There was no endpoint listening at net.pipe://localhost/Rim.Desktop.MediaServer that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details. -- STACK: {CRLF}Server stack trace: {CRLF} at System.ServiceModel.Channels.PipeConnectionInitiat or.GetPipeName(Uri uri){CRLF} at System.ServiceModel.Channels.NamedPipeConnectionPo olRegistry.NamedPipeConnectionPool.GetPoolKey(Endp ointAddress address, Uri via){CRLF} at System.ServiceModel.Channels.ConnectionPoolHelper. EstablishConnection(TimeSpan timeout){CRLF} at System.ServiceModel.Channels.ClientFramingDuplexSe ssionChannel.OnOpen(TimeSpan timeout){CRLF} at System.ServiceModel.Channels.CommunicationObject.O pen(TimeSpan timeout){CRLF} at System.ServiceModel.Channels.ServiceChannel.OnOpen (TimeSpan timeout){CRLF} at System.ServiceModel.Channels.CommunicationObject.O pen(TimeSpan timeout){CRLF} at System.ServiceModel.Channels.ServiceChannel.CallOp enOnce.System.ServiceModel.Channels.ServiceChannel .ICallOnce.Call(ServiceChannel channel, TimeSpan timeout){CRLF} at System.ServiceModel.Channels.ServiceChannel.CallOn ceManager.CallOnce(TimeSpan timeout, CallOnceManager cascade){CRLF} at System.ServiceModel.Channels.ServiceChannel.Ensure Opened(TimeSpan timeout){CRLF} at System.ServiceModel.Channels.ServiceChannel.Call(S tring action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout){CRLF} at System.ServiceModel.Channels.ServiceChannel.Call(S tring action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs){CRLF} at System.ServiceModel.Channels.ServiceChannelProxy.I nvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation){CRLF} at System.ServiceModel.Channels.ServiceChannelProxy.I nvoke(IMessage message){CRLF}{CRLF}Exception rethrown at [0]: {CRLF} at System.Runtime.Remoting.Proxies.RealProxy.HandleRe turnMessage(IMessage reqMsg, IMessage retMsg){CRLF} at System.Runtime.Remoting.Proxies.RealProxy.PrivateI nvoke(MessageData& msgData, Int32 type){CRLF} at Rim.Media.Sync.MobileMediaSync.IWifiServerStatusPu blisher.PublishStatus(WifiServerStatus status){CRLF} at Rim.Wms.Sync.WmsApplication.OnWifiStatusChanged(Wi fiServerStatus status)

    The DesktopHelper.log info appeared after it loaded up my iTunes playlists... and it seems to be referring to media. I am gong to go look into that.

    Thoughts anyone? This now doesn't seem to be an isolated issue, more people than just I are having issues.

    Windows 7 Pro 32Bit.
    DM Manager 700_b019_multilanguage
    11-23-11 05:28 PM
  8. ishny1's Avatar
    iv the same problem on a winxp full patched.
    I find my answer on EE Mobile: BlackBerry Desktop 6.1 Crashes on Launch

    1. Go to Start > Run > in the "Open" field, type "appwiz.cpl"
    2. Uninstall Microsoft .NET Framework (All versions, if applicable)
    3. Restart the PC
    4. Download the latest Desktop Software v6.1.0 B34 (v6.1.0 B038 for me)
    5. Run the Desktop Software installer and it should detect .NET is missing an automatically download and install the required version.

    Iv not install any .net framework update after.... so i dont know if it can work after you install other .net update.
    12-07-11 07:40 PM
  9. Jhazon's Avatar
    iv the same problem on a winxp full patched.
    I find my answer ...
    Ok, will do. Removing .Net frameworks now. Will report back in. I've been suffering the same error (crashing DM) and unable to update my BB software.
    12-31-11 09:31 AM
  10. Jhazon's Avatar
    After following all of the instruction listed above, 1hour later and the same error occurs...

    AppName: loader.exe AppVer: ModName: loader.exe
    ModVer: Offset: 0015a360

    With the error being in "\Temp\ea54_appcompat.txt"

    So, I am unable to update my BB software from 6.0 Bundle 2391 to 6.0 Bundle 2921

    Now I am fraustrated. I am one of the last sole user of RIM in my pack of friends and now this....
    12-31-11 10:34 AM
  11. Jhazon's Avatar
    WONDERFUL!!!... just realized that this same error does not allow me to see the applications on my device! Can't say the iTune ever failed me in this way... this could well be the reason I depart with BB.
    12-31-11 10:39 AM
  12. clicks's Avatar
    errors using blackberry playbook desktop software, installed OK but failed to work, screen stated it had stopped working. Installed .NET Framework 4, the latest version and Windows Installer which solved the problem. Worth trying.

    Vista 32, 2Gb Ram.
    02-18-13 01:35 PM