1. jhawkins21's Avatar
    when i try and install my blackberry desktop manager it says, "this software does not support your current operating system. please upgrade to the newest version." does anyone know what this means? i have a curve 8330 and a mac. thanks in advance!
    02-22-10 08:47 PM
  2. Motorcycle Mama's Avatar
    Did you download the correct version for your OS version?

    What OS is on your computer?
    02-22-10 09:03 PM
  3. jhawkins21's Avatar
    version 10.4.11
    02-22-10 09:05 PM
  4. Cyber Warrior's Avatar
    I use to have that problem with the old versions of DM when downloading from a link. Had to use the CD.
    02-22-10 09:08 PM
  5. Cyber Warrior's Avatar
    Are you using a link or the CD it comes with?
    02-22-10 09:10 PM
  6. jhawkins21's Avatar
    i'm downloading it from blackberry.com. should i try the disc?
    02-22-10 09:11 PM