1. tx_traveler's Avatar
    Looks like the newer BB software on the Bold supports multiple calendars. My problem is that the BB Desktop put all my calendar entries in one email account, and I receive meeting invitations on another email account.

    Is there some way to specify in the BB Desktop which email address to use when it creates calendar entries? I'm not seeing it, and I've searched thru the forums. There are some posts on multiple calendars, but not an answer to this question.
    11-10-08 05:45 PM
  2. tpoon's Avatar
    As far as I know, you can only sync to a default calendar.
    11-10-08 06:17 PM
  3. Dawg357's Avatar
    first thing you want to do is go into advance options on your blackberry and find "Default Services" - - be sure you have the email that you want as your default email for calendar set there - that determines where they will go when you sync as well.

    Next you'll want to hook your blackberry up to desktop manager and click on backup and restore - over to the right is "advanced" click on that and look for calendar all - you'll see your records there - - you want to delete them from the blackberry because if you do a sync after you have changed the default calendar email it will give you double entries. After you have deleted the entries from the blackberry - you can do a sync and all your calendar enteries from Outlook or what ever you are using will end up on your blackberry under the correct email address. One thing I do which is probably redundant but I do it for safety - after I have deleted entries from the blackberry and I am ready to re-syc to desktop - I go into sync configuration and set the calendar as a one-way sync from desktop to blackberry device for that first sync, this way I wont risk deleting from desktop when I do the sync - - there after you can set it back for two-way sync.
    11-10-08 06:22 PM
  4. tx_traveler's Avatar
    first thing you want to do is go into advance options on your blackberry and find "Default Services" - - be sure you have the email that you want as your default email for calendar set there - that determines where they will go when you sync as well.

    Next you'll want to hook your blackberry up to desktop manager and click on backup and restore - over to the right is "advanced" click on that and look for calendar all - you'll see your records there - - you want to delete them from the blackberry because if you do a sync after you have changed the default calendar email it will give you double entries. After you have deleted the entries from the blackberry - you can do a sync and all your calendar enteries from Outlook or what ever you are using will end up on your blackberry under the correct email address. One thing I do which is probably redundant but I do it for safety - after I have deleted entries from the blackberry and I am ready to re-syc to desktop - I go into sync configuration and set the calendar as a one-way sync from desktop to blackberry device for that first sync, this way I wont risk deleting from desktop when I do the sync - - there after you can set it back for two-way sync.
    Dawg357 - Thanks for your response! You completely understood my issue and gave me clear instructions on a complicated procedure to resolve the issue. Well done. This worked exactly as you said. Thanks!!!!

    Anyone with multiple email addresses on their BIS is likely to have this issue.
    11-11-08 06:35 AM
  5. Dawg357's Avatar
    Dawg357 - Thanks for your response! You completely understood my issue and gave me clear instructions on a complicated procedure to resolve the issue. Well done. This worked exactly as you said. Thanks!!!!

    Anyone with multiple email addresses on their BIS is likely to have this issue.
    Thanks TX - - I had the same issue when I upgraded my operating system to 4.5 and didn't notice that the "Default Services" had changed during the upgrade process - - so when I did my calendar sync it wanted to add all my entries a second time - that's when I found the issue.
    11-11-08 02:15 PM
  6. sc13's Avatar
    I've been scouring these boards for a couple of days, trying to find a solution to the following dilemma:

    • I have a Bold 9000, on which I have three separate (BIS) email accounts set up.
    • I synch with a desktop version of Outlook (Windows XP).
    • Somehow in the process of upgrading to this new Bold (backup data imported from an old 7130) and doing various troubleshooting activities and synchs, I wound up having triple calendar entries for just about everything (particularly recurring/series appointments like holidays and birthdays). For example, "New Year's Eve" would show up Dec 31 in red, blue and green separate events on the handheld, while only showing up once in Outlook. (this is probably due to the "default" email address changing, unknown to me, during the backups and restores).
    • I wanted to have only one set of appointments on both, with no duplications, and couldn't find an easy way to accomplish this.



    Here was my solution, which fortunately didn't involve deleting CICAL service books or going through anything too traumatic:

    1. Do a synch to make sure that every calendar event you want is currently in Outlook on the PC.
    2. Pick one email address (ABC@gmail.com) as your primary, and default address. Make sure this is the default address in Outlook AND make sure it is selected as the default address on the handheld in BOTH Calendar and Messaging (Options/Advanced Options/Default Services).
    3. After you have both Outlook and the handheld options set to the same email address, do another synch. Every event in Outlook should now be on your handheld, and should be "color coded" to your primary/default email. (If you want to check the number of events in each "color coded" handheld calendar, open the handheld calendar, and select menu/Options. You will se all the color coded calendars there, listed by email address. Scroll down and select one, and you will find a listing for "number of entries." Your primary email address should have the number of entries you want, and that should correspond to the number of entries you have in Outlook. The other, secondary calendars may have the same or fewer entries, depending on when you got into this mess with multiple calendars. However, they should not have MORE entries). Also, just to double check, pick a few important dates and see if they have the double or triple entries (red, blue, green) for the same item. The important thing is that every event you want shows up in your default email account color.
    4. Once you know that you have all the events you want in Outlook, AND on the handheld in your default color, now it's time to delete the duplicates.
    5. Go into the calendar application on the handheld, and press the menu button. Choose "Select Calendar" When the screen comes up, it will give you the option to "Show All Calendars", or choose each individual calendar. Choose one of the calendars that you DO NOT want.
    6. When you are in one of the unwanted calendars, then press menu/View Agenda (which will show all the appointments/events in a vertical list by date).
    7. Then, press menu/Go To Date and pick a date way out in the far future, like Jan 1, 2015 or something.
    8. Once you're on that future date, press menu and select "Delete Prior." This will delete every single appointment for ONLY that calendar. You've just eliminated one set of duplicates from the master calendar.
    9. Follow the same process to delete all duplicate events from a second or third calendar.
    10. Now you should only have one set of events in your calendar, all synched to the same email address in both Outlook and on the handheld. (There may be a few stragglers way out in the future, if for example you had set up a "recurring event" like a birthday in Outlook that had no end date and it was beyond the date you picked Jan 1, 2015 for our example for Delete Prior. If you find one of those, you can manually selected it, in the "unwanted" calendar color, of course, and select it individually and delete the series).



    I hope that helps someone who was experiencing the same frustration as I was with the multiple calendars and duplicate entries. It worked great for me.

    (Now, the next challenge is to figure out how to avoid multiple entries when synching one BlackBerry with two different PCs one work and one home -- that each have a different default email account assigned to them).
    12-29-08 07:35 PM
  7. somasupport's Avatar
    we used to tell people this back in the 90's..

    when all else fails back up and re-install windows 98 it's just crap and there is not much you can do about it but try and back up and start with a blank slate..

    what i had to do...
    then i looked around here for tweaks.. seems there are good ones..

    hope this fixes all the bugs..
    01-06-09 09:40 PM
  8. spacemanspiff's Avatar
    I've been scouring these boards for a couple of days, trying to find a solution to the following dilemma:

    • I have a Bold 9000, on which I have three separate (BIS) email accounts set up.
    • I synch with a desktop version of Outlook (Windows XP).
    • Somehow in the process of upgrading to this new Bold (backup data imported from an old 7130) and doing various troubleshooting activities and synchs, I wound up having triple calendar entries for just about everything (particularly recurring/series appointments like holidays and birthdays). For example, "New Year's Eve" would show up Dec 31 in red, blue and green separate events on the handheld, while only showing up once in Outlook. (this is probably due to the "default" email address changing, unknown to me, during the backups and restores).
    • I wanted to have only one set of appointments on both, with no duplications, and couldn't find an easy way to accomplish this.



    Here was my solution, which fortunately didn't involve deleting CICAL service books or going through anything too traumatic:

    1. Do a synch to make sure that every calendar event you want is currently in Outlook on the PC.
    2. Pick one email address (ABC@gmail.com) as your primary, and default address. Make sure this is the default address in Outlook AND make sure it is selected as the default address on the handheld in BOTH Calendar and Messaging (Options/Advanced Options/Default Services).
    3. After you have both Outlook and the handheld options set to the same email address, do another synch. Every event in Outlook should now be on your handheld, and should be "color coded" to your primary/default email. (If you want to check the number of events in each "color coded" handheld calendar, open the handheld calendar, and select menu/Options. You will se all the color coded calendars there, listed by email address. Scroll down and select one, and you will find a listing for "number of entries." Your primary email address should have the number of entries you want, and that should correspond to the number of entries you have in Outlook. The other, secondary calendars may have the same or fewer entries, depending on when you got into this mess with multiple calendars. However, they should not have MORE entries). Also, just to double check, pick a few important dates and see if they have the double or triple entries (red, blue, green) for the same item. The important thing is that every event you want shows up in your default email account color.
    4. Once you know that you have all the events you want in Outlook, AND on the handheld in your default color, now it's time to delete the duplicates.
    5. Go into the calendar application on the handheld, and press the menu button. Choose "Select Calendar" When the screen comes up, it will give you the option to "Show All Calendars", or choose each individual calendar. Choose one of the calendars that you DO NOT want.
    6. When you are in one of the unwanted calendars, then press menu/View Agenda (which will show all the appointments/events in a vertical list by date).
    7. Then, press menu/Go To Date and pick a date way out in the far future, like Jan 1, 2015 or something.
    8. Once you're on that future date, press menu and select "Delete Prior." This will delete every single appointment for ONLY that calendar. You've just eliminated one set of duplicates from the master calendar.
    9. Follow the same process to delete all duplicate events from a second or third calendar.
    10. Now you should only have one set of events in your calendar, all synched to the same email address in both Outlook and on the handheld. (There may be a few stragglers way out in the future, if for example you had set up a "recurring event" like a birthday in Outlook that had no end date and it was beyond the date you picked Jan 1, 2015 for our example for Delete Prior. If you find one of those, you can manually selected it, in the "unwanted" calendar color, of course, and select it individually and delete the series).



    I hope that helps someone who was experiencing the same frustration as I was with the multiple calendars and duplicate entries. It worked great for me.

    (Now, the next challenge is to figure out how to avoid multiple entries when synching one BlackBerry with two different PCs one work and one home -- that each have a different default email account assigned to them).
    Awesome explanation and thanks for your help. Worked perfectly and resolved my calendar issue.
    01-07-09 08:59 AM
  9. meola023's Avatar
    I just opened my Outlook Calendar and its EMPTY!!!

    I have all my calendar events on the device on the Default Device calendar. How do i get them back to the Outlook?!

    PLEASE HELP!!!
    01-16-09 02:56 PM
  10. NeverEnufGadgets's Avatar
    Do a one way sync from your device to outlook.
    01-20-09 06:55 AM
  11. NeverEnufGadgets's Avatar
    Thank you. Do you have a fix for repeating events, such as birthdays that extend over two days? They are pulled from Outlook and appear to start at 5:00am. one day through 5:00 am the next day. I checked my configuration settings and I am on the correct time zone. This is driving me crazy. It appears that this problem started after I installed a new os. Not to mention, I try to sync 2 blackberries to both work and home. Uggghhhh!
    01-20-09 09:23 AM
  12. NeverEnufGadgets's Avatar
    I've been scouring these boards for a couple of days, trying to find a solution to the following dilemma:

    • I have a Bold 9000, on which I have three separate (BIS) email accounts set up.
    • I synch with a desktop version of Outlook (Windows XP).
    • Somehow in the process of upgrading to this new Bold (backup data imported from an old 7130) and doing various troubleshooting activities and synchs, I wound up having triple calendar entries for just about everything (particularly recurring/series appointments like holidays and birthdays). For example, "New Year's Eve" would show up Dec 31 in red, blue and green separate events on the handheld, while only showing up once in Outlook. (this is probably due to the "default" email address changing, unknown to me, during the backups and restores).
    • I wanted to have only one set of appointments on both, with no duplications, and couldn't find an easy way to accomplish this.



    Here was my solution, which fortunately didn't involve deleting CICAL service books or going through anything too traumatic:

    1. Do a synch to make sure that every calendar event you want is currently in Outlook on the PC.
    2. Pick one email address (ABC@gmail.com) as your primary, and default address. Make sure this is the default address in Outlook AND make sure it is selected as the default address on the handheld in BOTH Calendar and Messaging (Options/Advanced Options/Default Services).
    3. After you have both Outlook and the handheld options set to the same email address, do another synch. Every event in Outlook should now be on your handheld, and should be "color coded" to your primary/default email. (If you want to check the number of events in each "color coded" handheld calendar, open the handheld calendar, and select menu/Options. You will se all the color coded calendars there, listed by email address. Scroll down and select one, and you will find a listing for "number of entries." Your primary email address should have the number of entries you want, and that should correspond to the number of entries you have in Outlook. The other, secondary calendars may have the same or fewer entries, depending on when you got into this mess with multiple calendars. However, they should not have MORE entries). Also, just to double check, pick a few important dates and see if they have the double or triple entries (red, blue, green) for the same item. The important thing is that every event you want shows up in your default email account color.
    4. Once you know that you have all the events you want in Outlook, AND on the handheld in your default color, now it's time to delete the duplicates.
    5. Go into the calendar application on the handheld, and press the menu button. Choose "Select Calendar" When the screen comes up, it will give you the option to "Show All Calendars", or choose each individual calendar. Choose one of the calendars that you DO NOT want.
    6. When you are in one of the unwanted calendars, then press menu/View Agenda (which will show all the appointments/events in a vertical list by date).
    7. Then, press menu/Go To Date and pick a date way out in the far future, like Jan 1, 2015 or something.
    8. Once you're on that future date, press menu and select "Delete Prior." This will delete every single appointment for ONLY that calendar. You've just eliminated one set of duplicates from the master calendar.
    9. Follow the same process to delete all duplicate events from a second or third calendar.
    10. Now you should only have one set of events in your calendar, all synched to the same email address in both Outlook and on the handheld. (There may be a few stragglers way out in the future, if for example you had set up a "recurring event" like a birthday in Outlook that had no end date and it was beyond the date you picked Jan 1, 2015 for our example for Delete Prior. If you find one of those, you can manually selected it, in the "unwanted" calendar color, of course, and select it individually and delete the series).



    I hope that helps someone who was experiencing the same frustration as I was with the multiple calendars and duplicate entries. It worked great for me.

    (Now, the next challenge is to figure out how to avoid multiple entries when synching one BlackBerry with two different PCs one work and one home -- that each have a different default email account assigned to them).
    I've found the calendar information, unfortunately, I can't seem to find out how to "delete prior" the only option I have is "delete", I've even tried just being on a date, and not in an event, but can not find the option to delete prior. Can you help?
    01-21-09 10:33 AM
  13. cleaverton's Avatar
    first thing you want to do is go into advance options on your blackberry and find "Default Services" - - be sure you have the email that you want as your default email for calendar set there - that determines where they will go when you sync as well.

    Next you'll want to hook your blackberry up to desktop manager and click on backup and restore - over to the right is "advanced" click on that and look for calendar all - you'll see your records there - - you want to delete them from the blackberry because if you do a sync after you have changed the default calendar email it will give you double entries. After you have deleted the entries from the blackberry - you can do a sync and all your calendar enteries from Outlook or what ever you are using will end up on your blackberry under the correct email address. One thing I do which is probably redundant but I do it for safety - after I have deleted entries from the blackberry and I am ready to re-syc to desktop - I go into sync configuration and set the calendar as a one-way sync from desktop to blackberry device for that first sync, this way I wont risk deleting from desktop when I do the sync - - there after you can set it back for two-way sync.
    Thanks! Had to do some searching to figure out how to fix my duplicate calendar issues on my Bold. After deleting CICAL for each of my "extra" email addresses, everytime I would synch Desktop Manager would re-add ALL of my calendar entries....I was up to 4 of everything and starting to panic. I found your solution and tried it along with making sure that my default email address was the same for my calendar AND my messages and wah-lah! I am fixed!
    Last edited by cleaverton; 12-28-09 at 10:44 PM.
    12-28-09 10:39 PM
  14. Cain57's Avatar
    Thank you. Do you have a fix for repeating events, such as birthdays that extend over two days? They are pulled from Outlook and appear to start at 5:00am. one day through 5:00 am the next day. I checked my configuration settings and I am on the correct time zone. This is driving me crazy. It appears that this problem started after I installed a new os. Not to mention, I try to sync 2 blackberries to both work and home. Uggghhhh!
    Anyone know how to fix and event that bleeds over to two days as described here ??

    Thx !!
    06-11-10 07:16 AM
LINK TO POST COPIED TO CLIPBOARD