1. JohnnyVBC's Avatar
    I have had my Z30 for 2 months now. It's a great phone and I am extremely happy with it. My only concern is the wifi antenna quality. I have been playing with my ASUS Rt-N66U settings and I still can't get my full 50 mb\s on a 2.4 ghz I am getting 25mb max and on 5.0 mgz I am getting around the same... Uploads are correct. Are there any tweaks I should make to my settings ? Or is it just an avg Wireless N antenna?

    Any help would be greatly appreciated. Thank you
    03-23-14 04:46 PM
  2. anon721037's Avatar
    I think there was a problem with one of the OS out there and I believe that was one of the issues, check through some of the leak threads I can't remember which one sorry.
    03-23-14 05:19 PM
  3. Ecm's Avatar
    I have had my Z30 for 2 months now. It's a great phone and I am extremely happy with it. My only concern is the wifi antenna quality. I have been playing with my ASUS Rt-N66U settings and I still can't get my full 50 mb\s on a 2.4 ghz I am getting 25mb max and on 5.0 mgz I am getting around the same... Uploads are correct. Are there any tweaks I should make to my settings ? Or is it just an avg Wireless N antenna?

    Any help would be greatly appreciated. Thank you
    I believe I recall hitting 42mb/s on 10.2.1.1925. The last couple of OS versions seem to have lowered my max. But snce the rest of the OS is so much better with the latest (.2234) that doesn't bother me. High 20's is good for almost everything I need it for. I've hit 46+ on LTE, so we know it's capable.
    anon721037 likes this.
    03-23-14 05:23 PM
  4. anon(8476153)'s Avatar
    Something isn't right. I get anywhere between 25-37 mbps on my z30 on either 2.4 or 5ghz and my service is 25 (higher cause of rogers speed boost) and this is on a 3 year old lynksys router. Have you tried this anywhere else like a friends router? Maybe it's your routers configuration isn't optimal

    Posted via CB10
    03-23-14 06:33 PM
  5. digitalmayhem01's Avatar
    I don't get over 3mbps...

    Posted from Thor's hammer...my Z30!
    03-24-14 12:00 AM
  6. imandroid's Avatar
    Here I thought I was the only one having this issue. I have a newer router that easily hits the 58 mb service on my other devices.

    Oh well still a great device

    Posted via CB10
    03-24-14 12:11 PM
  7. 1REDRUM's Avatar
    How do I check / measure this?

    Posted via CB10
    03-24-14 12:53 PM
  8. Ecm's Avatar
    How do I check / measure this?

    Posted via CB10
    If you're using any of the Android stores, search Ookla. That should give you the Ookla Speed Test. Works for cell and WiFi. (There are others, but I find this one the most accurate & consistent.)
    03-24-14 01:07 PM

Similar Threads

  1. instalation problems z30 software
    By Vitor Lucas in forum BlackBerry Z30
    Replies: 4
    Last Post: 03-23-14, 05:15 PM
  2. TechnoBuffalo's Mobile Madness Z30 vs Nexus 5; A rare encounter, FINALE!!!!
    By dildothegreat in forum Rehab & Off-Topic Lounge
    Replies: 1
    Last Post: 03-23-14, 12:33 PM
  3. Wifi not perfect
    By yeosy z10 in forum BlackBerry Z10
    Replies: 2
    Last Post: 03-23-14, 10:28 AM
  4. Vote Blackberry Z30 - Final
    By whatsever in forum BlackBerry Z10
    Replies: 1
    Last Post: 03-23-14, 10:03 AM
  5. Replies: 2
    Last Post: 03-23-14, 07:59 AM
LINK TO POST COPIED TO CLIPBOARD