1. paulwallace1234's Avatar
    I've noticed that the wifi on my new z30 is really really bad, it barely seems to pick anything up compared to my z10, anyone have bad wifi?
    Running 10.3.1.1767
    06-02-15 01:44 AM
  2. SourceCode's Avatar
    My WiFi works better than my laptop sometimes. I haven't had trouble with it so far (even through updates, etc).
    06-02-15 02:02 AM
  3. paulwallace1234's Avatar
    My WiFi works better than my laptop sometimes. I haven't had trouble with it so far (even through updates, etc).

    Damn :/ mine really is awful, picks up jack all
    06-02-15 02:10 AM
  4. 10_z_no gimmick's Avatar
    As long as I'm connected to the network and literally stuck to the router, even 1 bar will get me the job done.
    When other devices connect it becomes a fingers crossed game, some times all looks fine but still no connection, often times limited connection.
    Rebooting the router generally helps. Any how I can never be too far from it and this bugs me...

    Z30 / 10.3.1.2558
    06-02-15 02:43 AM
  5. Sukiyaki's Avatar
    It was practically perfect under 10.2.1 horrible under 10.3.1 and so so under 10.3.2

    Posted via CB10
    06-02-15 03:13 AM
  6. muindor's Avatar
    It was practically perfect under 10.2.1 horrible under 10.3.1 and so so under 10.3.2

    Posted via CB10
    Agreed apart from the 10.3.2 because I'm still on 10.3.1.2744 (Autoloaded)

    10.2.1 was a perfect OS. I feel like 10.3.1 radios suck the battery way faster too.

    06-02-15 03:32 AM
  7. shorski's Avatar
    I have been using my z30 for over a year now and I have never had WiFi issues. Never!

    Z30 STA100-2 | 10.3.BLACKBERRY
    Zeratul57 likes this.
    06-02-15 03:59 AM
  8. JamBueree's Avatar
    No WiFi issues here. It actually connects better than my laptop does. There are times when Wi-Fi on my laptop refuses to work, but would work perfectly fine on my phone.

    Posted via  Z30 STA100-2 | 10.3.2.680
    06-02-15 05:54 AM
  9. eunoia1995's Avatar
    Mine is abysmal. Sitting here on the balcony, not more than 10 feet from my router inside, drops down to two, then, one, then no reception, at all. Frustrates me to no end. As soon as I go inside, blam, ber strong signal. Grr!

    Sporting a Black Zed 30, STA 100-5, 10.3.1.1865
    06-02-15 06:06 AM
  10. Fool Guy's Avatar
    WiFi is slightly better in 10.3.1.2744 i feel, Try it.
    Though the performance is sub par if compared with other OS.
    06-02-15 06:19 AM
  11. FF22's Avatar
    I have only recently had any issues with wifi at home and I guess I can blame that on my new CenturyLink router/modem combo which is the only change in the last 3 weeks. Rarely had issues with the previous Linksys router. And the week before the CenturyLink was installed I was on vacation and easily re-connected to 3 different motel/hotel wifi systems on re-entering the premises.

    10.3.1.1784
    06-02-15 08:11 AM
  12. Polotis's Avatar
    No problems here, except sometimes in the bathroom at the far end of the apartment from the router. 5Ghz.

    Z30STA100-5/10.3.1.2582

    Bring back random taglines!
    06-02-15 08:48 AM
  13. vergiove's Avatar
    Near the wifi router 3-4 bar, on second floor I got 1-2 bar, sometimes got nothing.

    Posted by Z30
    06-02-15 09:20 AM
  14. RLTurn77's Avatar
    Have all of my devices on 2.4 and the Z30 WiFi is above average. I've been having some issues with the Z10 though which carried over from 10.2 to 10.3.

    If I connect to our other WiFi the Z10 is fine. We have some old one which I have no clue what it is, but works well with the Z10.

    Recently added 2.4 and 5. The 2.4 just goes further (sacrificing some speed supposedly). Get consistently excellent WiFi on 2.4 with the Z30 from the basement to sitting by the pool in the backyard.

    Posted via CB10
    06-02-15 09:45 AM
  15. Polotis's Avatar

    Recently added 2.4 and 5. The 2.4 just goes further (sacrificing some speed supposedly).
    I use 5 because 2.4 is really congested -- lots of networks in the building.

    Bring back random taglines!
    06-03-15 12:45 AM
  16. Zeratul57's Avatar
    WiFi on my z30 has exceeded expectations and better than other devices. I think the antenna has something to do with that. :the first thing to do is change router channel to 11 or something. Or upgrade router to a quality one. Old cheap routers are the plague of the last 15 years.

    Posted from a Passport or Z30. Get one!
    06-03-15 10:22 AM
  17. joeragan's Avatar
    WiFi is good and I am still using an 8 years old Linksys WRT54G router.

    Z30STA100-2/10.3.2.798
    06-03-15 11:11 AM
  18. RLTurn77's Avatar
    I use 5 because 2.4 is really congested -- lots of networks in the building.

    Bring back random taglines!
    Yup. In general, 2.4 will go further but is typically slower and congested. 5 doesn't have the reach in distance that 2.4 has, but is faster with little congestion.

    At my house, 2.4 isn't all that much congested and the difference between 2.4 and 5 are negligible so I happily stream music by the pool on 2.4 where I would typically have weak or no signal out back by the pool on 5.

    Posted via CB10
    Polotis likes this.
    06-03-15 11:19 AM
  19. Johnny Dollar's Avatar
    Agreed apart from the 10.3.2 because I'm still on 10.3.1.2744 (Autoloaded)

    10.2.1 was a perfect OS. I feel like 10.3.1 radios suck the battery way faster too.

    I'm having the exact opposite experience as you with 10.3.2

    BlackBerry... Now and Forever.
    06-03-15 01:08 PM
  20. paulwallace1234's Avatar
    Rather weird, this just came though, not sure but it's picking up a few more networks now
    Z30 users, what's your wifi like?-img_20150603_182211.png
    06-03-15 01:15 PM
  21. Maserati Storm's Avatar
    Ive also had my Z30 over a year , and its been pretty solid with wifi. Not much drops, sometimes faster than laptops!
    06-03-15 01:31 PM

Similar Threads

  1. BlackBerry Z30 Unlocked White
    By Israel1319 in forum Buy, Sell, Trade - Sold / Archived
    Replies: 36
    Last Post: 06-23-15, 11:58 PM
  2. A Z30 Review from an iPhone User
    By Slow Joe in forum BlackBerry Z30
    Replies: 46
    Last Post: 06-23-15, 08:31 PM
  3. Replies: 3
    Last Post: 06-02-15, 12:21 PM
  4. Is there a lock sound on the Passport like iPhone?
    By Jawad Siddiqi in forum BlackBerry Passport
    Replies: 1
    Last Post: 06-01-15, 09:22 PM
LINK TO POST COPIED TO CLIPBOARD