1. Coxwain's Avatar
    I had a big problem with my Z30.

    1st instace happened a week ago after installing Vinino through the google play store. Shortly after the screen became un responsive.

    I held down the power button to do a restart a few times and that fixed it.

    Coincidently I had replaced the screen with a so called OEM screen just 1 month ago and figured my screen was bad.

    a few days later the screen became unresponsive again and I did the restart a number of times. Didint fix it.
    I backed up the device and then restored it and that didnt fix it.

    I then went and reset the device to factory and that didnt fix it and I couldnt go through the setup sequence.

    I then removed my SIM card and did a restart and it came back to life. So I dont know if the sim card is bad or if the glitch was there?

    So the screen is fully functional and I have since restored my backup to the device. I am upset a number of the settings did not get restored such as wall paper. but I am on an ENTERPRISE server and noticed that SNAP was deleted from the device after the restore. Or maybe it wasnt backed up in the first place.

    I am going to leave SNAP off the device as google play seems to be more reliable anyway.

    the Vinino is still installed and I will leave it on for now and see how things go. I have a new sim card and havent installed it either but may do that if the problem persists.

    This could be a rare event as I didnt find much information on the internet on non responsive un cracked screens.

    I hope this helps someone.
    01-05-16 11:57 AM
  2. Dunt Dunt Dunt's Avatar
    SIM Card and Screen Responsiveness..... nope never would have tied those two together.



    I would check the connections you made when you replaced the screen before.
    FF22 likes this.
    01-05-16 12:42 PM
  3. Coxwain's Avatar
    I have had the issue return. I have rebooted and removed the sim and memory card and it didn't respond right away. But it did eventually resolve itself.

    I have not changed SIM yet. Hopefully this is a glitch that get fixed next update.
    01-17-16 03:08 PM
  4. hayman68's Avatar
    This happened today on my z30!!! Tried everything except reload software. It works and all but If a call comes in I can't answer it. I switched back to my old q10 and I have to say it's screen is more responsive then the z30 screen was when it was working for some reason. Don't notice it tell you actually use another phone.
    01-18-16 12:49 AM
  5. Coxwain's Avatar
    Did you try the restart without the sim and memory card a few times?

    Also try putting your fingernail under the right side of the screen just above the volume buttons and gently work it up and down the side of the phone . I did that too and don't know if that helps or not.
    01-18-16 05:12 AM
  6. hayman68's Avatar
    Did you try the restart without the sim and memory card a few times?

    Also try putting your fingernail under the right side of the screen just above the volume buttons and gently work it up and down the side of the phone . I did that too and don't know if that helps or not.
    Yeah tried those things too. It's like the screen is locked or something and no longer responds to touch.
    01-18-16 09:14 AM
  7. hayman68's Avatar
    Well I tried a factory reset and still its nonresponsive so I guess its toast. Don't know what I did but I did something it didn't like. Ironically I was think'n about a priv so I'll see what I can find that works.
    01-18-16 02:44 PM
  8. Coxwain's Avatar
    I was convinced its a glitch of some sort. My phone was completely unresponsive. I would get calls comming through and couldnt answer them.
    I did the factory reset and couldnt work through the setup b/c of the touch.

    Seriously, remove and keep out the SIM and SD cards. Hold the RESET botton on the top for 15-20 seconds till the Logo appears.
    Then repeat, with the two volume buttons on the side will also RESET the phone i beleive.
    Repeat a few times with the reset then add the SIM only back into the phone and do some resets again.
    Also, try someone elses sim card to see if that clears the glitch.

    Did you replace your screen recently?
    01-18-16 02:56 PM
  9. Rustybronco's Avatar
    You can take it apart again and try reseating the lone cable to the motherboard.

    1st post
    Coincidently I had replaced the screen with a so called OEM screen just 1 month ago and figured my screen was bad.
    01-18-16 03:02 PM
  10. Coxwain's Avatar
    I had the screen replaced,

    I am not sure if Hayman had his screen replaced but you are most likely right, it needs to be reseated if there was a recent replacement.
    01-18-16 03:45 PM
  11. Rustybronco's Avatar
    Sorry, I didn't realize you were the OP responding to someone else with a similar issue.
    01-18-16 04:09 PM
  12. hayman68's Avatar
    Well I gave up trying to get the Z30 back running. I went to the .... dark side and bought a Samsung S6. I figured i'd get a Priv but they don't have durable cases for it. They said with the slide out key board it was difficult to make a good case. Maybe in time BB will make another phone like the z30 running android or something.
    01-22-16 01:35 AM
  13. herbaciopereira's Avatar
    tried this. didnt work. and it is also on lockscreen ask for password. cant enter since touch screen dont work
    07-09-18 10:30 PM
  14. herbaciopereira's Avatar
    how can i retrieve my files
    07-09-18 10:32 PM
  15. FillypiMiranda's Avatar
    my touchscreen also stopped from scratch, everything works normally, except the screen. I've tried everything. Is there anything else I can do?
    09-10-20 10:05 PM

Similar Threads

  1. My Z30 and just venting.
    By cbeeches in forum BlackBerry Z30
    Replies: 9
    Last Post: 01-22-16, 10:33 AM
  2. Bricked Z30 (dead screen): Can i access the files?
    By chertik0ff in forum BlackBerry Z30
    Replies: 3
    Last Post: 01-11-16, 08:54 PM
  3. Priv screen (upper left hand side) not responding
    By dlrogers81 in forum BlackBerry Priv
    Replies: 2
    Last Post: 01-05-16, 11:11 AM
  4. Does Z30 support fast charger?
    By mien742 in forum BlackBerry Z30
    Replies: 9
    Last Post: 01-05-16, 09:55 AM
  5. buggy screen?
    By eyeb in forum BlackBerry Passport
    Replies: 2
    Last Post: 01-05-16, 08:28 AM
LINK TO POST COPIED TO CLIPBOARD